Packaging update version to 1.3.5
[platform/core/uifw/wayland-extension.git] / packaging / wayland-extension.spec
1 # to build examples
2 %define enable_examples 0
3
4 Name:           wayland-extension
5 Version:        1.3.5
6 Release:        0
7 Summary:        Wayland extenstion protocols that add functionality not available in the Wayland core protocol
8 License:        MIT
9 Group:          Graphics & UI Framework/Wayland Window System
10 URL:            http://www.tizen.org/
11 Source:         %name-%version.tar.xz
12 Source1001:     %name.manifest
13 BuildRequires:  autoconf >= 2.64, automake >= 1.11
14 BuildRequires:  libtool >= 2.2
15 BuildRequires:  pkgconfig
16 BuildRequires:  pkgconfig(wayland-server)
17 BuildRequires:  pkgconfig(wayland-client)
18
19 # requires to build examples
20 %if "%{enable_examples}" == "1"
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(ecore)
23 BuildRequires:  pkgconfig(ecore-wl2)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(libtbm)
26 BuildRequires:  pkgconfig(wayland-tbm-client)
27 # NB: It causes a circular dependency, however we have no choice
28 #     but to use the elm to build examples.
29 BuildRequires:  wayland-extension-client-devel
30 %endif
31
32 %description
33 wayland-extension contains Wayland protocols that add functionality not available in the Wayland core protocol.
34
35 %package -n libwayland-extension-client
36 Group:          Graphics & UI Framework/Wayland Window System
37 Summary:        Wayland Extension client library
38 Requires:   libwayland-client
39
40 %description -n libwayland-extension-client
41 wayland-extension is a protocol for tizen window system.
42
43 %package -n libwayland-extension-server
44 Group:          Graphics & UI Framework/Wayland Window System
45 Summary:        Wayland Extension server library
46 Requires:   libwayland-server
47
48 %description -n libwayland-extension-server
49 wayland-extension is a protocol for tizen window system.
50
51 %package -n wayland-extension-client-devel
52 Summary:        Client development files for the Wayland Extension Protocol
53 Group:          Graphics & UI Framework/Development
54 Requires:       libwayland-extension-client = %version
55
56 %description -n wayland-extension-client-devel
57 wayland-extension is a protocol for tizen window system.
58
59 This package contains all necessary include files and libraries needed
60 to develop applications that require these.
61
62 %package -n wayland-extension-server-devel
63 Summary:        Server development files for the Wayland Extension Protocol
64 Group:          Graphics & UI Framework/Development
65 Requires:       libwayland-extension-server = %version
66
67 %description -n wayland-extension-server-devel
68 wayland-extension is a protocol for tizen window system.
69
70 This package contains all necessary include files and libraries needed
71 to develop a compositor that require these.
72
73 %package -n wayland-protocols
74 Summary:        Wayland upstream protocols
75 Group:          Graphics & UI Framework/Development
76 Requires:   libwayland-client
77
78 %description -n wayland-protocols
79 wayland-protocols contains Wayland upstream protocols that add functionality not available in the Wayland core protocol
80
81
82 %prep
83 %setup -q
84 cp %{SOURCE1001} .
85
86 %build
87 export CFLAGS+=" -Wall -Werror"
88 %if "%{enable_examples}" == "1"
89    export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
90    %reconfigure --disable-static --enable-build-examples
91 %else
92    %reconfigure --disable-static
93 %endif
94 make %{?_smp_mflags}
95
96 %install
97 %make_install
98
99 %post -n libwayland-extension-client -p /sbin/ldconfig
100 %postun -n libwayland-extension-client -p /sbin/ldconfig
101 %post -n libwayland-extension-server -p /sbin/ldconfig
102 %postun -n libwayland-extension-server -p /sbin/ldconfig
103
104 %files -n libwayland-extension-client
105 %manifest %{name}.manifest
106 %license COPYING
107 %defattr(-,root,root)
108 %_libdir/*-client.so.0*
109 %if "%{enable_examples}" == "1"
110 %{_bindir}/*
111 %endif
112
113 %files -n libwayland-extension-server
114 %manifest %{name}.manifest
115 %license COPYING
116 %defattr(-,root,root)
117 %_libdir/*-server.so.0*
118
119 %files -n wayland-extension-client-devel
120 %manifest %{name}.manifest
121 %defattr(-,root,root)
122 %_includedir/wayland-extension/wayland-extension-version.h
123 %_includedir/wayland-extension/*-client-protocol.h
124 %_libdir/*-client.so
125 %_libdir/pkgconfig/*-client.pc
126
127 %files -n wayland-extension-server-devel
128 %manifest %{name}.manifest
129 %defattr(-,root,root)
130 %_includedir/wayland-extension/wayland-extension-version.h
131 %_includedir/wayland-extension/*-server-protocol.h
132 %_libdir/*-server.so
133 %_libdir/pkgconfig/*-server.pc
134
135 %files -n wayland-protocols
136 %manifest %{name}.manifest
137 %license COPYING
138 %defattr(-,root,root)
139 %_datadir/wayland-extension/protocol/stable/*
140 %_datadir/wayland-extension/protocol/unstable/*
141 %_libdir/pkgconfig/wayland-protocols.pc
142
143 %changelog