packaging: do not build if we are not in a X11 profile
[platform/upstream/videoproto.git] / packaging / videoproto.spec
1 Name:           videoproto
2 Version:        2.3.2
3 Release:        1
4 License:        MIT
5 Summary:        X
6 Url:            http://www.x.org
7 Group:          Development/System
8 Source0:        %{name}-%{version}.tar.bz2
9 Source1001:     videoproto.manifest
10
11 BuildRequires:  pkgconfig
12 BuildRequires:  pkgconfig(xorg-macros)
13
14 %if !%{with x}
15 ExclusiveArch:
16 %endif
17
18 %description
19 Description: %{summary}
20 This extension provides a protocol for a video output mechanism,
21 mainly to rescale video playback in the video controller hardware.
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28
29 %autogen --disable-static \
30              --libdir=%{_datadir} \
31              --without-xmlto
32
33 make %{?_smp_mflags}
34
35 %install
36 %make_install
37
38 %remove_docs
39
40 %files
41 %manifest %{name}.manifest
42 %license COPYING
43 %defattr(-,root,root,-)
44 %{_includedir}/X11/extensions/*.h
45 %{_datadir}/pkgconfig/*.pc