update binary
[platform/core/uifw/vc-engine-default.git] / packaging / vc-engine-default.spec
1 Name:       vc-engine-default
2 Summary:    Voice control default engine library
3 Version:    0.2.0
4 Release:    1
5 Group:      Graphics & UI Framework/Voice Framework
6 %if "%{?profile}" == "tv"
7 License:    Flora-1.1
8 %else
9 License:    Samsung proprietary
10 %endif
11 Source0:    %{name}-%{version}.tar.gz
12 Source1001: %{name}.manifest
13 BuildRequires:  cmake
14 BuildRequires:  pkgconfig(libtzplatform-config)
15
16 %description
17 Description: Voice control default engine library
18
19 %prep
20 %setup -q
21 cp %{SOURCE1001} .
22
23 %if "%{?profile}" == "tv"
24 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE -DCMAKE_PROFILE=TV
25 %else
26 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DLIBDIR=%{_libdir} -DTZ_SYS_RO_SHARE=%TZ_SYS_RO_SHARE
27 %endif
28
29 %build
30 make %{?jobs:-j%jobs}
31
32 %install
33 rm -rf %{buildroot}
34 %make_install
35 mkdir -p %{buildroot}%{TZ_SYS_RO_SHARE}/license
36 %if "%{?profile}" == "tv"
37 cp %{_builddir}/%{name}-%{version}/LICENSE_embedded %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
38 %else
39 cp %{_builddir}/%{name}-%{version}/LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
40 %endif
41
42 %files
43 %manifest vc-engine-default.manifest
44 %defattr(-,root,root,-)
45 %{TZ_SYS_RO_SHARE}/voice/vc/1.0/engine/lib*.so
46 %{TZ_SYS_RO_SHARE}/voice/vc/1.0/engine-info/vc-default-info.xml
47 %{TZ_SYS_RO_SHARE}/voice/vc/1.0/engine-data/*
48 %{TZ_SYS_RO_SHARE}/license/%{name}
49 %if "%{?profile}" != "tv"
50 %{_libdir}/libasr-nlu.so
51 %{_libdir}/libsvoiceclientdp.so
52 %{_libdir}/libsvoiceparser.so
53 %{_libdir}/libvoiceactivity.so
54 %{_libdir}/libvoice-transport.so
55 %endif