Initial import.
[profile/ivi/uxlaunch.git] / packaging / uxlaunch.spec
1 Name:       uxlaunch
2 Summary:    UX launcher daemon
3 Version:    0.64
4 Release:    1
5 Group:      System/Console
6 License:    GPLv2
7 URL:        http://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    uxlaunch.config
10 Requires(preun): systemd
11 Requires(post): systemd
12 Requires(postun): systemd
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(xau)
15 BuildRequires:  pkgconfig(dbus-1)
16 BuildRequires:  pkgconfig(systemd)
17 BuildRequires:  pam-devel
18
19
20 %description
21 Uxlaunch is a generic X session launch utility, designed to
22 quickly start X and a user desktop.
23
24
25 %package devel
26 Summary:    Headers for uxlaunch IPC
27 Group:      Development/Libraries
28 Requires:   %{name} = %{version}-%{release}
29
30 %description devel
31 Development files for uxlaunch.
32
33 %prep
34 %setup -q -n %{name}-%{version}
35
36 %build
37
38 %reconfigure --disable-static --without-ck-connector
39 make %{?jobs:-j%jobs}
40
41 %install
42 rm -rf %{buildroot}
43 mkdir -p %{buildroot}/%{_lib}/systemd/system/graphical.target.wants
44 ln -s ../uxlaunch.service %{buildroot}/%{_lib}/systemd/system/graphical.target.wants/uxlaunch.service
45 %make_install
46
47 install -D -p -m 0644 %{SOURCE1} \
48     %{buildroot}%{_sysconfdir}/sysconfig/uxlaunch
49
50 %preun
51 if [ $1 == 0 ]; then
52     systemctl stop uxlaunch.service
53 fi
54
55 %post
56 systemctl daemon-reload
57 if [ $1 == 1 ]; then
58     systemctl restart uxlaunch.service
59 fi
60
61 %postun
62 systemctl daemon-reload
63
64 %files
65 %defattr(-,root,root,-)
66 %{_sbindir}/uxlaunch
67 %config(noreplace) %{_sysconfdir}/sysconfig/uxlaunch
68 %doc %{_mandir}/man1/uxlaunch.1*
69 %{_datadir}/uxlaunch/dmi-dpi
70 /lib/systemd/system/uxlaunch.service
71 /lib/systemd/system/graphical.target.wants/uxlaunch.service
72
73 %files devel
74 %defattr(-,root,root,-)
75 %{_includedir}/uxlaunch-ipc.h
76
77 %changelog
78