fix typo in the name of the xterm config file
[profile/ivi/uxlaunch.git] / packaging / uxlaunch.spec
1 Name:       uxlaunch
2 Summary:    UX launcher daemon
3 Version:    0.64
4 Release:    1
5 Group:      System/Console
6 License:    GPLv2
7 URL:        http://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 Source1:    uxlaunch.config
10 Source2:    xterm.desktop
11 Requires(preun): systemd
12 Requires(post): systemd
13 Requires(postun): systemd
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(xau)
16 BuildRequires:  pkgconfig(dbus-1)
17 BuildRequires:  pkgconfig(systemd)
18 BuildRequires:  pam-devel
19
20
21 %description
22 Uxlaunch is a generic X session launch utility, designed to
23 quickly start X and a user desktop.
24
25
26 %package devel
27 Summary:    Headers for uxlaunch IPC
28 Group:      Development/Libraries
29 Requires:   %{name} = %{version}-%{release}
30
31 %description devel
32 Development files for uxlaunch.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38
39 %reconfigure --disable-static --without-ck-connector
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 mkdir -p %{buildroot}/%{_lib}/systemd/system/graphical.target.wants
45 ln -s ../uxlaunch.service %{buildroot}/%{_lib}/systemd/system/graphical.target.wants/uxlaunch.service
46 %make_install
47
48 install -D -p -m 0644 %{SOURCE1} \
49     %{buildroot}%{_sysconfdir}/sysconfig/uxlaunch
50
51 install -D -p -m 0644 %{SOURCE1} \
52     %{buildroot}%{_datadir}/xsessions/xterm.desktop
53
54 %preun
55 if [ $1 == 0 ]; then
56     systemctl stop uxlaunch.service
57 fi
58
59 %post
60 systemctl daemon-reload
61 if [ $1 == 1 ]; then
62     systemctl restart uxlaunch.service
63 fi
64
65 %postun
66 systemctl daemon-reload
67
68 %files
69 %defattr(-,root,root,-)
70 %{_sbindir}/uxlaunch
71 %config(noreplace) %{_sysconfdir}/sysconfig/uxlaunch
72 %doc %{_mandir}/man1/uxlaunch.1*
73 %{_datadir}/uxlaunch/dmi-dpi
74 %{_datadir}/xsessions/xterm.desktop
75 /lib/systemd/system/uxlaunch.service
76 /lib/systemd/system/graphical.target.wants/uxlaunch.service
77
78 %files devel
79 %defattr(-,root,root,-)
80 %{_includedir}/uxlaunch-ipc.h
81
82 %changelog
83