resetting manifest requested domain to floor
[platform/upstream/unifdef.git] / packaging / unifdef.spec
1 Name:           unifdef
2 Version:        2.8
3 Release:        1
4 License:        BSD
5 Summary:        Removes ifdefs from C files
6 Url:            http://dotat.at/prog/unifdef/
7 Group:          Development/Tools
8 Source:         http://dotat.at/prog/unifdef/%{name}-%{version}.tar.gz
9 Source1001:     unifdef.manifest
10
11 %description
12 Unifdef is useful for removing ifdef'ed lines from a file while otherwise
13 leaving the file alone.  Unifdef acts on #ifdef, #ifndef, #else, and #enĀ­
14 dif lines, and it knows only enough about C to know when one of these is
15 inactive because it is inside a comment, or a single or double quote.
16
17 %track
18 prog %{name} = {
19         url = http://dotat.at/prog/unifdef/
20         version = %{version}
21         regex = %{name}-(__VER__)\.tar\.gz
22 }
23
24 %prep
25 %setup -q
26 cp %{SOURCE1001} .
27
28 %build
29 make %?_smp_mflags CC=gcc CFLAGS="%{optflags}"
30
31 %install
32 make install DESTDIR=%{buildroot} prefix=%{_prefix}
33
34 %files
35 %manifest %{name}.manifest
36 %license COPYING
37 %{_bindir}/unifdef
38 %{_bindir}/unifdefall
39 %{_mandir}/man1/unifdef.1*
40 %{_mandir}/man1/unifdefall.1*
41
42 %changelog