replace vconf to dbus to listen homescreen launch signal
[platform/core/appfw/ui-gadget-1.git] / packaging / ui-gadget-1.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       ui-gadget-1
5 Summary:    UI Gadget Library
6 Version:    0.1.30
7 Release:    1
8 Group:      System/Libraries
9 License:    Apache-2.0
10 Source0:    %{name}-%{version}.tar.gz
11 Source1001:     ui-gadget-1.manifest
12 Requires(post): /sbin/ldconfig
13 Requires(postun): /sbin/ldconfig
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(appcore-efl)
16 BuildRequires:  pkgconfig(bundle)
17 BuildRequires:  pkgconfig(dlog)
18 %if %{with x}
19 BuildRequires:  pkgconfig(x11)
20 %endif
21 BuildRequires:  pkgconfig(appsvc)
22 BuildRequires:  pkgconfig(elementary)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-appfw-app-manager)
25 BuildRequires:  pkgconfig(vconf)
26 BuildRequires:  pkgconfig(dbus-glib-1)
27 BuildRequires:  cmake
28 BuildRequires:  edje-bin
29 BuildRequires: pkgconfig(libtzplatform-config)
30
31 %description
32 UI gadget library (development headers)
33
34 %package devel
35 Summary:    Development files for %{name}
36 Group:      Development/Libraries
37 Requires:   %{name} = %{version}-%{release}
38 %if %{with x}
39 Requires:  pkgconfig(x11)
40 %endif
41
42 %description devel
43 Development files for %{name}
44
45 %prep
46 %setup -q
47 cp %{SOURCE1001} .
48
49 %build
50 %cmake . \
51 -DTZ_SYS_ETC=%TZ_SYS_ETC \
52 %if %{with wayland} && !%{with x}
53 -Dwith_wayland=TRUE
54 %else
55 -Dwith_x=TRUE
56 %endif
57
58 make %{?jobs:-j%jobs}
59
60 %install
61 rm -rf %{buildroot}
62 %make_install
63 mkdir -p %{buildroot}/usr/share/license
64 install LICENSE %{buildroot}/usr/share/license/%{name}
65
66 %post
67 /sbin/ldconfig
68 ln -sf %{TZ_SYS_BIN}/ug-client %{TZ_SYS_BIN}/ug-launcher
69
70 %postun -p /sbin/ldconfig
71
72 %files
73 %manifest %{name}.manifest
74 %defattr(-,root,root,-)
75 %{_libdir}/*.so.*
76 %{_libdir}/lib%{name}-efl-engine.so
77 /usr/share/edje/ug_effect.edj
78 %{_bindir}/ug-client
79 /usr/share/edje/ug-client/*.edj
80 /usr/share/license/%{name}
81
82 %files devel
83 %manifest %{name}.manifest
84 %defattr(-,root,root,-)
85 %{_includedir}/ug-1/*.h
86 %{_libdir}/libui-gadget-1.so
87 %{_libdir}/pkgconfig/%{name}.pc
88