Remove the sim feature and deprecated vconf key
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3 %bcond_with x
4
5 Name:       ug-setting-mobileap-efl
6 Summary:    Tethering UI Gadget Library
7 Version:    0.1.166
8 Release:    1
9 Group:      TO_BE/FILLED_IN
10 License:    Flora License Version 1.0
11 Source0:    %{name}-%{version}.tar.gz
12 Requires(post): /usr/bin/vconftool
13 BuildRequires: cmake
14 BuildRequires: edje-bin
15 BuildRequires: gettext-tools
16 BuildRequires: libtzplatform-config-devel
17 BuildRequires: pkgconfig(elementary)
18 BuildRequires: pkgconfig(evas)
19 BuildRequires: pkgconfig(ui-gadget-1)
20 BuildRequires: pkgconfig(capi-network-wifi-direct)
21 BuildRequires: pkgconfig(capi-network-tethering)
22 BuildRequires: pkgconfig(capi-network-connection)
23 BuildRequires: pkgconfig(capi-network-wifi)
24 BuildRequires: pkgconfig(capi-network-bluetooth)
25 BuildRequires: pkgconfig(notification)
26 %if %{with x}
27 BuildRequires: pkgconfig(x11)
28 %endif
29
30 %description
31 Tethering UI Gadget Library
32
33 %prep
34 %setup -q
35
36 %build
37 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
38 make %{?jobs:-j%jobs}
39
40 %install
41 rm -rf %{buildroot}
42 %make_install
43
44 %post
45 GID=$(getent group %{TZ_SYS_USER_GROUP} | cut -f 3 -d :)
46 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -g $GID -f
47 /usr/bin/vconftool set -t int memory/mobile_hotspot/wifi_state 0 -g 6519 -i -f
48 mkdir -p /usr/ug/bin/
49 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-mobileap-efl
50
51 %files
52 %manifest ug-setting-mobileap-efl.manifest
53 %defattr(-,root,root,-)
54 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
55 %{_ugdir}/res/locale/*/LC_MESSAGES/*
56 %{_ugdir}/res/images/ug-setting-mobileap-efl/*.png
57 %{_ugdir}/lib/libug-setting-mobileap-efl.so
58 /usr/share/packages/ug-setting-mobileap-efl.xml
59
60 %changelog
61 * Tue Apr 09 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.162-1
62 - Maximum connection information is displayed
63 - Implement connection timer
64 - UX Change : Data usage and Connected device
65 - Change ug name & Support appsvc
66 - Translation data is updated
67
68 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
69 - Fix : The grouping of genlist item is wrong
70 - Back button position and Naviframe title visibility are changed
71 - Make grouping for genlist expanded item
72 - Editfield change is applied
73 - Ticker notification is implemented for passphrase entry
74 - Implement title slide
75 - Pop-up parent and entry's context menu allowance are changed
76
77 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
78 - Remove unrequired log
79
80 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
81 - Fix : When device is rotated, guide text is displayed short time
82 - Fix : Security / Hide items are disabled sometimes
83 - Translation data is updated
84 - Pop-up scenario for USB tethering is implemented
85 - IMF is hided by focus out
86 - Wi-Fi tethering is enabled without checking enable state
87
88 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
89 - New winset is applied and some bugs are fixed
90
91 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
92 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
93
94 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
95 - Initial package upload
96
97 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
98 - Install path is changed from /opt to /usr
99
100 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
101 - License is added
102
103 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
104 - Connection / Wi-Fi's changed CAPIs are applied
105
106 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
107 - Pop-up button's style is changed
108
109 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
110 - Add manifest file for SMACK
111
112 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
113 - When client's connection is changed, old handles are freed
114
115 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
116 - Managed APIs are used to get Network connection state and control Wi-Fi
117 - Crash issue is fixed because of "Unable to use tethering" pop-up
118 - End separator is added to each genlist
119 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
120
121 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
122 - Managed APIs are used to get Wi-Fi tethering settings
123 - Password entry issue("Enter" can be inserted) is fixed
124
125 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
126 - Unused resource is removed
127
128 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
129 - Apply White theme
130
131 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
132 - Upload pkg for ug library change
133
134 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
135 - ui-gadget-1 is applied
136 - typedef struct rule is fixed
137 - unnecessary dependency and header include are removed
138
139 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
140 - library is stripped
141
142 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
143 - "Wi-Fi tethering is not enabled" issue is fixed
144
145 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
146 - libmobile-ap is replaced with capi-network-tethering
147
148 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
149 - Data usage is got from agent
150
151 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
152 - Initialize vconf key
153 - Remove unused vconf key
154
155 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
156 - Enabled indicatons are handled
157 - Wi-Fi vconf is used to know when Wi-Fi is disabled
158 - Code clean-up
159
160 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
161 - hide option vconfkey is exported to internal vconfkeys
162
163 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
164 - "Tethering" translation data is applied
165
166 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
167 - Private vconfkey is changed following new naming rule
168
169 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
170 - Tethering and portable hotspot is changed to Tethering
171
172 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
173 - libmobile-ap API's and EFL are changed
174
175 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
176 - Deprecated dependencies are removed