de7eb777391f2c2e38d723a7bbec1e4675730018
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.160
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(wifi-direct)
19 BuildRequires: pkgconfig(capi-network-tethering)
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-network-wifi)
22 BuildRequires: pkgconfig(capi-telephony-sim)
23 BuildRequires: pkgconfig(notification)
24
25 %description
26 Tethering UI Gadget Library
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 %post
40 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
41
42 %files
43 %manifest ug-setting-mobileap-efl.manifest
44 %defattr(-,root,root,-)
45 %{_ugdir}/res/edje/ug-setting-mobile-ap-ug/*.edj
46 %{_ugdir}/res/locale/*/LC_MESSAGES/*
47 %{_ugdir}/lib/libug-setting-mobile-ap-ug.so
48
49 %changelog
50 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
51 - Remove unrequired log
52
53 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
54 - Fix : When device is rotated, guide text is displayed short time
55 - Fix : Security / Hide items are disabled sometimes
56 - Translation data is updated
57 - Pop-up scenario for USB tethering is implemented
58 - IMF is hided by focus out
59 - Wi-Fi tethering is enabled without checking enable state
60
61 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
62 - New winset is applied and some bugs are fixed
63
64 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
65 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
66
67 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
68 - Initial package upload
69
70 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
71 - Install path is changed from /opt to /usr
72
73 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
74 - License is added
75
76 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
77 - Connection / Wi-Fi's changed CAPIs are applied
78
79 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
80 - Pop-up button's style is changed
81
82 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
83 - Add manifest file for SMACK
84
85 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
86 - When client's connection is changed, old handles are freed
87
88 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
89 - Managed APIs are used to get Network connection state and control Wi-Fi
90 - Crash issue is fixed because of "Unable to use tethering" pop-up
91 - End separator is added to each genlist
92 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
93
94 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
95 - Managed APIs are used to get Wi-Fi tethering settings
96 - Password entry issue("Enter" can be inserted) is fixed
97
98 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
99 - Unused resource is removed
100
101 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
102 - Apply White theme
103
104 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
105 - Upload pkg for ug library change
106
107 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
108 - ui-gadget-1 is applied
109 - typedef struct rule is fixed
110 - unnecessary dependency and header include are removed
111
112 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
113 - library is stripped
114
115 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
116 - "Wi-Fi tethering is not enabled" issue is fixed
117
118 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
119 - libmobile-ap is replaced with capi-network-tethering
120
121 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
122 - Data usage is got from agent
123
124 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
125 - Initialize vconf key
126 - Remove unused vconf key
127
128 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
129 - Enabled indicatons are handled
130 - Wi-Fi vconf is used to know when Wi-Fi is disabled
131 - Code clean-up
132
133 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
134 - hide option vconfkey is exported to internal vconfkeys
135
136 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
137 - "Tethering" translation data is applied
138
139 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
140 - Private vconfkey is changed following new naming rule
141
142 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
143 - Tethering and portable hotspot is changed to Tethering
144
145 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
146 - libmobile-ap API's and EFL are changed
147
148 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
149 - Deprecated dependencies are removed