Merge branch 'master' into tizen_2.1
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/ug
3
4 Name:       ug-setting-mobileap-efl
5 Summary:    Tethering UI Gadget Library
6 Version:    0.1.161
7 Release:    2
8 Group:      TO_BE/FILLED_IN
9 License:    Flora License Version 1.0
10 Source0:    %{name}-%{version}.tar.gz
11 Requires(post): /usr/bin/vconftool
12 BuildRequires: cmake
13 BuildRequires: edje-bin
14 BuildRequires: gettext-tools
15 BuildRequires: pkgconfig(elementary)
16 BuildRequires: pkgconfig(evas)
17 BuildRequires: pkgconfig(ui-gadget-1)
18 BuildRequires: pkgconfig(wifi-direct)
19 BuildRequires: pkgconfig(capi-network-tethering)
20 BuildRequires: pkgconfig(capi-network-connection)
21 BuildRequires: pkgconfig(capi-network-wifi)
22 BuildRequires: pkgconfig(capi-telephony-sim)
23 BuildRequires: pkgconfig(notification)
24
25 %description
26 Tethering UI Gadget Library
27
28 %prep
29 %setup -q
30
31 %build
32 cmake . -DCMAKE_INSTALL_PREFIX="%{_ugdir}"
33 make %{?jobs:-j%jobs}
34
35 %install
36 rm -rf %{buildroot}
37 %make_install
38
39 %post
40 /usr/bin/vconftool set -t bool db/private/libug-setting-mobileap-efl/prev_wifi_status 0 -u 5000 -f
41
42 %files
43 %manifest ug-setting-mobileap-efl.manifest
44 %defattr(-,root,root,-)
45 %{_ugdir}/res/edje/ug-setting-mobile-ap-ug/*.edj
46 %{_ugdir}/res/locale/*/LC_MESSAGES/*
47 %{_ugdir}/lib/libug-setting-mobile-ap-ug.so
48
49 %changelog
50 * Fri Mar 29 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.161-2
51 - Fix : The grouping of genlist item is wrong
52 - Back button position and Naviframe title visibility are changed
53 - Make grouping for genlist expanded item
54 - Editfield change is applied
55 - Ticker notification is implemented for passphrase entry
56 - Implement title slide
57 - Pop-up parent and entry's context menu allowance are changed
58
59 * Mon Jan 28 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.160-1
60 - Remove unrequired log
61
62 * Tue Jan 15 2013 Seungyoun Ju <sy39.ju@samsung.com> 0.1.159-1
63 - Fix : When device is rotated, guide text is displayed short time
64 - Fix : Security / Hide items are disabled sometimes
65 - Translation data is updated
66 - Pop-up scenario for USB tethering is implemented
67 - IMF is hided by focus out
68 - Wi-Fi tethering is enabled without checking enable state
69
70 * Fri Dec 07 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.158-1
71 - New winset is applied and some bugs are fixed
72
73 * Mon Nov 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.157-1
74 - Cellular network state is separated to CONNECTION_CELLULAR_STATE_AVAILABLE and CONNECTION_CELLULAR_STATE_CONNECTED
75
76 * Wed Oct 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-2
77 - Initial package upload
78
79 * Mon Oct 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.156-1
80 - Install path is changed from /opt to /usr
81
82 * Thu Oct 22 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.155-1
83 - License is added
84
85 * Thu Oct 04 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.154-1
86 - Connection / Wi-Fi's changed CAPIs are applied
87
88 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.153-1
89 - Pop-up button's style is changed
90
91 * Fri Sep 21 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.152-1
92 - Add manifest file for SMACK
93
94 * Wed Aug 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.151-1
95 - When client's connection is changed, old handles are freed
96
97 * Wed Aug 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.150-1
98 - Managed APIs are used to get Network connection state and control Wi-Fi
99 - Crash issue is fixed because of "Unable to use tethering" pop-up
100 - End separator is added to each genlist
101 - Wi-Fi direct is considered when Wi-Fi tethering is enabled
102
103 * Wed Aug 01 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.149-1
104 - Managed APIs are used to get Wi-Fi tethering settings
105 - Password entry issue("Enter" can be inserted) is fixed
106
107 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-2
108 - Unused resource is removed
109
110 * Thu Jul 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.148-1
111 - Apply White theme
112
113 * Wed Jul 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-2
114 - Upload pkg for ug library change
115
116 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.147-1
117 - ui-gadget-1 is applied
118 - typedef struct rule is fixed
119 - unnecessary dependency and header include are removed
120
121 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.146-1
122 - library is stripped
123
124 * Thu Jul 12 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.145-1
125 - "Wi-Fi tethering is not enabled" issue is fixed
126
127 * Fri Jun 29 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.144-1
128 - libmobile-ap is replaced with capi-network-tethering
129
130 * Mon Jun 25 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.143-1
131 - Data usage is got from agent
132
133 * Thu Jun 04 2012 Injun Yang <injun.yang@samsung.com> 0.1.142-1
134 - Initialize vconf key
135 - Remove unused vconf key
136
137 * Thu May 31 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.141-1
138 - Enabled indicatons are handled
139 - Wi-Fi vconf is used to know when Wi-Fi is disabled
140 - Code clean-up
141
142 * Thu May 24 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.140-1
143 - hide option vconfkey is exported to internal vconfkeys
144
145 * Fri May 18 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.139-1
146 - "Tethering" translation data is applied
147
148 * Thu May 17 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.138-1
149 - Private vconfkey is changed following new naming rule
150
151 * Mon Mar 26 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.137-1
152 - Tethering and portable hotspot is changed to Tethering
153
154 * Tue Mar 14 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.135-1
155 - libmobile-ap API's and EFL are changed
156
157 * Wed Feb 06 2012 Seungyoun Ju <sy39.ju@samsung.com> 0.1.130-1
158 - Deprecated dependencies are removed