Remove unnecessary post field in spec
[apps/native/ug-mobile-ap.git] / packaging / ug-setting-mobileap-efl.spec
1 %define _usrdir /usr
2 %define _ugdir  %{_usrdir}/apps/ug-setting-mobileap-efl
3
4 Name:           ug-setting-mobileap-efl
5 Summary:        Tethering UI Gadget Library
6 Version:        1.0.146
7 Release:        1
8 Group:          App/Network
9 License:        Flora-1.1
10 Source0:        %{name}-%{version}.tar.gz
11
12 %if "%{?profile}" == "wearable"
13 ExcludeArch: %{arm} %ix86 x86_64
14 %endif
15 %if "%{?profile}" == "tv"
16 ExcludeArch: %{arm} %ix86 x86_64
17 %endif
18
19 BuildRequires:  pkgconfig(evas)
20 BuildRequires:  pkgconfig(elementary)
21 BuildRequires:  pkgconfig(ui-gadget-1)
22 BuildRequires:  pkgconfig(capi-network-wifi)
23 BuildRequires:  pkgconfig(capi-network-tethering)
24 BuildRequires:  pkgconfig(capi-network-connection)
25 BuildRequires:  pkgconfig(notification)
26 BuildRequires:  pkgconfig(aul)
27 BuildRequires:  pkgconfig(bundle)
28 BuildRequires:  pkgconfig(efl-extension)
29 BuildRequires:  pkgconfig(dpm)
30 BuildRequires:  cmake
31 BuildRequires:  edje-bin
32 BuildRequires:  gettext-tools
33 Requires(post): /usr/bin/vconftool
34
35 %description
36 Tethering UI Gadget Library
37
38 %prep
39 %setup -q
40
41 %build
42 cmake -DCMAKE_INSTALL_PREFIX="%{_ugdir}"  \
43         .
44
45 make %{?_smp_mflags}
46
47
48 %install
49 rm -rf %{buildroot}
50 %make_install
51
52 #License
53 mkdir -p %{buildroot}%{_datadir}/license
54 cp LICENSE %{buildroot}%{_datadir}/license/%{name}
55
56 %post
57
58 %files
59 %manifest ug-setting-mobileap-efl.manifest
60 %defattr(-,root,root,-)
61 /usr/ug/res/locale/*/LC_MESSAGES/ug-setting-mobileap-efl*
62 /usr/ug/res/images/ug-setting-mobileap-efl/*.png
63 %{_ugdir}/res/edje/ug-setting-mobileap-efl/*.edj
64 %{_ugdir}/res/help/ug-setting-mobileap-efl/help_setting_tethering.xml
65 %{_ugdir}/lib/ug/libug-setting-mobileap-efl.so
66 /usr/share/packages/ug-setting-mobileap-efl.xml
67 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_ChangeableColorInfo.xml
68 /usr/apps/ug-setting-mobileap-efl/shared/res/tables/ug-setting-mobileap-efl_fontInfoTable.xml
69 %{_datadir}/license/%{name}