remove S BEAM setting
[apps/home/ug-nfc-efl.git] / packaging / ug-nfc-efl.spec
1 %define _optdir /opt
2 %define _ugdir  %{_optdir}/ug
3
4
5 Name:       ug-nfc-efl
6 Summary:    UI gadget about the nfc
7 Version:    0.0.2
8 Release:    20
9 Group:      TO_BE/FILLED_IN
10 License:    Samsung Proprietary License
11 Source0:    %{name}-%{version}.tar.gz
12 Source1:    libug-setting-nfc-efl.install.in
13 Source2:    libug-share-nfc-efl.install.in
14 BuildRequires:  pkgconfig(elementary)
15 BuildRequires:  pkgconfig(ui-gadget-1)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(utilX)
19 BuildRequires:  pkgconfig(status)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-network-nfc)
22 BuildRequires:  pkgconfig(capi-content-mime-type)
23
24 BuildRequires:  cmake
25 BuildRequires:  edje-tools
26 BuildRequires:  gettext-tools
27
28 Requires(post): /sbin/ldconfig
29 Requires(post): /usr/bin/vconftool
30 Requires(postun): /sbin/ldconfig
31
32 %description
33 UI gadget about the nfc
34
35 %prep
36 %setup -q
37
38 %package devel
39 Summary:  ug for nfc setting
40 Group:    Development/Libraries
41 Requires: %{name} = %{version}-%{release}
42
43 %description devel
44 ug for nfc setting
45
46 %package -n ug-share-nfc-efl
47 Summary:  ug for nfc share
48 Group:    Development/Libraries
49 Requires(post): /sbin/ldconfig
50 Requires(post): /usr/bin/vconftool
51 Requires: %{name} = %{version}-%{release}
52
53 %description -n ug-share-nfc-efl
54 ug for nfc share
55
56
57 %build
58 mkdir cmake_tmp
59 cd cmake_tmp
60 cmake .. -DCMAKE_INSTALL_PREFIX=%{_ugdir}
61
62 make %{?jobs:-j%jobs}
63
64
65 %install
66 cd cmake_tmp
67 rm -rf %{buildroot}
68 %make_install
69
70 %post
71
72
73 %post -n ug-share-nfc-efl
74 vconftool set -t int -f db/private/ug-nfc-efl/last_file_number 0 -u 5000
75
76 %postun
77
78 %files
79 %defattr(-,root,root,-)
80 /opt/ug/lib/libug-setting-nfc-efl*
81 /opt/ug/res/locale/*/LC_MESSAGES/ug-setting-nfc-efl*
82 /opt/ug/res/icons/*
83
84 %files -n ug-share-nfc-efl
85 %defattr(-,root,root,-)
86 /opt/ug/lib/libug-share-nfc-efl*
87 /opt/ug/res/edje/*
88 /opt/ug/res/images/*
89 /opt/ug/res/locale/*/LC_MESSAGES/ug-share-nfc-efl*