Update the latest source
[apps/home/ug-nfc-efl.git] / packaging / ug-nfc-efl.spec
1 %define _optdir /opt
2 %define _ugdir  %{_optdir}/ug
3
4
5 Name:       ug-nfc-efl
6 Summary:    UI gadget about the nfc
7 Version:    0.0.2
8 Release:    17
9 Group:      TO_BE/FILLED_IN
10 License:    Samsung Proprietary License
11 Source0:    %{name}-%{version}.tar.gz
12 Source1:    libug-setting-nfc-efl.install.in
13 Source2:    libug-share-nfc-efl.install.in
14 BuildRequires:  pkgconfig(elementary)
15 BuildRequires:  pkgconfig(ui-gadget-1)
16 BuildRequires:  pkgconfig(dlog)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(utilX)
19 BuildRequires:  pkgconfig(syspopup-caller)
20 BuildRequires:  pkgconfig(capi-appfw-application)
21 BuildRequires:  pkgconfig(capi-network-nfc)
22
23 BuildRequires:  cmake
24 BuildRequires:  edje-tools
25 BuildRequires:  gettext-tools
26
27 Requires(post): /sbin/ldconfig
28 Requires(post): /usr/bin/vconftool
29 Requires(postun): /sbin/ldconfig
30
31 %description
32 UI gadget about the nfc
33
34 %prep
35 %setup -q
36
37 %package devel
38 Summary:  ug for nfc setting
39 Group:    Development/Libraries
40 Requires: %{name} = %{version}-%{release}
41
42 %description devel
43 ug for nfc setting
44
45 %package -n ug-share-nfc-efl
46 Summary:  ug for nfc share
47 Group:    Development/Libraries
48 Requires(post): /sbin/ldconfig
49 Requires(post): /usr/bin/vconftool
50 Requires: %{name} = %{version}-%{release}
51
52 %description -n ug-share-nfc-efl
53 ug for nfc share
54
55
56 %build
57 mkdir cmake_tmp
58 cd cmake_tmp
59 cmake .. -DCMAKE_INSTALL_PREFIX=%{_ugdir}
60
61 make %{?jobs:-j%jobs}
62
63
64 %install
65 cd cmake_tmp
66 rm -rf %{buildroot}
67 %make_install
68
69 %post
70
71
72 %post -n ug-share-nfc-efl
73 vconftool set -t int -f db/private/ug-nfc-efl/last_file_number 0 -u 5000
74
75 %postun
76
77 %files
78 %defattr(-,root,root,-)
79 /opt/ug/lib/libug-setting-nfc-efl*
80 /opt/ug/res/locale/*/LC_MESSAGES/ug-setting-nfc-efl*
81 /opt/ug/res/icons/*
82
83 %files -n ug-share-nfc-efl
84 %defattr(-,root,root,-)
85 /opt/ug/lib/libug-share-nfc-efl*
86 /opt/ug/res/edje/*
87 /opt/ug/res/images/*
88 /opt/ug/res/locale/*/LC_MESSAGES/ug-share-nfc-efl*