Tizen 2.1 base
[apps/native/ug-bluetooth-efl.git] / packaging / ug-bluetooth-efl.spec
1 %define _optdir /opt
2 %define _usrdir /usr
3 %define _ugdir  %{_usrdir}/ug
4
5 Name:       ug-bluetooth-efl
6 Summary:    UI gadget about the bluetooth
7 Version:    0.2.141
8 Release:    2
9 Group:      TO_BE/FILLED_IN
10 License:    Flora Software License
11 Source0:    %{name}-%{version}.tar.gz
12 Requires(post): vconf
13 Requires(post): coreutils
14 BuildRequires: cmake
15 BuildRequires: edje-tools
16 BuildRequires: gettext-tools
17 BuildRequires: pkgconfig(elementary)
18 BuildRequires: pkgconfig(bundle)
19 BuildRequires: pkgconfig(ui-gadget-1)
20 BuildRequires: pkgconfig(dlog)
21 BuildRequires: pkgconfig(vconf)
22 BuildRequires: pkgconfig(edbus)
23 BuildRequires: pkgconfig(evas)
24 BuildRequires: pkgconfig(edje)
25 BuildRequires: pkgconfig(ecore)
26 BuildRequires: pkgconfig(eina)
27 BuildRequires: pkgconfig(aul)
28 BuildRequires: pkgconfig(appcore-efl)
29 BuildRequires: pkgconfig(syspopup-caller)
30 BuildRequires: pkgconfig(capi-network-bluetooth)
31 BuildRequires: pkgconfig(capi-network-connection)
32 BuildRequires: pkgconfig(dbus-glib-1)
33
34 %description
35 UI gadget about the bluetooth
36
37 %prep
38 %setup -q
39
40 %build
41 LDFLAGS="$LDFLAGS -Wl,-z -Wl,nodelete"
42 export LDFLAGS
43 cmake . -DCMAKE_INSTALL_PREFIX=%{_ugdir}
44
45 make %{?jobs:-j%jobs}
46
47 %post
48 vconftool set -tf int file/private/libug-setting-bluetooth-efl/visibility_time "0" -g 6520
49 mkdir -p /usr/ug/bin/
50 ln -sf /usr/bin/ug-client /usr/ug/bin/setting-bluetooth-efl
51
52 %install
53 rm -rf %{buildroot}
54 %make_install
55
56 %files
57 %manifest ug-bluetooth-elf.manifest
58 %defattr(-,root,root,-)
59 %{_ugdir}/res/locale/*/LC_MESSAGES/*
60 %{_ugdir}/res/images/ug-setting-bluetooth-efl/*
61 %{_ugdir}/lib/libug-setting-bluetooth-efl.so.0.1.0
62 %{_ugdir}/lib/libug-setting-bluetooth-efl.so
63 %{_usrdir}/share/packages/ug-bluetooth-efl.xml
64