thor: fix invalid larger device descriptor than requested
[profile/mobile/platform/kernel/u-boot-tm1.git] / packaging / u-boot-tm1.spec
1 Name: u-boot-sprd
2 Summary: Bootloader for Embedded boards based on ARM processor
3 Version: 2010.12
4 Release: 0
5 Group: System/Kernel
6 License: GPL-2.0+
7 ExclusiveArch: %{arm}
8 URL: http://www.denx.de/wiki/U-Boot
9 Source0: %{name}-%{version}.tar.bz2
10 Source1001: packaging/u-boot-tm1.manifest 
11
12 %description
13 bootloader for Embedded boards based on ARM processor
14
15 %package -n u-boot-tm1
16 Summary: A bootloader for Embedded system
17 Group: System/Kernel
18
19 %description -n u-boot-tm1
20 A boot loader for embedded systems.
21 Das U-Boot is a cross-platform bootloader for embedded systems,
22 used as the default boot loader by several board vendors.  It is
23 intended to be easy to port and to debug, and runs on many
24 supported architectures, including PPC, ARM, MIPS, x86, m68k, NIOS,
25 and Microblaze.
26
27 %ifarch %{arm}
28 %global use_mmc_storage 1
29 %endif
30
31 %prep
32 %setup -q
33
34 %build
35 %{?asan:/usr/bin/gcc-unforce-options}
36 cp %{SOURCE1001} .
37 make distclean
38 make tizen_tm1_config
39
40 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true tools
41
42 %if 1%{?use_mmc_storage}
43 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" CONFIG_ENV_IS_IN_MMC=y env
44 %else
45 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" env
46 %endif
47
48 export PATH="$PATH:tools"
49 make %{?_smp_mflags} EXTRAVERSION=`echo %{vcs} | sed 's/.*u-boot.*#\(.\{9\}\).*/-g\1-TIZEN.org/'`
50
51 # Sign u-boot-multi.bin - output is: u-boot-mmc.bin
52 chmod 755 tools/mkimage_signed.sh
53 mkimage_signed.sh u-boot.bin "tizen_tm1"
54
55 %install
56 rm -rf %{buildroot}
57
58 # u-boot installation
59 mkdir -p %{buildroot}/boot/u-boot
60 install -d %{buildroot}/boot/u-boot
61 install -m 755 u-boot.bin %{buildroot}/boot/u-boot
62 install -m 755 u-boot-mmc.bin %{buildroot}/boot/u-boot
63
64 %clean
65
66 %files -n u-boot-tm1
67 %manifest u-boot-tm1.manifest
68 %defattr(-,root,root,-)
69 /boot/u-boot