First tlm release
[platform/core/system/tlm.git] / packaging / tlm.spec
1 # enable debug features such as control environment variables
2 # WARNING! do not use for production builds as it will break security
3 %define debug_build 0
4
5 Name: tlm
6 Summary: Login manager for Tizen
7 Version: 0.0.1
8 Release: 1
9 Group: System/Daemons
10 License: LGPL-2.1+
11 Source: %{name}-%{version}.tar.gz
12 URL: https://github.com/01org/tlm
13 Source1001:     %{name}.manifest
14 Requires(post): /sbin/ldconfig
15 Requires(postun): /sbin/ldconfig
16 BuildRequires: pkgconfig(gtk-doc)
17 BuildRequires: pkgconfig(glib-2.0) >= 2.30
18 BuildRequires: pkgconfig(gobject-2.0)
19 BuildRequires: pkgconfig(gio-2.0)
20 BuildRequires: pkgconfig(gio-unix-2.0)
21 BuildRequires: pkgconfig(gmodule-2.0)
22 BuildRequires: pkgconfig(libgum)
23 BuildRequires: pkgconfig(elementary)
24 BuildRequires: pam-devel
25
26 %description
27 %{summary}.
28
29
30 %package devel
31 Summary:    Development files for %{name}
32 Group:      Development/Libraries
33 Requires:   %{name} = %{version}-%{release}
34
35
36 %description devel
37 %{summary}.
38
39
40 %package doc
41 Summary:    Documentation files for %{name}
42 Group:      Development/Libraries
43 Requires:   %{name} = %{version}-%{release}
44
45
46 %description doc
47 %{summary}.
48
49
50 %prep
51 %setup -q -n %{name}-%{version}
52
53
54 %build
55 %if %{debug_build} == 1
56 %configure --enable-gum --enable-gtk-doc --enable-examples --enable-debug
57 %else
58 %configure --enable-gum --enable-gtk-doc --enable-examples
59 %endif
60
61
62 make %{?_smp_mflags}
63
64
65 %install
66 rm -rf %{buildroot}
67 %make_install
68 cp -a %{SOURCE1001} %{buildroot}%{_datadir}/%{name}.manifest
69
70
71 %post
72 /sbin/ldconfig
73
74
75 %postun -p /sbin/ldconfig
76
77
78 %files
79 %defattr(-,root,root,-)
80 %manifest %{_datadir}/%{name}.manifest
81 %doc AUTHORS COPYING INSTALL NEWS README
82 %{_bindir}/%{name}
83 %{_libdir}/lib%{name}*.so.*
84 %{_libdir}/%{name}/plugins/*.so*
85 %config(noreplace) %{_sysconfdir}/tlm.conf
86
87
88 %files devel
89 %defattr(-,root,root,-)
90 %{_includedir}/%{name}/*.h
91 %{_libdir}/lib%{name}*.so
92 %{_libdir}/pkgconfig/%{name}.pc
93 %{_bindir}/tlm-ui
94
95
96 %files doc
97 %defattr(-,root,root,-)
98 %{_datadir}/gtk-doc/html/tlm/*