Clean spec file
[platform/core/system/tizen-platform-config.git] / packaging / tizen-platform-config.spec
1 %define libname libtzplatform-config
2
3 Name:           tizen-platform-config
4 Version:        1.0
5 Release:        0
6 Summary:        Tizen Platform Configuration
7 License:        MIT
8 Url:            http://www.tizen.org
9 Group:          System/Configuration
10 Source0:        %{name}-%{version}.tar.gz
11 Source1:        %{name}-rpmlintrc
12 Source1001:     %{name}.manifest
13 BuildRequires:  tizen-platform-wrapper
14
15 # the main package only contains a config file but other dependent packages 
16 # will contain binary. So, we can't build a noarch package and have to avoid 
17 # a rpmlint warning using a filter in xxx-rpmlintrc
18
19 %description
20 Tizen Platform Configuration - variables definitions
21
22 %package -n %{libname}
23 Summary:        Tizen Platform Configuration - helper library
24 Group:          System/Libraries
25 License:        LGPL-2.0
26 Requires:       %{name} = %{version}
27 %description -n %{libname}
28 Tizen Platform Configuration - helper library to lookup Tizen variables easily
29
30 %package -n %{libname}-devel
31 Summary:        Tizen Platform Configuration - helper libray headers, RPM macros
32 Group:          Development/Libraries
33 License:        LGPL-2.0
34 Requires:       %{libname} = %{version}
35 %description -n %{libname}-devel
36 Tizen Platform Configuration - helper library headers to include in source code, RPM macros to call in spec files
37
38 %package -n %{name}-tools
39 Summary:        Tizen Platform Configuration - tools
40 Group:          System/Utilities
41 License:        LGPL-2.0
42 Requires:       %{libname} = %{version}
43 %description -n %{name}-tools
44 Tizen Platform Configuration - helper program to lookup Tizen variables easily
45
46 %prep
47 %setup -q
48 cp %{SOURCE1001} .
49
50 %build
51 %reconfigure \
52     --disable-static
53
54 make %{?_smp_mflags}
55
56 %check
57 make check
58
59 %install
60 %make_install
61
62 %post -n %{libname} -p /sbin/ldconfig
63
64 %postun -n %{libname} -p /sbin/ldconfig
65
66 %files
67 %manifest %{name}.manifest
68 %license MIT
69 %config %{_sysconfdir}/tizen-platform.conf
70
71 %files -n %{libname}
72 %manifest %{name}.manifest
73 %{_libdir}/*.so.*
74
75 %files -n %{libname}-devel
76 %manifest %{name}.manifest
77 %license LGPL_2.0
78 %{_libdir}/*.so
79 %{_libdir}/pkgconfig/*.pc
80 %{_includedir}/*.h
81 %config %{_sysconfdir}/rpm/macros.tizen-platform
82
83 %files -n %{name}-tools
84 %manifest %{name}.manifest
85 %{_bindir}/*