Fix for 64-bit build compatibility
[platform/core/telephony/telephony-daemon.git] / packaging / telephony-daemon.spec
1 %define major 1
2 %define minor 3
3 %define patchlevel 24
4
5 Name:           telephony-daemon
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        1
8 License:        Apache
9 Summary:        Telephony Daemon
10 Group:          System/Telephony
11 Source0:        %{name}-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(glib-2.0)
15 BuildRequires:  pkgconfig(tcore)
16 BuildRequires:  pkgconfig(vconf)
17 Requires(post):           sys-assert
18
19 %description
20 Description: Telephony Daemon
21
22 %prep
23 %setup -q
24
25 %build
26 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
27         -DLIB_INSTALL_DIR=%{_libdir} \
28         -DVERSION=%{version} \
29         -DTIZEN_DEBUG_ENABLE=1 \
30
31 make %{?_smp_mflags}
32
33 %install
34
35 %make_install
36 mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
37 ln -s %{_libdir}/systemd/system/telephony-daemon.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/telephony-daemon.service
38
39 %post -p /sbin/ldconfig
40
41 %files
42 %manifest telephony-daemon.manifest
43 %defattr(-,root,root,-)
44 %{_bindir}/telephony-daemon
45 %attr(644,root,root) %{_libdir}/systemd/system/telephony-daemon.service
46 %attr(644,root,root) %{_libdir}/systemd/system/multi-user.target.wants/telephony-daemon.service
47 %{_datadir}/license/telephony-daemon