567e240180ee04ebe376d67249016fc56bc6e813
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 23
4
5 Name:           tel-plugin-vmodem
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        1
8 License:        Apache-2.0
9 Summary:        Telephony AT Virtual Modem library
10 Group:          System/Libraries
11 Source0:        tel-plugin-vmodem-%{version}.tar.gz
12
13 %if %{_with_emulator}
14 %else
15 ExcludeArch: %{arm} aarch64
16 %endif
17
18 BuildRequires:  cmake
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(dlog)
21 BuildRequires:  pkgconfig(tcore)
22 Requires(post): /sbin/ldconfig
23 Requires(postun): /sbin/ldconfig
24
25 %description
26 Telephony AT Modem library
27
28 %prep
29 %setup -q
30
31 %build
32 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
33 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
34         -DLIB_INSTALL_DIR=%{_libdir} \
35         -DVERSION=$versionint
36 make %{?_smp_mflags}
37
38 %post
39 /sbin/ldconfig
40
41 %postun -p /sbin/ldconfig
42
43 %install
44 %make_install
45 mkdir -p %{buildroot}/usr/share/license
46
47 %files
48 %manifest tel-plugin-vmodem.manifest
49 %defattr(644,system,system,-)
50 #%doc COPYING
51 %{_libdir}/telephony/plugins/vmodem-plugin*
52 /usr/share/license/tel-plugin-vmodem