Code Sync up from tizen_2.4
[platform/core/telephony/tel-plugin-vmodem.git] / packaging / tel-plugin-vmodem.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 18
4
5 Name:           tel-plugin-vmodem
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        1
8 License:        Apache
9 Summary:        Telephony AT Virtual Modem library
10 Group:          System/Libraries
11 Source0:        tel-plugin-vmodem-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(tcore)
16 Requires(post): /sbin/ldconfig
17 Requires(postun): /sbin/ldconfig
18
19 %description
20 Telephony AT Modem library
21
22 %prep
23 %setup -q
24
25 %build
26 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
27 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DVERSION=$versionint
28 make %{?_smp_mflags}
29
30 %post
31 /sbin/ldconfig
32
33 %postun -p /sbin/ldconfig
34
35 %install
36 %make_install
37 mkdir -p %{buildroot}/usr/share/license
38
39 %files
40 %manifest tel-plugin-vmodem.manifest
41 %defattr(-,root,root,-)
42 #%doc COPYING
43 %{_libdir}/telephony/plugins/vmodem-plugin*
44 /usr/share/license/tel-plugin-vmodem