sync with private git
[framework/telephony/tel-plugin-vconf.git] / packaging / tel-plugin-vconf.spec
1 #sbs-git:slp/pkgs/t/tel-plugin-vconf
2 Name:       tel-plugin-vconf
3 Summary:    Telephony Vconf storage plugin
4 Version: 0.1.15
5 Release:    1
6 Group:      System/Libraries
7 License:    Apache
8 Source0:    tel-plugin-vconf-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(postun): /sbin/ldconfig
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(vconf)
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(gthread-2.0)
15 BuildRequires:  pkgconfig(tcore)
16 BuildRequires:  pkgconfig(dlog)
17
18 %description
19 Telephony Vconf storage plugin
20
21 %prep
22 %setup -q
23
24 %build
25 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
26 make %{?jobs:-j%jobs}
27
28 %post
29 /sbin/ldconfig
30
31 #Default Call Statistics
32 vconftool set -t int db/dnet/statistics/cellular/totalsnt 0 -i -f
33 vconftool set -t int db/dnet/statistics/cellular/totalrcv 0 -i -f
34 vconftool set -t int db/dnet/statistics/cellular/lastsnt 0 -i -f
35 vconftool set -t int db/dnet/statistics/cellular/lastrcv 0 -i -f
36
37 ##setting vconf key##
38 vconftool set -t int memory/dnet/state 0 -i
39 vconftool set -t int memory/dnet/cellular 4 -i
40 vconftool set -t int memory/telephony/svc_type 0 -i -f
41 vconftool set -t int memory/telephony/ps_type 0 -i -f
42 vconftool set -t int memory/telephony/rssi 0 -i -f
43 vconftool set -t int memory/telephony/sim_slot 0 -i -f
44 vconftool set -t int memory/telephony/svc_roam 0 -i -f
45 vconftool set -t int memory/telephony/event_system_ready 0 -i -f
46 vconftool set -t int memory/telephony/plmn 0 -i -f
47 vconftool set -t int memory/telephony/lac 0 -i -f
48 vconftool set -t int memory/telephony/cell_id 0 -i -f
49 vconftool set -t int memory/telephony/svc_cs 0 -i -f
50 vconftool set -t int memory/telephony/svc_ps 0 -i -f
51 vconftool set -t int memory/telephony/zone_type 0 -i -f
52 vconftool set -t int memory/telephony/sim_init 0 -i -f
53 vconftool set -t int memory/telephony/sim_chv 255
54 vconftool set -t int memory/telephony/pb_init 0 -i -f
55 vconftool set -t int memory/telephony/call_state 0 -i -f
56 vconftool set -t int memory/telephony/call_forward_state 0 -i -f
57 vconftool set -t int memory/telephony/tapi_state 0 -i -f
58 vconftool set -t int memory/telephony/spn_disp_condition 0 -i -f
59 vconftool set -t int memory/telephony/sat_idle 0 -i -f
60 vconftool set -t int memory/telephony/sat_state 0 -i -f
61 vconftool set -t int memory/telephony/zuhause_zone 0 -i -f
62 vconftool set -t int memory/telephony/low_battery 0 -i -f
63 vconftool set -t string memory/telephony/idle_text "" -i -f
64 vconftool set -t string memory/telephony/spn "" -i -f
65 vconftool set -t string memory/telephony/nw_name "" -i -f
66 vconftool set -t string memory/telephony/imei "" -i -f
67 vconftool set -t string memory/telephony/szSubscriberNumber "" -i -f
68 vconftool set -t string memory/telephony/szSubscriberAlpha "" -i -f
69 vconftool set -t string memory/telephony/szSWVersion "" -i -f
70 vconftool set -t string memory/telephony/szHWVersion "" -i -f
71 vconftool set -t string memory/telephony/szCalDate "" -i -f
72 vconftool set -t string memory/telephony/productCode "" -i -f
73 vconftool set -t string db/private/tel-plugin-vconf/imsi "" -f
74 vconftool set -t int db/telephony/emergency 0 -i -f
75 vconftool set -t bool memory/telephony/telephony_ready 0 -i -f
76
77 %postun -p /sbin/ldconfig
78
79 %install
80 rm -rf %{buildroot}
81 %make_install
82
83 %files
84 %defattr(-,root,root,-)
85 #%doc COPYING
86 %{_libdir}/telephony/plugins/vconf-plugin*