4f238adabb558e89a79d740b7b824e9ebce6dbfc
[platform/core/telephony/tel-plugin-manager.git] / packaging / tel-plugin-manager.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 1
4
5 Name:           tel-plugin-manager
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        2
8 License:        Apache
9 Summary:        Manager for telephony
10 Group:          System/Libraries
11 Source0:        %{name}-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(glib-2.0)
14 BuildRequires:  pkgconfig(libtzplatform-config)
15 BuildRequires:  pkgconfig(libxml-2.0)
16 BuildRequires:  pkgconfig(tcore)
17 BuildRequires:  pkgconfig(vconf)
18 BuildRequires:  pkgconfig(openssl)
19 BuildRequires:  pkgconfig(tfeature)
20 BuildRequires:  pkgconfig(cynara-client)
21 BuildRequires:  pkgconfig(cynara-session)
22
23 Requires(post): /sbin/ldconfig
24 Requires(postun): /sbin/ldconfig
25
26 %description
27 Manager for telephony
28
29 %prep
30 %setup -q
31
32 %build
33 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
34
35 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
36         -DVERSION=$versionint \
37         -DSYSCONFDIR=%{_sysconfdir} \
38         -DLIB_INSTALL_DIR=%{_libdir} \
39 %if 0%{?sec_product_feature_network_dsds}
40     -DFEATURE_MULTISIM=1 \
41 %endif
42 %if 0%{?sec_product_feature_profile_wearable}
43     -DWEARABLE=1 \
44 %endif
45
46 make %{?_smp_mflags}
47
48 %postun -p /sbin/ldconfig
49
50 %install
51 %make_install
52 mkdir -p %{buildroot}%{_datadir}/license
53
54 %files
55 %manifest tel-plugin-manager.manifest
56 %defattr(644,root,root,-)
57 #%doc COPYING
58 %{_libdir}/telephony/plugins/*
59 %{_datadir}/license/tel-plugin-manager