ab103b0b85a6497d8c41ab7c06aad625ce413d3e
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 62
4
5 Name:           tel-plugin-indicator
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        5
8 License:        Apache-2.0
9 Summary:        Telephony Indicator plugin
10 Group:          System/Libraries
11 Source0:        tel-plugin-indicator-%{version}.tar.gz
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(deviced)
14 BuildRequires:  pkgconfig(dlog)
15 BuildRequires:  pkgconfig(glib-2.0)
16 BuildRequires:  pkgconfig(vconf)
17 BuildRequires:  pkgconfig(tcore)
18 Requires(post): /sbin/ldconfig
19 Requires(postun): /sbin/ldconfig
20
21 %description
22 Telephony Indicator plugin
23
24 %prep
25 %setup -q
26
27 %build
28 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
29
30 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
31         -DLIB_INSTALL_DIR=%{_libdir} \
32         -DVERSION=$versionint \
33
34 make %{?_smp_mflags}
35
36 %post
37 /sbin/ldconfig
38
39 ##setting vconf key##
40 vconftool set -t bool memory/testmode/fast_dormancy 0 -i -f -s telephony_framework::vconf
41 vconftool set -t bool memory/testmode/fast_dormancy2 0 -i -f -s telephony_framework::vconf
42
43 %postun -p /sbin/ldconfig
44
45 %install
46 %make_install
47 mkdir -p %{buildroot}/usr/share/license
48 cp LICENSE %{buildroot}/usr/share/license/%{name}
49
50 %files
51 %manifest tel-plugin-indicator.manifest
52 %defattr(-,root,root,-)
53 %{_libdir}/telephony/plugins/indicator-plugin*
54 /usr/share/license/%{name}