Modify uid/gid from system to root
[platform/core/telephony/tel-plugin-indicator.git] / packaging / tel-plugin-indicator.spec
1 %define major 0
2 %define minor 1
3 %define patchlevel 70
4
5 Name:           tel-plugin-indicator
6 Version:        %{major}.%{minor}.%{patchlevel}
7 Release:        5
8 License:        Apache-2.0
9 Summary:        Telephony Indicator plugin
10 Group:          System/Libraries
11 Source0:        tel-plugin-indicator-%{version}.tar.gz
12
13 %if "%{profile}" == "tv"
14 ExcludeArch: %{arm} %ix86 x86_64
15 %endif
16
17 BuildRequires:  cmake
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(glib-2.0)
20 BuildRequires:  pkgconfig(tcore)
21 Requires(post): /sbin/ldconfig
22 Requires(postun): /sbin/ldconfig
23
24 %description
25 Telephony Indicator plugin
26
27 %prep
28 %setup -q
29
30 %build
31 versionint=$[%{major} * 1000000 + %{minor} * 1000 + %{patchlevel}]
32
33 %cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
34         -DLIB_INSTALL_DIR=%{_libdir} \
35         -DVERSION=$versionint \
36
37 make %{?_smp_mflags}
38
39 %post
40 /sbin/ldconfig
41
42 %postun -p /sbin/ldconfig
43
44 %install
45 %make_install
46 mkdir -p %{buildroot}/usr/share/license
47 cp LICENSE %{buildroot}/usr/share/license/%{name}
48
49 %files
50 %manifest tel-plugin-indicator.manifest
51 %defattr(644,root,root,-)
52 %{_libdir}/telephony/plugins/indicator-plugin*
53 /usr/share/license/%{name}