Initial refactoring merge
[platform/core/telephony/tel-plugin-database.git] / packaging / tel-plugin-database.spec
1 %define major 3
2 %define minor 0
3 %define patchlevel 1
4
5 Name: tel-plugin-database
6 Summary: Telephony DataBase storage plugin
7 Version:    %{major}.%{minor}.%{patchlevel}
8 Release:    1
9 Group:      System/Libraries
10 License:    Apache-2.0
11 Source0:    tel-plugin-database-%{version}.tar.gz
12 Source1001:     tel-plugin-database.manifest
13 Requires(post): /sbin/ldconfig
14 Requires(postun): /sbin/ldconfig
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(glib-2.0)
17 BuildRequires:  pkgconfig(tcore)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(db-util)
20
21 %description
22 Telephony DataBase storage plugin
23
24 %prep
25 %setup -q
26 cp %{SOURCE1001} .
27
28 %build
29 %cmake .
30 make %{?jobs:-j%jobs}
31
32 %post
33 /sbin/ldconfig
34
35 %postun -p /sbin/ldconfig
36
37 %install
38 %make_install
39 mkdir -p %{buildroot}/usr/share/license
40 cp LICENSE %{buildroot}/usr/share/license/%{name}
41
42 %files
43 %manifest %{name}.manifest
44 %defattr(-,root,root,-)
45 %{_libdir}/telephony/plugins/db-plugin*
46 /usr/share/license/%{name}