25d7152c42f40094d6ffd1dad558a08f95727d80
[platform/core/telephony/tel-plugin-atdongle.git] / packaging / tel-plugin-atdongle.spec
1 Name:           tel-plugin-atdongle
2 Summary:        AT dongle plugin for telephony
3 Version:        0.1.37
4 Release:        1
5 Group:          Development/Libraries
6 License:        Apache-2.0
7 Source0:        tel-plugin-atdongle-%{version}.tar.gz
8 Requires(post): /sbin/ldconfig
9 Requires(postun):/sbin/ldconfig
10 BuildRequires:  cmake
11 BuildRequires:  pkgconfig(glib-2.0)
12 BuildRequires:  pkgconfig(tcore)
13 BuildRequires:  pkgconfig(dlog)
14 BuildRequires:  pkgconfig(vconf)
15 BuildRequires:  pkgconfig(key-manager)
16
17 %if "%{?_repository}" == "emulator"
18 ExcludeArch: %{arm} %ix86 x86_64
19 %endif
20
21 %description
22 AT dongle plugin for telephony
23
24 %prep
25 %setup -q
26
27 %build
28 %cmake .
29 make %{?jobs:-j%jobs}
30
31 %post
32 /sbin/ldconfig
33
34 %postun -p /sbin/ldconfig
35
36 %install
37 rm -rf %{buildroot}
38 %make_install
39
40 %files
41 %manifest tel-plugin-atdongle.manifest
42 %defattr(-,root,root,-)
43 %{_libdir}/telephony/plugins/modems/*
44 %license LICENSE