license:change test-runner's license from Apache 2.0 to BSD-2-clause
[platform/upstream/systemd.git] / packaging / systemd.spec
1 # "enable foo" will turn into --enable-foo or --disable-foo
2 # depending "with_foo" macro
3 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
4
5 %define WITH_RANDOMSEED 0
6 %define WITH_BASH_COMPLETION 0
7 %define WITH_ZSH_COMPLETION 0
8 %define WITH_COREDUMP 0
9 %define WITH_BACKLIGHT 0
10 %define WITH_TIMEDATED 0
11 %define WITH_RFKILL 0
12 %define with_multiuser 1
13 %define WITH_MACHINED 0
14 %define WITH_DOC 0
15
16 Name:           systemd
17 Version:        231
18 Release:        0%{?release_flags}
19 # For a breakdown of the licensing, see README
20 License:        LGPL-2.1+ and GPL-2.0+
21 Summary:        A System and Service Manager
22 Url:            http://www.freedesktop.org/wiki/Software/systemd
23 Group:          Base/Startup
24 Source0:        https://github.com/systemd/systemd/archive/v%{version}.tar.gz
25 Source1:        pamconsole-tmp.conf
26 Source2:        %{name}-rpmlintrc
27 Source3:        500.systemd_upgrade.sh
28 Source4:        test-runner.c
29 Source1001:     systemd.manifest
30 BuildRequires:  gperf
31 BuildRequires:  intltool >= 0.40.0
32 BuildRequires:  libacl-devel
33 BuildRequires:  libblkid-devel >= 2.20
34 BuildRequires:  libcap-devel
35 BuildRequires:  libgcrypt-devel
36 BuildRequires:  libkmod-devel >= 14
37 %if %{?WITH_DOC}
38 BuildRequires:  xsltproc
39 BuildRequires:  docbook-xsl-stylesheets
40 %endif
41 BuildRequires:  pam-devel
42 BuildRequires:  pkgconfig
43 # BuildRequires:  pkgconfig(dbus-1)     # for remove circular dependency on OBS
44 BuildRequires:  pkgconfig(glib-2.0)
45 BuildRequires:  pkgconfig(liblzma)
46 BuildRequires:  pkgconfig(libkmod)
47 BuildRequires:  pkgconfig(mount)
48 # Requires:       dbus                  # for remove circular dependency on OBS
49 Requires:       filesystem
50 Requires(post): coreutils
51 Requires(post): gawk
52 Requires(pre):  coreutils
53 Requires(pre):  /usr/bin/getent
54 Requires(pre):  /usr/sbin/groupadd
55
56 Obsoletes:      SysVinit < 2.86-24
57 Obsoletes:      sysvinit < 2.86-24
58 Provides:       SysVinit = 2.86-24
59 Provides:       sysvinit = 2.86-24
60 Provides:       /bin/systemctl
61 Provides:       /sbin/shutdown
62 Provides:       udev = %{version}
63 Obsoletes:      udev < 183
64
65 %description
66 systemd is a system and service manager for Linux, compatible with
67 SysV and LSB init scripts. systemd provides aggressive parallelization
68 capabilities, uses socket and D-Bus activation for starting services,
69 offers on-demand starting of daemons, keeps track of processes using
70 Linux cgroups, supports snapshotting and restoring of the system
71 state, maintains mount and automount points and implements an
72 elaborate transactional dependency-based service control logic. It can
73 work as a drop-in replacement for sysvinit.
74
75 %package -n libsystemd
76 License:        LGPL-2.1+
77 Summary:        Systemd libraries
78 Group:          Base/Startup
79 Obsoletes:      libudev < 183
80 Provides:       libudev = %{version}
81 Obsoletes:      systemd < 185-4
82 Conflicts:      systemd < 185-4
83
84 %description -n libsystemd
85 Libraries for systemd and udev, as well as the systemd PAM module.
86
87 %package devel
88 License:        LGPL-2.1+
89 Summary:        Development headers for systemd
90 Requires:       %{name} = %{version}
91 Requires:               libsystemd = %{version}
92 Provides:       libudev-devel = %{version}
93 Obsoletes:      libudev-devel < 183
94
95 %description devel
96 Development headers and auxiliary files for developing applications for systemd.
97
98 %package analyze
99 License:        LGPL-2.1+
100 Summary:        Tool for processing systemd profiling information
101 Requires:       %{name} = %{version}
102 Obsoletes:      systemd < 38-5
103
104 %description analyze
105 'systemd-analyze blame' lists which systemd unit needed how much time to finish
106 initialization at boot.
107 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
108 at boot.
109
110 %package tests
111 License:        LGPL-2.1+ and BSD-2-Clause
112 Summary:        Set of tests for sd-bus component
113 Requires:       %{name} = %{version}
114
115 %description tests
116 This package is part of 'dbus-integratnion-tests' framework and contains set of tests
117 for sd-bus component (DBUS API C library).
118
119 %package extension-kdbus
120 Summary:        Extension for systemd to support KDBUS in Tizen
121 Requires:       %{name} = %{version}-%{release}
122
123 %description extension-kdbus
124 This modifies systemd to support KDBUS in Tizen.
125
126 %prep
127 %setup -q
128 cp %{SOURCE1001} .
129 cp %{SOURCE4} .
130
131 %build
132 %autogen
133 %configure \
134         --enable-kdbus \
135 %if ! %{WITH_RANDOMSEED}
136         --disable-randomseed \
137 %endif
138 %if ! %{?WITH_COREDUMP}
139         --disable-coredump \
140 %endif
141 %if ! %{?WITH_BACKLIGHT}
142         --disable-backlight \
143 %endif
144 %if ! %{?WITH_TIMEDATED}
145         --disable-timedated \
146 %endif
147 %if ! %{WITH_RFKILL}
148         --disable-rfkill \
149 %endif
150         --enable-compat-libs \
151         --disable-hwdb \
152         --disable-sysusers \
153         --disable-firstboot \
154         --disable-polkit \
155         --disable-timesyncd \
156         --disable-resolved \
157         --disable-networkd \
158 %if ! %{?WITH_MACHINED}
159         --disable-machined \
160 %endif
161         --disable-importd \
162         --disable-gcrypt \
163         --libexecdir=%{_prefix}/lib \
164         --docdir=%{_docdir}/systemd \
165 %if ! %{?WITH_DOC}
166         --disable-manpages \
167 %endif
168         --disable-static \
169         --with-sysvinit-path= \
170         --with-sysvrcnd-path= \
171         --with-smack-run-label=System::Privileged \
172 %if ! %{?with_multiuser}
173         --disable-logind \
174 %endif
175         cc_cv_CFLAGS__flto=no
176 make %{?_smp_mflags} \
177         systemunitdir=%{_unitdir} \
178         userunitdir=%{_unitdir_user}
179
180 # compile test-runner for 'dbus-integration-test' framework
181 %__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
182
183 %install
184 %make_install
185 %find_lang %{name}
186 cat <<EOF >> systemd.lang
187 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
188 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
189 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
190 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
191 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
192 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
193 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
194 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
195 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
196 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
197 EOF
198
199 # udev links
200 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
201 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
202 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
203
204 # Create SysV compatibility symlinks. systemctl/systemd are smart
205 # enough to detect in which way they are called.
206 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
207 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
208 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
209 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
210 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
211 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
212 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
213 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
214
215 # legacy links
216 %if %{?with_multiuser}
217 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
218 %endif
219
220 # We create all wants links manually at installation time to make sure
221 # they are not owned and hence overriden by rpm after the used deleted
222 # them.
223 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
224
225 # Make sure these directories are properly owned
226 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
227 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
228 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
229 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
230
231 # Make sure the user generators dir exists too
232 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
233 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
234
235 # Create new-style configuration files so that we can ghost-own them
236 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
237 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
238 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
239 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
240 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
241 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
242
243 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
244 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
245
246 # Make sure the shutdown/sleep drop-in dirs exist
247 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
248 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
249
250 # Make sure the NTP units dir exists
251 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
252
253 # Install modprobe fragment
254 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
255
256 # Fix the dangling /var/lock -> /run/lock symlink
257 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
258
259 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
260
261 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
262
263 rm -rf %{buildroot}/%{_docdir}/%{name}
264
265 # Disable some useless services in Tizen
266 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
267 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
268 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
269 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
270 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
271 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
272
273 # Move macros to the proper location for Tizen
274 mkdir -p %{buildroot}%{_sysconfdir}/rpm
275 install -m644 src/core/macros.systemd %{buildroot}%{_sysconfdir}/rpm/macros.systemd
276 rm -f %{buildroot}%{_prefix}/lib/rpm/macros.d/macros.systemd
277
278 # Exclude ELF binaries
279 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
280 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
281 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
282 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
283
284 # Marker file for kdbus
285 touch %{buildroot}/%{_sysconfdir}/systemd/extension-kdbus
286
287 # Preapre tests for 'dbus-integration-test' framework
288 install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
289 mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
290 mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
291
292 # Shell Completion
293 %if ! %{?WITH_BASH_COMPLETION}
294 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
295 %endif
296 %if ! %{?WITH_ZSH_COMPLETION}
297 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
298 %endif
299
300 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
301
302 # Upgrade script from 2.4 to 3.0
303 install -m 755 -d %{buildroot}%{_datadir}/upgrade/scripts
304 install -m 755 %{SOURCE3} %{buildroot}%{_datadir}/upgrade/scripts
305
306 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
307 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
308 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
309 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
310
311 # end of install
312 %pre
313 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
314 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
315 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
316 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
317 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
318
319 # Rename configuration files that changed their names
320 %if %{?with_multiuser}
321 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
322 %endif
323 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
324
325 %post
326 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
327 %if %{WITH_RANDOMSEED}
328 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
329 %endif
330 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
331 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
332 /usr/bin/mkdir -p /etc/systemd/network
333 /usr/bin/ln -sf /dev/null /etc/systemd/network/99-default.link
334
335 #link system, user unit directory in conf dir to opt conf dir
336 /usr/bin/mkdir -p /opt/etc/systemd
337 /usr/bin/mv /etc/systemd/system /opt/etc/systemd/system 
338 /usr/bin/mv /etc/systemd/user /opt/etc/systemd/user
339 /usr/bin/ln -s ../../opt/etc/systemd/system /etc/systemd/system
340 /usr/bin/ln -s ../../opt/etc/systemd/user /etc/systemd/user
341
342 %postun
343 if [ $1 -ge 1 ] ; then
344         /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
345         /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
346 fi
347
348 %preun
349 if [ $1 -eq 0 ] ; then
350         /usr/bin/systemctl disable \
351                 getty@.service \
352                 remote-fs.target \
353                 systemd-readahead-replay.service \
354                 systemd-readahead-collect.service >/dev/null 2>&1 || :
355 fi
356
357 %post -n libsystemd -p /sbin/ldconfig
358 %postun -n libsystemd  -p /sbin/ldconfig
359
360 %lang_package
361
362 %files
363 %manifest %{name}.manifest
364 %license LICENSE.LGPL2.1  LICENSE.GPL2
365 %if %{with_multiuser}
366 %config %{_sysconfdir}/pam.d/systemd-user
367 %endif
368 %{_bindir}/bootctl
369 %{_bindir}/busctl
370 %{_bindir}/kernel-install
371 %if %{?WITH_MACHINED}
372 %{_bindir}/machinectl
373 %endif
374 %{_bindir}/systemd-run
375 %dir %{_prefix}/lib/kernel
376 %dir %{_prefix}/lib/kernel/install.d
377 %{_prefix}/lib/kernel/install.d/50-depmod.install
378 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
379 %{_bindir}/hostnamectl
380 %{_bindir}/localectl
381 %if %{?WITH_COREDUMP}
382 %{_bindir}/coredumpctl
383 %endif
384 %if %{?WITH_TIMEDATED}
385 %{_bindir}/timedatectl
386 %endif
387 %dir %{_sysconfdir}/systemd
388 %{_sysconfdir}/systemd/system
389 %{_sysconfdir}/systemd/user
390 %dir %{_sysconfdir}/tmpfiles.d
391 %dir %{_sysconfdir}/sysctl.d
392 %dir %{_sysconfdir}/modules-load.d
393 %dir %{_sysconfdir}/binfmt.d
394 %if %{?WITH_BASH_COMPLETION}
395 %{_datadir}/bash-completion/*
396 %endif
397 %if %{?WITH_ZSH_COMPLETION}
398 %dir %{_datadir}/zsh/site-functions
399 %{_datadir}/zsh/site-functions/*
400 %endif
401 %dir %{_sysconfdir}/udev
402 %dir %{_sysconfdir}/udev/rules.d
403 %dir %{_prefix}/lib/systemd
404 %dir %{_prefix}/lib/systemd/system
405 %dir %{_prefix}/lib/systemd/system-generators
406 %dir %{_prefix}/lib/systemd/user-generators
407 %dir %{_prefix}/lib/systemd/system-preset
408 %dir %{_prefix}/lib/systemd/user-preset
409 %dir %{_prefix}/lib/systemd/system-shutdown
410 %dir %{_prefix}/lib/systemd/system-sleep
411 %dir %{_prefix}/lib/tmpfiles.d
412 %dir %{_prefix}/lib/sysctl.d
413 %dir %{_prefix}/lib/modules-load.d
414 %dir %{_prefix}/lib/binfmt.d
415 %dir %{_prefix}/lib/firmware
416 %dir %{_prefix}/lib/firmware/updates
417 %dir %{_datadir}/systemd
418 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
419 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
420 %if %{?with_multiuser}
421 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
422 %endif
423 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
424 %if %{?WITH_TIMEDATED}
425 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
426 %endif
427 %if %{?WITH_MACHINED}
428 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
429 %endif
430 %if %{?WITH_COREDUMP}
431 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
432 %endif
433 %config(noreplace) %{_sysconfdir}/systemd/system.conf
434 %config(noreplace) %{_sysconfdir}/systemd/user.conf
435 %if %{?with_multiuser}
436 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
437 %endif
438 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
439 %config(noreplace) %{_sysconfdir}/udev/udev.conf
440 %{_sysconfdir}/xdg/systemd
441 %ghost %config(noreplace) %{_sysconfdir}/hostname
442 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
443 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
444 %ghost %config(noreplace) %{_sysconfdir}/machine-id
445 %ghost %config(noreplace) %{_sysconfdir}/machine-info
446 %ghost %config(noreplace) %{_sysconfdir}/timezone
447 %exclude %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
448 %{_bindir}/systemd
449 %{_bindir}/systemctl
450 %{_bindir}/systemd-notify
451 %{_bindir}/systemd-ask-password
452 %{_bindir}/systemd-tty-ask-password-agent
453 %{_bindir}/systemd-machine-id-setup
454 %{_bindir}/systemd-socket-activate
455 %if %{?with_multiuser}
456 %{_bindir}/loginctl
457 %{_bindir}/systemd-loginctl
458 %endif
459 %{_bindir}/journalctl
460 %{_bindir}/systemd-tmpfiles
461 %{_bindir}/systemd-nspawn
462 %{_bindir}/systemd-stdio-bridge
463 %{_bindir}/systemd-cat
464 %{_bindir}/systemd-cgls
465 %{_bindir}/systemd-cgtop
466 %{_bindir}/systemd-delta
467 %{_bindir}/systemd-detect-virt
468 %if %{?with_multiuser}
469 %{_bindir}/systemd-inhibit
470 %endif
471 %{_bindir}/udevadm
472 %{_bindir}/systemd-escape
473 %{_bindir}/systemd-path
474 %{_prefix}/lib/sysctl.d/*.conf
475 %{_prefix}/lib/systemd/systemd
476 %{_prefix}/lib/systemd/system
477 %exclude %{_prefix}/lib/systemd/resolv.conf
478
479 %dir %{_prefix}/lib/systemd/system/basic.target.wants
480 %dir %{_prefix}/lib/systemd/user
481 %dir %{_prefix}/lib/systemd/network
482 %{_prefix}/lib/systemd/user/basic.target
483 %{_prefix}/lib/systemd/user/bluetooth.target
484 %{_prefix}/lib/systemd/user/exit.target
485 %{_prefix}/lib/systemd/user/printer.target
486 %{_prefix}/lib/systemd/user/shutdown.target
487 %{_prefix}/lib/systemd/user/sockets.target
488 %{_prefix}/lib/systemd/user/sound.target
489 %{_prefix}/lib/systemd/user/systemd-exit.service
490 %{_prefix}/lib/systemd/user/paths.target
491 %{_prefix}/lib/systemd/user/smartcard.target
492 %{_prefix}/lib/systemd/user/timers.target
493 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
494 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
495 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
496 %{_prefix}/lib/systemd/user/default.target
497 %{_prefix}/lib/systemd/network/99-default.link
498 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
499
500 %{_prefix}/lib/systemd/libsystemd-shared-231.so
501 %{_prefix}/lib/systemd/libsystemd-shared.so
502 %{_prefix}/lib/systemd/systemd-*
503 %dir %{_prefix}/lib/systemd/catalog
504 %{_prefix}/lib/systemd/catalog/systemd.catalog
505 %{_prefix}/lib/udev
506 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
507 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
508 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
509 %{_prefix}/lib/tmpfiles.d/home.conf
510 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
511 %{_prefix}/lib/tmpfiles.d/legacy.conf
512 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
513 %{_prefix}/lib/tmpfiles.d/systemd.conf
514 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
515 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
516 %{_prefix}/lib/tmpfiles.d/tmp.conf
517 %{_prefix}/lib/tmpfiles.d/var.conf
518 %{_prefix}/lib/tmpfiles.d/x11.conf
519 %{_sbindir}/init
520 %{_sbindir}/reboot
521 %{_sbindir}/halt
522 %{_sbindir}/poweroff
523 %{_sbindir}/shutdown
524 %{_sbindir}/telinit
525 %{_sbindir}/runlevel
526 %{_sbindir}/udevadm
527 %{_datadir}/systemd/kbd-model-map
528 %{_datadir}/systemd/language-fallback-map
529 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
530 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
531 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
532 %if %{?with_multiuser}
533 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
534 %endif
535 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
536 %if %{?WITH_TIMEDATED}
537 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
538 %endif
539 %if %{?WITH_MACHINED}
540 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
541 %endif
542 %dir %{_datadir}/factory/
543 %dir %{_datadir}/factory/etc
544 %dir %{_datadir}/factory/etc/pam.d
545 %{_datadir}/factory/etc/nsswitch.conf
546 %{_datadir}/factory/etc/pam.d/other
547 %{_datadir}/factory/etc/pam.d/system-auth
548
549 %{_localstatedir}/log/journal
550
551 %{_datadir}/upgrade/scripts/500.systemd_upgrade.sh
552
553 %files -n libsystemd
554 %manifest %{name}.manifest
555 %license LICENSE.LGPL2.1
556 %if %{?with_multiuser}
557 %{_libdir}/security/pam_systemd.so
558 %endif
559 %{_libdir}/libsystemd.so.*
560 %{_libdir}/libudev.so.*
561 %{_libdir}/libnss_myhostname.so.2
562 %if %{?WITH_MACHINED}
563 %{_libdir}/libnss_mymachines.so.2
564 %endif
565
566 %files extension-kdbus
567 %manifest %{name}.manifest
568 %license LICENSE.LGPL2.1  LICENSE.GPL2
569 %{_sysconfdir}/systemd/extension-kdbus
570 %{_prefix}/lib/systemd/user/busnames.target
571 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
572 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
573
574 %files devel
575 %manifest %{name}.manifest
576 %{_libdir}/libudev.so
577 %{_libdir}/libsystemd.so
578 %dir %{_includedir}/systemd
579 %{_includedir}/systemd/sd-bus.h
580 %{_includedir}/systemd/sd-bus-protocol.h
581 %{_includedir}/systemd/sd-bus-vtable.h
582 %{_includedir}/systemd/sd-event.h
583 %{_includedir}/systemd/_sd-common.h
584 %{_includedir}/systemd/sd-daemon.h
585 %{_includedir}/systemd/sd-id128.h
586 %{_includedir}/systemd/sd-journal.h
587 %{_includedir}/systemd/sd-login.h
588 %{_includedir}/systemd/sd-messages.h
589 %{_includedir}/libudev.h
590 %{_libdir}/pkgconfig/libudev.pc
591 %{_libdir}/pkgconfig/libsystemd.pc
592 %{_datadir}/pkgconfig/systemd.pc
593 %{_datadir}/pkgconfig/udev.pc
594 %{_libdir}/pkgconfig/libsystemd-daemon.pc
595 %{_libdir}/pkgconfig/libsystemd-id128.pc
596 %{_libdir}/pkgconfig/libsystemd-journal.pc
597 %{_libdir}/pkgconfig/libsystemd-login.pc
598 %{_sysconfdir}/rpm/macros.systemd
599
600 %files analyze
601 %manifest %{name}.manifest
602 %license LICENSE.LGPL2.1
603 %{_bindir}/systemd-analyze
604
605 %files tests
606 %manifest %{name}.manifest
607 %{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
608 %{_prefix}/lib/dbus-tests/runner/systemd-tests
609
610 %if %{?WITH_DOC}
611 %docs_package
612 %endif