tizen: upgrade script patches
[platform/upstream/systemd.git] / packaging / systemd.spec
1 %bcond_with kdbus
2
3 # "enable foo" will turn into --enable-foo or --disable-foo
4 # depending "with_foo" macro
5 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
6
7 %define WITH_RANDOMSEED 0
8 %define WITH_BASH_COMPLETION 0
9 %define WITH_ZSH_COMPLETION 0
10 %define WITH_COREDUMP 0
11 %define WITH_BACKLIGHT 0
12 %define WITH_TIMEDATED 0
13 %define WITH_RFKILL 0
14 %define with_multiuser 1
15 %define WITH_MACHINED 0
16
17 Name:           systemd
18 Version:        231
19 Release:        0%{?release_flags}
20 # For a breakdown of the licensing, see README
21 License:        LGPL-2.1+ and MIT and GPL-2.0+
22 Summary:        A System and Service Manager
23 Url:            http://www.freedesktop.org/wiki/Software/systemd
24 Group:          Base/Startup
25 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.gz
26 Source1:        pamconsole-tmp.conf
27 Source2:        %{name}-rpmlintrc
28 Source1001:     systemd.manifest
29 Source3:        500.systemd_upgrade.sh
30 #Source4:        test-runner.c
31 BuildRequires:  gperf
32 BuildRequires:  intltool >= 0.40.0
33 BuildRequires:  libacl-devel
34 BuildRequires:  libblkid-devel >= 2.20
35 BuildRequires:  libcap-devel
36 BuildRequires:  libgcrypt-devel
37 BuildRequires:  libkmod-devel >= 14
38 BuildRequires:  xsltproc
39 BuildRequires:  docbook-xsl-stylesheets
40 BuildRequires:  pam-devel
41 BuildRequires:  pkgconfig
42 # BuildRequires:  pkgconfig(dbus-1)     # for remove circular dependency on OBS
43 BuildRequires:  pkgconfig(glib-2.0)
44 BuildRequires:  pkgconfig(liblzma)
45 BuildRequires:  pkgconfig(libkmod)
46 BuildRequires:  pkgconfig(mount)
47 # Requires:       dbus                  # for remove circular dependency on OBS
48 Requires:       filesystem
49 Requires(post): coreutils
50 Requires(post): gawk
51 Requires(pre):  coreutils
52 Requires(pre):  /usr/bin/getent
53 Requires(pre):  /usr/sbin/groupadd
54
55 Obsoletes:      SysVinit < 2.86-24
56 Obsoletes:      sysvinit < 2.86-24
57 Provides:       SysVinit = 2.86-24
58 Provides:       sysvinit = 2.86-24
59 Provides:       /bin/systemctl
60 Provides:       /sbin/shutdown
61 Provides:       udev = %{version}
62 Obsoletes:      udev < 183
63
64 %description
65 systemd is a system and service manager for Linux, compatible with
66 SysV and LSB init scripts. systemd provides aggressive parallelization
67 capabilities, uses socket and D-Bus activation for starting services,
68 offers on-demand starting of daemons, keeps track of processes using
69 Linux cgroups, supports snapshotting and restoring of the system
70 state, maintains mount and automount points and implements an
71 elaborate transactional dependency-based service control logic. It can
72 work as a drop-in replacement for sysvinit.
73
74 %package -n libsystemd
75 License:        LGPL-2.1+ and MIT
76 Summary:        Systemd libraries
77 Group:          Base/Startup
78 Obsoletes:      libudev < 183
79 Provides:       libudev = %{version}
80 Obsoletes:      systemd < 185-4
81 Conflicts:      systemd < 185-4
82
83 %description -n libsystemd
84 Libraries for systemd and udev, as well as the systemd PAM module.
85
86 %package devel
87 License:        LGPL-2.1+ and MIT
88 Summary:        Development headers for systemd
89 Requires:       %{name} = %{version}
90 Requires:               libsystemd = %{version}
91 Provides:       libudev-devel = %{version}
92 Obsoletes:      libudev-devel < 183
93
94 %description devel
95 Development headers and auxiliary files for developing applications for systemd.
96
97 %package analyze
98 License:        LGPL-2.1+
99 Summary:        Tool for processing systemd profiling information
100 Requires:       %{name} = %{version}
101 Obsoletes:      systemd < 38-5
102
103 %description analyze
104 'systemd-analyze blame' lists which systemd unit needed how much time to finish
105 initialization at boot.
106 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
107 at boot.
108
109 #%package tests
110 #License:        LGPL-2.1+ and Apache-2.0
111 #Summary:        Set of tests for sd-bus component
112 #Requires:       %{name} = %{version}
113
114 #%description tests
115 #This package is part of 'dbus-integratnion-tests' framework and contains set of tests
116 #for sd-bus component (DBUS API C library).
117
118 %prep
119 %setup -q
120 cp %{SOURCE1001} .
121 #cp %{SOURCE4} .
122
123 %build
124 %autogen
125 %configure \
126         %{enable kdbus} \
127 %if ! %{WITH_RANDOMSEED}
128         --disable-randomseed \
129 %endif
130 %if ! %{?WITH_COREDUMP}
131         --disable-coredump \
132 %endif
133 %if ! %{?WITH_BACKLIGHT}
134         --disable-backlight \
135 %endif
136 %if ! %{?WITH_TIMEDATED}
137         --disable-timedated \
138 %endif
139 %if ! %{WITH_RFKILL}
140         --disable-rfkill \
141 %endif
142         --enable-compat-libs \
143         --disable-hwdb \
144         --disable-sysusers \
145         --disable-firstboot \
146         --disable-polkit \
147         --disable-timesyncd \
148         --disable-resolved \
149         --disable-networkd \
150 %if ! %{?WITH_MACHINED}
151         --disable-machined \
152 %endif
153         --disable-importd \
154         --disable-gcrypt \
155         --libexecdir=%{_prefix}/lib \
156         --docdir=%{_docdir}/systemd \
157         --disable-static \
158         --with-sysvinit-path= \
159         --with-sysvrcnd-path= \
160         --with-smack-run-label=System::Privileged \
161 %if ! %{?with_multiuser}
162         --disable-logind \
163 %endif
164         cc_cv_CFLAGS__flto=no
165 make %{?_smp_mflags} \
166         systemunitdir=%{_unitdir} \
167         userunitdir=%{_unitdir_user}
168
169 # compile test-runner for 'dbus-integration-test' framework
170 #%__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
171
172 %install
173 %make_install
174 %find_lang %{name}
175 cat <<EOF >> systemd.lang
176 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
177 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
178 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
179 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
180 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
181 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
182 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
183 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
184 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
185 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
186 EOF
187
188 # udev links
189 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
190 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
191 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
192
193 # Create SysV compatibility symlinks. systemctl/systemd are smart
194 # enough to detect in which way they are called.
195 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
196 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
197 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
198 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
199 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
200 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
201 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
202 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
203
204 # legacy links
205 %if %{?with_multiuser}
206 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
207 %endif
208
209 # We create all wants links manually at installation time to make sure
210 # they are not owned and hence overriden by rpm after the used deleted
211 # them.
212 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
213
214 # Make sure these directories are properly owned
215 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
216 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
217 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
218 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
219
220 # Make sure the user generators dir exists too
221 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
222 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
223
224 # Create new-style configuration files so that we can ghost-own them
225 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
226 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
227 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
228 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
229 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
230 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
231
232 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
233 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
234
235 # Make sure the shutdown/sleep drop-in dirs exist
236 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
237 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
238
239 # Make sure the NTP units dir exists
240 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
241
242 # Install modprobe fragment
243 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
244
245 # Fix the dangling /var/lock -> /run/lock symlink
246 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
247
248 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
249
250 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
251
252 rm -rf %{buildroot}/%{_docdir}/%{name}
253
254 # Disable some useless services in Tizen
255 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
256 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
257 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
258 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
259 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
260 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
261
262 # Disable systemd-bus-proxyd
263 %if %{with kdbus}
264 rm -Rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-bus-proxyd.socket
265 rm -Rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-bus-proxyd.service
266 rm -Rf %{buildroot}/%{_prefix}/lib/systemd/user/systemd-bus-proxyd.socket
267 rm -Rf %{buildroot}/%{_prefix}/lib/systemd/user/systemd-bus-proxyd.service
268 %endif
269
270 # Move macros to the proper location for Tizen
271 mkdir -p %{buildroot}%{_sysconfdir}/rpm
272 install -m644 src/core/macros.systemd %{buildroot}%{_sysconfdir}/rpm/macros.systemd
273 rm -f %{buildroot}%{_prefix}/lib/rpm/macros.d/macros.systemd
274
275 # Exclude ELF binaries
276 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
277 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
278 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
279 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
280
281 # Preapre tests for 'dbus-integration-test' framework
282 #install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
283 #mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
284 #mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
285 #rm %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/test-bus-policy
286
287 # Shell Completion
288 %if ! %{?WITH_BASH_COMPLETION}
289 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
290 %endif
291 %if ! %{?WITH_ZSH_COMPLETION}
292 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
293 %endif
294
295 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
296
297 # Upgrade script from 2.4 to 3.0
298 install -m 755 -d %{buildroot}%{_datadir}/upgrade/scripts
299 install -m 755 %{SOURCE3} %{buildroot}%{_datadir}/upgrade/scripts
300
301 %if ! %{with kdbus}
302 rm -f  %{buildroot}/etc/X11/xinit/xinitrc.d/50-systemd-user.sh
303 rm -f  %{buildroot}/usr/include/systemd/sd-bus-protocol.h
304 rm -f  %{buildroot}/usr/include/systemd/sd-bus-vtable.h
305 rm -f  %{buildroot}/usr/include/systemd/sd-bus.h
306 rm -f  %{buildroot}/usr/include/systemd/sd-event.h
307 rm -f  %{buildroot}/usr/lib/systemd/system-generators/systemd-dbus1-generator
308 rm -f  %{buildroot}/usr/lib/systemd/user-generators/systemd-dbus1-generator
309 rm -f  %{buildroot}/usr/lib/systemd/user/busnames.target
310 %endif
311
312 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
313 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
314 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
315 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
316
317 # end of install
318 %pre
319 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
320 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
321 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
322 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
323 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
324
325 # Rename configuration files that changed their names
326 %if %{?with_multiuser}
327 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
328 %endif
329 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
330
331 %post
332 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
333 %if %{WITH_RANDOMSEED}
334 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
335 %endif
336 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
337 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
338
339 %postun
340 if [ $1 -ge 1 ] ; then
341         /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
342         /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
343 fi
344
345 %preun
346 if [ $1 -eq 0 ] ; then
347         /usr/bin/systemctl disable \
348                 getty@.service \
349                 remote-fs.target \
350                 systemd-readahead-replay.service \
351                 systemd-readahead-collect.service >/dev/null 2>&1 || :
352 fi
353
354 %post -n libsystemd -p /sbin/ldconfig
355 %postun -n libsystemd  -p /sbin/ldconfig
356
357 %lang_package
358
359 %files
360 %manifest %{name}.manifest
361 %if %{with_multiuser}
362 %config %{_sysconfdir}/pam.d/systemd-user
363 %endif
364 %{_bindir}/bootctl
365 %{_bindir}/busctl
366 %{_bindir}/kernel-install
367 %if %{?WITH_MACHINED}
368 %{_bindir}/machinectl
369 %endif
370 %{_bindir}/systemd-run
371 %dir %{_prefix}/lib/kernel
372 %dir %{_prefix}/lib/kernel/install.d
373 %{_prefix}/lib/kernel/install.d/50-depmod.install
374 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
375 %{_bindir}/hostnamectl
376 %{_bindir}/localectl
377 %if %{?WITH_COREDUMP}
378 %{_bindir}/coredumpctl
379 %endif
380 %if %{?WITH_TIMEDATED}
381 %{_bindir}/timedatectl
382 %endif
383 %dir %{_sysconfdir}/systemd
384 %dir %{_sysconfdir}/systemd/system
385 %dir %{_sysconfdir}/systemd/user
386 %dir %{_sysconfdir}/tmpfiles.d
387 %dir %{_sysconfdir}/sysctl.d
388 %dir %{_sysconfdir}/modules-load.d
389 %dir %{_sysconfdir}/binfmt.d
390 %if %{?WITH_BASH_COMPLETION}
391 %{_datadir}/bash-completion/*
392 %endif
393 %if %{?WITH_ZSH_COMPLETION}
394 %dir %{_datadir}/zsh/site-functions
395 %{_datadir}/zsh/site-functions/*
396 %endif
397 %dir %{_sysconfdir}/udev
398 %dir %{_sysconfdir}/udev/rules.d
399 %dir %{_prefix}/lib/systemd
400 %dir %{_prefix}/lib/systemd/system
401 %dir %{_prefix}/lib/systemd/system-generators
402 %dir %{_prefix}/lib/systemd/user-generators
403 %dir %{_prefix}/lib/systemd/system-preset
404 %dir %{_prefix}/lib/systemd/user-preset
405 %dir %{_prefix}/lib/systemd/system-shutdown
406 %dir %{_prefix}/lib/systemd/system-sleep
407 %dir %{_prefix}/lib/tmpfiles.d
408 %dir %{_prefix}/lib/sysctl.d
409 %dir %{_prefix}/lib/modules-load.d
410 %dir %{_prefix}/lib/binfmt.d
411 %dir %{_prefix}/lib/firmware
412 %dir %{_prefix}/lib/firmware/updates
413 %dir %{_datadir}/systemd
414 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
415 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
416 %if %{?with_multiuser}
417 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
418 %endif
419 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
420 %if %{?WITH_TIMEDATED}
421 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
422 %endif
423 %if %{?WITH_MACHINED}
424 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
425 %endif
426 %if %{?WITH_COREDUMP}
427 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
428 %endif
429 %config(noreplace) %{_sysconfdir}/systemd/system.conf
430 %config(noreplace) %{_sysconfdir}/systemd/user.conf
431 %if %{?with_multiuser}
432 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
433 %endif
434 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
435 %config(noreplace) %{_sysconfdir}/udev/udev.conf
436 %{_sysconfdir}/xdg/systemd
437 %ghost %config(noreplace) %{_sysconfdir}/hostname
438 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
439 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
440 %ghost %config(noreplace) %{_sysconfdir}/machine-id
441 %ghost %config(noreplace) %{_sysconfdir}/machine-info
442 %ghost %config(noreplace) %{_sysconfdir}/timezone
443 %if %{with kdbus}
444 %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
445 %endif
446 %{_bindir}/systemd
447 %{_bindir}/systemctl
448 %{_bindir}/systemd-notify
449 %{_bindir}/systemd-ask-password
450 %{_bindir}/systemd-tty-ask-password-agent
451 %{_bindir}/systemd-machine-id-setup
452 %{_bindir}/systemd-socket-activate
453 %if %{?with_multiuser}
454 %{_bindir}/loginctl
455 %{_bindir}/systemd-loginctl
456 %endif
457 %{_bindir}/journalctl
458 %{_bindir}/systemd-tmpfiles
459 %{_bindir}/systemd-nspawn
460 %{_bindir}/systemd-stdio-bridge
461 %{_bindir}/systemd-cat
462 %{_bindir}/systemd-cgls
463 %{_bindir}/systemd-cgtop
464 %{_bindir}/systemd-delta
465 %{_bindir}/systemd-detect-virt
466 %if %{?with_multiuser}
467 %{_bindir}/systemd-inhibit
468 %endif
469 %{_bindir}/udevadm
470 %{_bindir}/systemd-escape
471 %{_bindir}/systemd-path
472 %{_prefix}/lib/sysctl.d/*.conf
473 %{_prefix}/lib/systemd/systemd
474 %{_prefix}/lib/systemd/system
475 %exclude %{_prefix}/lib/systemd/resolv.conf
476
477 %dir %{_prefix}/lib/systemd/system/basic.target.wants
478 %dir %{_prefix}/lib/systemd/user
479 %dir %{_prefix}/lib/systemd/network
480 %{_prefix}/lib/systemd/user/basic.target
481 %{_prefix}/lib/systemd/user/bluetooth.target
482 %{_prefix}/lib/systemd/user/exit.target
483 %{_prefix}/lib/systemd/user/printer.target
484 %{_prefix}/lib/systemd/user/shutdown.target
485 %{_prefix}/lib/systemd/user/sockets.target
486 %{_prefix}/lib/systemd/user/sound.target
487 %{_prefix}/lib/systemd/user/systemd-exit.service
488 %{_prefix}/lib/systemd/user/paths.target
489 %{_prefix}/lib/systemd/user/smartcard.target
490 %{_prefix}/lib/systemd/user/timers.target
491 %if %{with kdbus}
492 %{_prefix}/lib/systemd/user/busnames.target
493 %endif
494 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
495 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
496 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
497 %{_prefix}/lib/systemd/user/default.target
498 %{_prefix}/lib/systemd/network/99-default.link
499 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
500
501 %{_prefix}/lib/systemd/libsystemd-shared-231.so
502 %{_prefix}/lib/systemd/libsystemd-shared.so
503 %{_prefix}/lib/systemd/systemd-*
504 %dir %{_prefix}/lib/systemd/catalog
505 %{_prefix}/lib/systemd/catalog/systemd.catalog
506 %{_prefix}/lib/udev
507 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
508 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
509 %if %{with kdbus}
510 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
511 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
512 %endif
513 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
514 %{_prefix}/lib/tmpfiles.d/etc.conf
515 %{_prefix}/lib/tmpfiles.d/home.conf
516 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
517 %{_prefix}/lib/tmpfiles.d/legacy.conf
518 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
519 %{_prefix}/lib/tmpfiles.d/systemd.conf
520 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
521 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
522 %{_prefix}/lib/tmpfiles.d/tmp.conf
523 %{_prefix}/lib/tmpfiles.d/var.conf
524 %{_prefix}/lib/tmpfiles.d/x11.conf
525 %{_sbindir}/init
526 %{_sbindir}/reboot
527 %{_sbindir}/halt
528 %{_sbindir}/poweroff
529 %{_sbindir}/shutdown
530 %{_sbindir}/telinit
531 %{_sbindir}/runlevel
532 %{_sbindir}/udevadm
533 %{_datadir}/systemd/kbd-model-map
534 %{_datadir}/systemd/language-fallback-map
535 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
536 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
537 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
538 %if %{?with_multiuser}
539 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
540 %endif
541 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
542 %if %{?WITH_TIMEDATED}
543 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
544 %endif
545 %if %{?WITH_MACHINED}
546 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
547 %endif
548 %dir %{_datadir}/factory/
549 %dir %{_datadir}/factory/etc
550 %dir %{_datadir}/factory/etc/pam.d
551 %{_datadir}/factory/etc/nsswitch.conf
552 %{_datadir}/factory/etc/pam.d/other
553 %{_datadir}/factory/etc/pam.d/system-auth
554
555 %{_localstatedir}/log/journal
556
557 %{_datadir}/upgrade/scripts/500.systemd_upgrade.sh
558
559 %files -n libsystemd
560 %manifest %{name}.manifest
561 %if %{?with_multiuser}
562 %{_libdir}/security/pam_systemd.so
563 %endif
564 %{_libdir}/libsystemd.so.*
565 %{_libdir}/libudev.so.*
566 %{_libdir}/libnss_myhostname.so.2
567 %if %{?WITH_MACHINED}
568 %{_libdir}/libnss_mymachines.so.2
569 %endif
570
571 %files devel
572 %manifest %{name}.manifest
573 %{_libdir}/libudev.so
574 %{_libdir}/libsystemd.so
575 %dir %{_includedir}/systemd
576 %if %{with kdbus}
577 %{_includedir}/systemd/sd-bus.h
578 %{_includedir}/systemd/sd-bus-protocol.h
579 %{_includedir}/systemd/sd-bus-vtable.h
580 %{_includedir}/systemd/sd-event.h
581 %endif
582 %{_includedir}/systemd/_sd-common.h
583 %{_includedir}/systemd/sd-daemon.h
584 %{_includedir}/systemd/sd-id128.h
585 %{_includedir}/systemd/sd-journal.h
586 %{_includedir}/systemd/sd-login.h
587 %{_includedir}/systemd/sd-messages.h
588 %{_includedir}/libudev.h
589 %{_libdir}/pkgconfig/libudev.pc
590 %{_libdir}/pkgconfig/libsystemd.pc
591 %{_datadir}/pkgconfig/systemd.pc
592 %{_datadir}/pkgconfig/udev.pc
593 %{_libdir}/pkgconfig/libsystemd-daemon.pc
594 %{_libdir}/pkgconfig/libsystemd-id128.pc
595 %{_libdir}/pkgconfig/libsystemd-journal.pc
596 %{_libdir}/pkgconfig/libsystemd-login.pc
597 %{_sysconfdir}/rpm/macros.systemd
598
599 %files analyze
600 %manifest %{name}.manifest
601 %{_bindir}/systemd-analyze
602
603 #%files tests
604 #%manifest %{name}.manifest
605 #%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
606 #%{_prefix}/lib/dbus-tests/runner/systemd-tests
607
608 %docs_package