1 # "enable foo" will turn into --enable-foo or --disable-foo
2 # depending "with_foo" macro
3 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
5 %define WITH_RANDOMSEED 0
6 %define WITH_BASH_COMPLETION 0
7 %define WITH_ZSH_COMPLETION 0
8 %define WITH_COREDUMP 0
9 %define WITH_BACKLIGHT 0
10 %define WITH_TIMEDATED 0
12 %define with_multiuser 1
13 %define WITH_MACHINED 0
17 Release: 0%{?release_flags}
18 # For a breakdown of the licensing, see README
19 License: LGPL-2.1+ and MIT and GPL-2.0+
20 Summary: A System and Service Manager
21 Url: http://www.freedesktop.org/wiki/Software/systemd
23 Source0: https://github.com/systemd/systemd/archive/v%{version}.tar.gz
24 Source1: pamconsole-tmp.conf
25 Source2: %{name}-rpmlintrc
26 Source3: 500.systemd_upgrade.sh
27 Source4: test-runner.c
28 Source1001: systemd.manifest
30 BuildRequires: intltool >= 0.40.0
31 BuildRequires: libacl-devel
32 BuildRequires: libblkid-devel >= 2.20
33 BuildRequires: libcap-devel
34 BuildRequires: libgcrypt-devel
35 BuildRequires: libkmod-devel >= 14
36 BuildRequires: xsltproc
37 BuildRequires: docbook-xsl-stylesheets
38 BuildRequires: pam-devel
39 BuildRequires: pkgconfig
40 # BuildRequires: pkgconfig(dbus-1) # for remove circular dependency on OBS
41 BuildRequires: pkgconfig(glib-2.0)
42 BuildRequires: pkgconfig(liblzma)
43 BuildRequires: pkgconfig(libkmod)
44 BuildRequires: pkgconfig(mount)
45 # Requires: dbus # for remove circular dependency on OBS
47 Requires(post): coreutils
49 Requires(pre): coreutils
50 Requires(pre): /usr/bin/getent
51 Requires(pre): /usr/sbin/groupadd
53 Obsoletes: SysVinit < 2.86-24
54 Obsoletes: sysvinit < 2.86-24
55 Provides: SysVinit = 2.86-24
56 Provides: sysvinit = 2.86-24
57 Provides: /bin/systemctl
58 Provides: /sbin/shutdown
59 Provides: udev = %{version}
63 systemd is a system and service manager for Linux, compatible with
64 SysV and LSB init scripts. systemd provides aggressive parallelization
65 capabilities, uses socket and D-Bus activation for starting services,
66 offers on-demand starting of daemons, keeps track of processes using
67 Linux cgroups, supports snapshotting and restoring of the system
68 state, maintains mount and automount points and implements an
69 elaborate transactional dependency-based service control logic. It can
70 work as a drop-in replacement for sysvinit.
72 %package -n libsystemd
73 License: LGPL-2.1+ and MIT
74 Summary: Systemd libraries
76 Obsoletes: libudev < 183
77 Provides: libudev = %{version}
78 Obsoletes: systemd < 185-4
79 Conflicts: systemd < 185-4
81 %description -n libsystemd
82 Libraries for systemd and udev, as well as the systemd PAM module.
85 License: LGPL-2.1+ and MIT
86 Summary: Development headers for systemd
87 Requires: %{name} = %{version}
88 Requires: libsystemd = %{version}
89 Provides: libudev-devel = %{version}
90 Obsoletes: libudev-devel < 183
93 Development headers and auxiliary files for developing applications for systemd.
97 Summary: Tool for processing systemd profiling information
98 Requires: %{name} = %{version}
99 Obsoletes: systemd < 38-5
102 'systemd-analyze blame' lists which systemd unit needed how much time to finish
103 initialization at boot.
104 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
108 License: LGPL-2.1+ and Apache-2.0
109 Summary: Set of tests for sd-bus component
110 Requires: %{name} = %{version}
113 This package is part of 'dbus-integratnion-tests' framework and contains set of tests
114 for sd-bus component (DBUS API C library).
116 %package extension-kdbus
117 Summary: Extension for systemd to support KDBUS in Tizen
118 Requires: %{name} = %{version}-%{release}
120 %description extension-kdbus
121 This modifies systemd to support KDBUS in Tizen.
132 %if ! %{WITH_RANDOMSEED}
133 --disable-randomseed \
135 %if ! %{?WITH_COREDUMP}
138 %if ! %{?WITH_BACKLIGHT}
139 --disable-backlight \
141 %if ! %{?WITH_TIMEDATED}
142 --disable-timedated \
147 --enable-compat-libs \
150 --disable-firstboot \
152 --disable-timesyncd \
155 %if ! %{?WITH_MACHINED}
160 --libexecdir=%{_prefix}/lib \
161 --docdir=%{_docdir}/systemd \
163 --with-sysvinit-path= \
164 --with-sysvrcnd-path= \
165 --with-smack-run-label=System::Privileged \
166 %if ! %{?with_multiuser}
169 cc_cv_CFLAGS__flto=no
170 make %{?_smp_mflags} \
171 systemunitdir=%{_unitdir} \
172 userunitdir=%{_unitdir_user}
174 # compile test-runner for 'dbus-integration-test' framework
175 %__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
180 cat <<EOF >> systemd.lang
181 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
182 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
183 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
184 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
185 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
186 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
187 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
188 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
189 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
190 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
194 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
195 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
196 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
198 # Create SysV compatibility symlinks. systemctl/systemd are smart
199 # enough to detect in which way they are called.
200 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
201 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
202 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
203 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
204 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
205 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
206 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
207 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
210 %if %{?with_multiuser}
211 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
214 # We create all wants links manually at installation time to make sure
215 # they are not owned and hence overriden by rpm after the used deleted
217 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
219 # Make sure these directories are properly owned
220 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
221 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
222 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
223 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
225 # Make sure the user generators dir exists too
226 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
227 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
229 # Create new-style configuration files so that we can ghost-own them
230 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
231 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
232 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
233 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
234 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
235 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
237 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
238 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
240 # Make sure the shutdown/sleep drop-in dirs exist
241 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
242 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
244 # Make sure the NTP units dir exists
245 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
247 # Install modprobe fragment
248 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
250 # Fix the dangling /var/lock -> /run/lock symlink
251 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
253 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
255 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
257 rm -rf %{buildroot}/%{_docdir}/%{name}
259 # Disable some useless services in Tizen
260 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
261 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
262 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
263 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
264 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
265 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
267 # Move macros to the proper location for Tizen
268 mkdir -p %{buildroot}%{_sysconfdir}/rpm
269 install -m644 src/core/macros.systemd %{buildroot}%{_sysconfdir}/rpm/macros.systemd
270 rm -f %{buildroot}%{_prefix}/lib/rpm/macros.d/macros.systemd
272 # Exclude ELF binaries
273 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
274 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
275 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
276 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
278 # Marker file for kdbus
279 touch %{buildroot}/%{_sysconfdir}/systemd/extension-kdbus
281 # Preapre tests for 'dbus-integration-test' framework
282 install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
283 mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
284 mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
287 %if ! %{?WITH_BASH_COMPLETION}
288 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
290 %if ! %{?WITH_ZSH_COMPLETION}
291 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
294 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
296 # Upgrade script from 2.4 to 3.0
297 install -m 755 -d %{buildroot}%{_datadir}/upgrade/scripts
298 install -m 755 %{SOURCE3} %{buildroot}%{_datadir}/upgrade/scripts
300 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
301 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
302 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
303 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
307 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
308 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
309 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
310 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
311 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
313 # Rename configuration files that changed their names
314 %if %{?with_multiuser}
315 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
317 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
320 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
321 %if %{WITH_RANDOMSEED}
322 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
324 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
325 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
326 /usr/bin/mkdir -p /etc/systemd/network
327 /usr/bin/ln -sf /dev/null /etc/systemd/network/99-default.link
329 #link system, user unit directory in conf dir to opt conf dir
330 /usr/bin/mkdir -p /opt/etc/systemd
331 /usr/bin/mv /etc/systemd/system /opt/etc/systemd/system
332 /usr/bin/mv /etc/systemd/user /opt/etc/systemd/user
333 /usr/bin/ln -s ../../opt/etc/systemd/system /etc/systemd/system
334 /usr/bin/ln -s ../../opt/etc/systemd/user /etc/systemd/user
337 if [ $1 -ge 1 ] ; then
338 /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
339 /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
343 if [ $1 -eq 0 ] ; then
344 /usr/bin/systemctl disable \
347 systemd-readahead-replay.service \
348 systemd-readahead-collect.service >/dev/null 2>&1 || :
351 %post -n libsystemd -p /sbin/ldconfig
352 %postun -n libsystemd -p /sbin/ldconfig
357 %manifest %{name}.manifest
358 %if %{with_multiuser}
359 %config %{_sysconfdir}/pam.d/systemd-user
363 %{_bindir}/kernel-install
364 %if %{?WITH_MACHINED}
365 %{_bindir}/machinectl
367 %{_bindir}/systemd-run
368 %dir %{_prefix}/lib/kernel
369 %dir %{_prefix}/lib/kernel/install.d
370 %{_prefix}/lib/kernel/install.d/50-depmod.install
371 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
372 %{_bindir}/hostnamectl
374 %if %{?WITH_COREDUMP}
375 %{_bindir}/coredumpctl
377 %if %{?WITH_TIMEDATED}
378 %{_bindir}/timedatectl
380 %dir %{_sysconfdir}/systemd
381 %{_sysconfdir}/systemd/system
382 %{_sysconfdir}/systemd/user
383 %dir %{_sysconfdir}/tmpfiles.d
384 %dir %{_sysconfdir}/sysctl.d
385 %dir %{_sysconfdir}/modules-load.d
386 %dir %{_sysconfdir}/binfmt.d
387 %if %{?WITH_BASH_COMPLETION}
388 %{_datadir}/bash-completion/*
390 %if %{?WITH_ZSH_COMPLETION}
391 %dir %{_datadir}/zsh/site-functions
392 %{_datadir}/zsh/site-functions/*
394 %dir %{_sysconfdir}/udev
395 %dir %{_sysconfdir}/udev/rules.d
396 %dir %{_prefix}/lib/systemd
397 %dir %{_prefix}/lib/systemd/system
398 %dir %{_prefix}/lib/systemd/system-generators
399 %dir %{_prefix}/lib/systemd/user-generators
400 %dir %{_prefix}/lib/systemd/system-preset
401 %dir %{_prefix}/lib/systemd/user-preset
402 %dir %{_prefix}/lib/systemd/system-shutdown
403 %dir %{_prefix}/lib/systemd/system-sleep
404 %dir %{_prefix}/lib/tmpfiles.d
405 %dir %{_prefix}/lib/sysctl.d
406 %dir %{_prefix}/lib/modules-load.d
407 %dir %{_prefix}/lib/binfmt.d
408 %dir %{_prefix}/lib/firmware
409 %dir %{_prefix}/lib/firmware/updates
410 %dir %{_datadir}/systemd
411 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
412 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
413 %if %{?with_multiuser}
414 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
416 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
417 %if %{?WITH_TIMEDATED}
418 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
420 %if %{?WITH_MACHINED}
421 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
423 %if %{?WITH_COREDUMP}
424 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
426 %config(noreplace) %{_sysconfdir}/systemd/system.conf
427 %config(noreplace) %{_sysconfdir}/systemd/user.conf
428 %if %{?with_multiuser}
429 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
431 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
432 %config(noreplace) %{_sysconfdir}/udev/udev.conf
433 %{_sysconfdir}/xdg/systemd
434 %ghost %config(noreplace) %{_sysconfdir}/hostname
435 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
436 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
437 %ghost %config(noreplace) %{_sysconfdir}/machine-id
438 %ghost %config(noreplace) %{_sysconfdir}/machine-info
439 %ghost %config(noreplace) %{_sysconfdir}/timezone
440 %exclude %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
443 %{_bindir}/systemd-notify
444 %{_bindir}/systemd-ask-password
445 %{_bindir}/systemd-tty-ask-password-agent
446 %{_bindir}/systemd-machine-id-setup
447 %{_bindir}/systemd-socket-activate
448 %if %{?with_multiuser}
450 %{_bindir}/systemd-loginctl
452 %{_bindir}/journalctl
453 %{_bindir}/systemd-tmpfiles
454 %{_bindir}/systemd-nspawn
455 %{_bindir}/systemd-stdio-bridge
456 %{_bindir}/systemd-cat
457 %{_bindir}/systemd-cgls
458 %{_bindir}/systemd-cgtop
459 %{_bindir}/systemd-delta
460 %{_bindir}/systemd-detect-virt
461 %if %{?with_multiuser}
462 %{_bindir}/systemd-inhibit
465 %{_bindir}/systemd-escape
466 %{_bindir}/systemd-path
467 %{_prefix}/lib/sysctl.d/*.conf
468 %{_prefix}/lib/systemd/systemd
469 %{_prefix}/lib/systemd/system
470 %exclude %{_prefix}/lib/systemd/resolv.conf
472 %dir %{_prefix}/lib/systemd/system/basic.target.wants
473 %dir %{_prefix}/lib/systemd/user
474 %dir %{_prefix}/lib/systemd/network
475 %{_prefix}/lib/systemd/user/basic.target
476 %{_prefix}/lib/systemd/user/bluetooth.target
477 %{_prefix}/lib/systemd/user/exit.target
478 %{_prefix}/lib/systemd/user/printer.target
479 %{_prefix}/lib/systemd/user/shutdown.target
480 %{_prefix}/lib/systemd/user/sockets.target
481 %{_prefix}/lib/systemd/user/sound.target
482 %{_prefix}/lib/systemd/user/systemd-exit.service
483 %{_prefix}/lib/systemd/user/paths.target
484 %{_prefix}/lib/systemd/user/smartcard.target
485 %{_prefix}/lib/systemd/user/timers.target
486 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
487 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
488 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
489 %{_prefix}/lib/systemd/user/default.target
490 %{_prefix}/lib/systemd/network/99-default.link
491 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
493 %{_prefix}/lib/systemd/libsystemd-shared-231.so
494 %{_prefix}/lib/systemd/libsystemd-shared.so
495 %{_prefix}/lib/systemd/systemd-*
496 %dir %{_prefix}/lib/systemd/catalog
497 %{_prefix}/lib/systemd/catalog/systemd.catalog
499 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
500 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
501 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
502 %{_prefix}/lib/tmpfiles.d/home.conf
503 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
504 %{_prefix}/lib/tmpfiles.d/legacy.conf
505 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
506 %{_prefix}/lib/tmpfiles.d/systemd.conf
507 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
508 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
509 %{_prefix}/lib/tmpfiles.d/tmp.conf
510 %{_prefix}/lib/tmpfiles.d/var.conf
511 %{_prefix}/lib/tmpfiles.d/x11.conf
520 %{_datadir}/systemd/kbd-model-map
521 %{_datadir}/systemd/language-fallback-map
522 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
523 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
525 %if %{?with_multiuser}
526 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
528 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
529 %if %{?WITH_TIMEDATED}
530 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
532 %if %{?WITH_MACHINED}
533 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
535 %dir %{_datadir}/factory/
536 %dir %{_datadir}/factory/etc
537 %dir %{_datadir}/factory/etc/pam.d
538 %{_datadir}/factory/etc/nsswitch.conf
539 %{_datadir}/factory/etc/pam.d/other
540 %{_datadir}/factory/etc/pam.d/system-auth
542 %{_localstatedir}/log/journal
544 %{_datadir}/upgrade/scripts/500.systemd_upgrade.sh
547 %manifest %{name}.manifest
548 %if %{?with_multiuser}
549 %{_libdir}/security/pam_systemd.so
551 %{_libdir}/libsystemd.so.*
552 %{_libdir}/libudev.so.*
553 %{_libdir}/libnss_myhostname.so.2
554 %if %{?WITH_MACHINED}
555 %{_libdir}/libnss_mymachines.so.2
558 %files extension-kdbus
559 %manifest %{name}.manifest
560 %{_sysconfdir}/systemd/extension-kdbus
561 %{_prefix}/lib/systemd/user/busnames.target
562 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
563 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
566 %manifest %{name}.manifest
567 %{_libdir}/libudev.so
568 %{_libdir}/libsystemd.so
569 %dir %{_includedir}/systemd
570 %{_includedir}/systemd/sd-bus.h
571 %{_includedir}/systemd/sd-bus-protocol.h
572 %{_includedir}/systemd/sd-bus-vtable.h
573 %{_includedir}/systemd/sd-event.h
574 %{_includedir}/systemd/_sd-common.h
575 %{_includedir}/systemd/sd-daemon.h
576 %{_includedir}/systemd/sd-id128.h
577 %{_includedir}/systemd/sd-journal.h
578 %{_includedir}/systemd/sd-login.h
579 %{_includedir}/systemd/sd-messages.h
580 %{_includedir}/libudev.h
581 %{_libdir}/pkgconfig/libudev.pc
582 %{_libdir}/pkgconfig/libsystemd.pc
583 %{_datadir}/pkgconfig/systemd.pc
584 %{_datadir}/pkgconfig/udev.pc
585 %{_libdir}/pkgconfig/libsystemd-daemon.pc
586 %{_libdir}/pkgconfig/libsystemd-id128.pc
587 %{_libdir}/pkgconfig/libsystemd-journal.pc
588 %{_libdir}/pkgconfig/libsystemd-login.pc
589 %{_sysconfdir}/rpm/macros.systemd
592 %manifest %{name}.manifest
593 %{_bindir}/systemd-analyze
596 %manifest %{name}.manifest
597 %{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
598 %{_prefix}/lib/dbus-tests/runner/systemd-tests