License: add license files
[platform/upstream/systemd.git] / packaging / systemd.spec
1 # "enable foo" will turn into --enable-foo or --disable-foo
2 # depending "with_foo" macro
3 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
4
5 %define WITH_RANDOMSEED 0
6 %define WITH_BASH_COMPLETION 0
7 %define WITH_ZSH_COMPLETION 0
8 %define WITH_COREDUMP 0
9 %define WITH_BACKLIGHT 0
10 %define WITH_TIMEDATED 0
11 %define WITH_RFKILL 0
12 %define with_multiuser 1
13 %define WITH_MACHINED 0
14
15 Name:           systemd
16 Version:        231
17 Release:        0%{?release_flags}
18 # For a breakdown of the licensing, see README
19 License:        LGPL-2.1+ and GPL-2.0+
20 Summary:        A System and Service Manager
21 Url:            http://www.freedesktop.org/wiki/Software/systemd
22 Group:          Base/Startup
23 Source0:        https://github.com/systemd/systemd/archive/v%{version}.tar.gz
24 Source1:        pamconsole-tmp.conf
25 Source2:        %{name}-rpmlintrc
26 Source3:        500.systemd_upgrade.sh
27 Source4:        test-runner.c
28 Source1001:     systemd.manifest
29 BuildRequires:  gperf
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libacl-devel
32 BuildRequires:  libblkid-devel >= 2.20
33 BuildRequires:  libcap-devel
34 BuildRequires:  libgcrypt-devel
35 BuildRequires:  libkmod-devel >= 14
36 BuildRequires:  xsltproc
37 BuildRequires:  docbook-xsl-stylesheets
38 BuildRequires:  pam-devel
39 BuildRequires:  pkgconfig
40 # BuildRequires:  pkgconfig(dbus-1)     # for remove circular dependency on OBS
41 BuildRequires:  pkgconfig(glib-2.0)
42 BuildRequires:  pkgconfig(liblzma)
43 BuildRequires:  pkgconfig(libkmod)
44 BuildRequires:  pkgconfig(mount)
45 # Requires:       dbus                  # for remove circular dependency on OBS
46 Requires:       filesystem
47 Requires(post): coreutils
48 Requires(post): gawk
49 Requires(pre):  coreutils
50 Requires(pre):  /usr/bin/getent
51 Requires(pre):  /usr/sbin/groupadd
52
53 Obsoletes:      SysVinit < 2.86-24
54 Obsoletes:      sysvinit < 2.86-24
55 Provides:       SysVinit = 2.86-24
56 Provides:       sysvinit = 2.86-24
57 Provides:       /bin/systemctl
58 Provides:       /sbin/shutdown
59 Provides:       udev = %{version}
60 Obsoletes:      udev < 183
61
62 %description
63 systemd is a system and service manager for Linux, compatible with
64 SysV and LSB init scripts. systemd provides aggressive parallelization
65 capabilities, uses socket and D-Bus activation for starting services,
66 offers on-demand starting of daemons, keeps track of processes using
67 Linux cgroups, supports snapshotting and restoring of the system
68 state, maintains mount and automount points and implements an
69 elaborate transactional dependency-based service control logic. It can
70 work as a drop-in replacement for sysvinit.
71
72 %package -n libsystemd
73 License:        LGPL-2.1+
74 Summary:        Systemd libraries
75 Group:          Base/Startup
76 Obsoletes:      libudev < 183
77 Provides:       libudev = %{version}
78 Obsoletes:      systemd < 185-4
79 Conflicts:      systemd < 185-4
80
81 %description -n libsystemd
82 Libraries for systemd and udev, as well as the systemd PAM module.
83
84 %package devel
85 License:        LGPL-2.1+
86 Summary:        Development headers for systemd
87 Requires:       %{name} = %{version}
88 Requires:               libsystemd = %{version}
89 Provides:       libudev-devel = %{version}
90 Obsoletes:      libudev-devel < 183
91
92 %description devel
93 Development headers and auxiliary files for developing applications for systemd.
94
95 %package analyze
96 License:        LGPL-2.1+
97 Summary:        Tool for processing systemd profiling information
98 Requires:       %{name} = %{version}
99 Obsoletes:      systemd < 38-5
100
101 %description analyze
102 'systemd-analyze blame' lists which systemd unit needed how much time to finish
103 initialization at boot.
104 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
105 at boot.
106
107 %package tests
108 License:        LGPL-2.1+ and Apache-2.0
109 Summary:        Set of tests for sd-bus component
110 Requires:       %{name} = %{version}
111
112 %description tests
113 This package is part of 'dbus-integratnion-tests' framework and contains set of tests
114 for sd-bus component (DBUS API C library).
115
116 %package extension-kdbus
117 Summary:        Extension for systemd to support KDBUS in Tizen
118 Requires:       %{name} = %{version}-%{release}
119
120 %description extension-kdbus
121 This modifies systemd to support KDBUS in Tizen.
122
123 %prep
124 %setup -q
125 cp %{SOURCE1001} .
126 cp %{SOURCE4} .
127
128 %build
129 %autogen
130 %configure \
131         --enable-kdbus \
132 %if ! %{WITH_RANDOMSEED}
133         --disable-randomseed \
134 %endif
135 %if ! %{?WITH_COREDUMP}
136         --disable-coredump \
137 %endif
138 %if ! %{?WITH_BACKLIGHT}
139         --disable-backlight \
140 %endif
141 %if ! %{?WITH_TIMEDATED}
142         --disable-timedated \
143 %endif
144 %if ! %{WITH_RFKILL}
145         --disable-rfkill \
146 %endif
147         --enable-compat-libs \
148         --disable-hwdb \
149         --disable-sysusers \
150         --disable-firstboot \
151         --disable-polkit \
152         --disable-timesyncd \
153         --disable-resolved \
154         --disable-networkd \
155 %if ! %{?WITH_MACHINED}
156         --disable-machined \
157 %endif
158         --disable-importd \
159         --disable-gcrypt \
160         --libexecdir=%{_prefix}/lib \
161         --docdir=%{_docdir}/systemd \
162         --disable-static \
163         --with-sysvinit-path= \
164         --with-sysvrcnd-path= \
165         --with-smack-run-label=System::Privileged \
166 %if ! %{?with_multiuser}
167         --disable-logind \
168 %endif
169         cc_cv_CFLAGS__flto=no
170 make %{?_smp_mflags} \
171         systemunitdir=%{_unitdir} \
172         userunitdir=%{_unitdir_user}
173
174 # compile test-runner for 'dbus-integration-test' framework
175 %__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
176
177 %install
178 %make_install
179 %find_lang %{name}
180 cat <<EOF >> systemd.lang
181 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
182 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
183 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
184 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
185 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
186 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
187 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
188 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
189 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
190 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
191 EOF
192
193 # udev links
194 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
195 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
196 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
197
198 # Create SysV compatibility symlinks. systemctl/systemd are smart
199 # enough to detect in which way they are called.
200 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
201 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
202 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
203 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
204 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
205 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
206 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
207 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
208
209 # legacy links
210 %if %{?with_multiuser}
211 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
212 %endif
213
214 # We create all wants links manually at installation time to make sure
215 # they are not owned and hence overriden by rpm after the used deleted
216 # them.
217 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
218
219 # Make sure these directories are properly owned
220 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
221 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
222 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
223 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
224
225 # Make sure the user generators dir exists too
226 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
227 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
228
229 # Create new-style configuration files so that we can ghost-own them
230 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
231 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
232 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
233 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
234 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
235 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
236
237 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
238 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
239
240 # Make sure the shutdown/sleep drop-in dirs exist
241 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
242 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
243
244 # Make sure the NTP units dir exists
245 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
246
247 # Install modprobe fragment
248 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
249
250 # Fix the dangling /var/lock -> /run/lock symlink
251 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
252
253 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
254
255 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
256
257 rm -rf %{buildroot}/%{_docdir}/%{name}
258
259 # Disable some useless services in Tizen
260 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
261 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
262 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
263 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
264 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
265 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
266
267 # Move macros to the proper location for Tizen
268 mkdir -p %{buildroot}%{_sysconfdir}/rpm
269 install -m644 src/core/macros.systemd %{buildroot}%{_sysconfdir}/rpm/macros.systemd
270 rm -f %{buildroot}%{_prefix}/lib/rpm/macros.d/macros.systemd
271
272 # Exclude ELF binaries
273 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
274 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
275 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
276 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
277
278 # Marker file for kdbus
279 touch %{buildroot}/%{_sysconfdir}/systemd/extension-kdbus
280
281 # Preapre tests for 'dbus-integration-test' framework
282 install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
283 mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
284 mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
285
286 # Shell Completion
287 %if ! %{?WITH_BASH_COMPLETION}
288 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
289 %endif
290 %if ! %{?WITH_ZSH_COMPLETION}
291 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
292 %endif
293
294 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
295
296 # Upgrade script from 2.4 to 3.0
297 install -m 755 -d %{buildroot}%{_datadir}/upgrade/scripts
298 install -m 755 %{SOURCE3} %{buildroot}%{_datadir}/upgrade/scripts
299
300 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
301 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
302 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
303 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
304
305 # end of install
306 %pre
307 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
308 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
309 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
310 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
311 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
312
313 # Rename configuration files that changed their names
314 %if %{?with_multiuser}
315 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
316 %endif
317 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
318
319 %post
320 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
321 %if %{WITH_RANDOMSEED}
322 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
323 %endif
324 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
325 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
326 /usr/bin/mkdir -p /etc/systemd/network
327 /usr/bin/ln -sf /dev/null /etc/systemd/network/99-default.link
328
329 #link system, user unit directory in conf dir to opt conf dir
330 /usr/bin/mkdir -p /opt/etc/systemd
331 /usr/bin/mv /etc/systemd/system /opt/etc/systemd/system 
332 /usr/bin/mv /etc/systemd/user /opt/etc/systemd/user
333 /usr/bin/ln -s ../../opt/etc/systemd/system /etc/systemd/system
334 /usr/bin/ln -s ../../opt/etc/systemd/user /etc/systemd/user
335
336 %postun
337 if [ $1 -ge 1 ] ; then
338         /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
339         /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
340 fi
341
342 %preun
343 if [ $1 -eq 0 ] ; then
344         /usr/bin/systemctl disable \
345                 getty@.service \
346                 remote-fs.target \
347                 systemd-readahead-replay.service \
348                 systemd-readahead-collect.service >/dev/null 2>&1 || :
349 fi
350
351 %post -n libsystemd -p /sbin/ldconfig
352 %postun -n libsystemd  -p /sbin/ldconfig
353
354 %lang_package
355
356 %files
357 %manifest %{name}.manifest
358 %license LICENSE.LGPL2.1  LICENSE.GPL2
359 %if %{with_multiuser}
360 %config %{_sysconfdir}/pam.d/systemd-user
361 %endif
362 %{_bindir}/bootctl
363 %{_bindir}/busctl
364 %{_bindir}/kernel-install
365 %if %{?WITH_MACHINED}
366 %{_bindir}/machinectl
367 %endif
368 %{_bindir}/systemd-run
369 %dir %{_prefix}/lib/kernel
370 %dir %{_prefix}/lib/kernel/install.d
371 %{_prefix}/lib/kernel/install.d/50-depmod.install
372 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
373 %{_bindir}/hostnamectl
374 %{_bindir}/localectl
375 %if %{?WITH_COREDUMP}
376 %{_bindir}/coredumpctl
377 %endif
378 %if %{?WITH_TIMEDATED}
379 %{_bindir}/timedatectl
380 %endif
381 %dir %{_sysconfdir}/systemd
382 %{_sysconfdir}/systemd/system
383 %{_sysconfdir}/systemd/user
384 %dir %{_sysconfdir}/tmpfiles.d
385 %dir %{_sysconfdir}/sysctl.d
386 %dir %{_sysconfdir}/modules-load.d
387 %dir %{_sysconfdir}/binfmt.d
388 %if %{?WITH_BASH_COMPLETION}
389 %{_datadir}/bash-completion/*
390 %endif
391 %if %{?WITH_ZSH_COMPLETION}
392 %dir %{_datadir}/zsh/site-functions
393 %{_datadir}/zsh/site-functions/*
394 %endif
395 %dir %{_sysconfdir}/udev
396 %dir %{_sysconfdir}/udev/rules.d
397 %dir %{_prefix}/lib/systemd
398 %dir %{_prefix}/lib/systemd/system
399 %dir %{_prefix}/lib/systemd/system-generators
400 %dir %{_prefix}/lib/systemd/user-generators
401 %dir %{_prefix}/lib/systemd/system-preset
402 %dir %{_prefix}/lib/systemd/user-preset
403 %dir %{_prefix}/lib/systemd/system-shutdown
404 %dir %{_prefix}/lib/systemd/system-sleep
405 %dir %{_prefix}/lib/tmpfiles.d
406 %dir %{_prefix}/lib/sysctl.d
407 %dir %{_prefix}/lib/modules-load.d
408 %dir %{_prefix}/lib/binfmt.d
409 %dir %{_prefix}/lib/firmware
410 %dir %{_prefix}/lib/firmware/updates
411 %dir %{_datadir}/systemd
412 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
413 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
414 %if %{?with_multiuser}
415 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
416 %endif
417 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
418 %if %{?WITH_TIMEDATED}
419 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
420 %endif
421 %if %{?WITH_MACHINED}
422 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
423 %endif
424 %if %{?WITH_COREDUMP}
425 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
426 %endif
427 %config(noreplace) %{_sysconfdir}/systemd/system.conf
428 %config(noreplace) %{_sysconfdir}/systemd/user.conf
429 %if %{?with_multiuser}
430 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
431 %endif
432 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
433 %config(noreplace) %{_sysconfdir}/udev/udev.conf
434 %{_sysconfdir}/xdg/systemd
435 %ghost %config(noreplace) %{_sysconfdir}/hostname
436 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
437 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
438 %ghost %config(noreplace) %{_sysconfdir}/machine-id
439 %ghost %config(noreplace) %{_sysconfdir}/machine-info
440 %ghost %config(noreplace) %{_sysconfdir}/timezone
441 %exclude %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
442 %{_bindir}/systemd
443 %{_bindir}/systemctl
444 %{_bindir}/systemd-notify
445 %{_bindir}/systemd-ask-password
446 %{_bindir}/systemd-tty-ask-password-agent
447 %{_bindir}/systemd-machine-id-setup
448 %{_bindir}/systemd-socket-activate
449 %if %{?with_multiuser}
450 %{_bindir}/loginctl
451 %{_bindir}/systemd-loginctl
452 %endif
453 %{_bindir}/journalctl
454 %{_bindir}/systemd-tmpfiles
455 %{_bindir}/systemd-nspawn
456 %{_bindir}/systemd-stdio-bridge
457 %{_bindir}/systemd-cat
458 %{_bindir}/systemd-cgls
459 %{_bindir}/systemd-cgtop
460 %{_bindir}/systemd-delta
461 %{_bindir}/systemd-detect-virt
462 %if %{?with_multiuser}
463 %{_bindir}/systemd-inhibit
464 %endif
465 %{_bindir}/udevadm
466 %{_bindir}/systemd-escape
467 %{_bindir}/systemd-path
468 %{_prefix}/lib/sysctl.d/*.conf
469 %{_prefix}/lib/systemd/systemd
470 %{_prefix}/lib/systemd/system
471 %exclude %{_prefix}/lib/systemd/resolv.conf
472
473 %dir %{_prefix}/lib/systemd/system/basic.target.wants
474 %dir %{_prefix}/lib/systemd/user
475 %dir %{_prefix}/lib/systemd/network
476 %{_prefix}/lib/systemd/user/basic.target
477 %{_prefix}/lib/systemd/user/bluetooth.target
478 %{_prefix}/lib/systemd/user/exit.target
479 %{_prefix}/lib/systemd/user/printer.target
480 %{_prefix}/lib/systemd/user/shutdown.target
481 %{_prefix}/lib/systemd/user/sockets.target
482 %{_prefix}/lib/systemd/user/sound.target
483 %{_prefix}/lib/systemd/user/systemd-exit.service
484 %{_prefix}/lib/systemd/user/paths.target
485 %{_prefix}/lib/systemd/user/smartcard.target
486 %{_prefix}/lib/systemd/user/timers.target
487 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
488 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
489 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
490 %{_prefix}/lib/systemd/user/default.target
491 %{_prefix}/lib/systemd/network/99-default.link
492 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
493
494 %{_prefix}/lib/systemd/libsystemd-shared-231.so
495 %{_prefix}/lib/systemd/libsystemd-shared.so
496 %{_prefix}/lib/systemd/systemd-*
497 %dir %{_prefix}/lib/systemd/catalog
498 %{_prefix}/lib/systemd/catalog/systemd.catalog
499 %{_prefix}/lib/udev
500 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
501 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
502 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
503 %{_prefix}/lib/tmpfiles.d/home.conf
504 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
505 %{_prefix}/lib/tmpfiles.d/legacy.conf
506 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
507 %{_prefix}/lib/tmpfiles.d/systemd.conf
508 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
509 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
510 %{_prefix}/lib/tmpfiles.d/tmp.conf
511 %{_prefix}/lib/tmpfiles.d/var.conf
512 %{_prefix}/lib/tmpfiles.d/x11.conf
513 %{_sbindir}/init
514 %{_sbindir}/reboot
515 %{_sbindir}/halt
516 %{_sbindir}/poweroff
517 %{_sbindir}/shutdown
518 %{_sbindir}/telinit
519 %{_sbindir}/runlevel
520 %{_sbindir}/udevadm
521 %{_datadir}/systemd/kbd-model-map
522 %{_datadir}/systemd/language-fallback-map
523 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
525 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
526 %if %{?with_multiuser}
527 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
528 %endif
529 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
530 %if %{?WITH_TIMEDATED}
531 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
532 %endif
533 %if %{?WITH_MACHINED}
534 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
535 %endif
536 %dir %{_datadir}/factory/
537 %dir %{_datadir}/factory/etc
538 %dir %{_datadir}/factory/etc/pam.d
539 %{_datadir}/factory/etc/nsswitch.conf
540 %{_datadir}/factory/etc/pam.d/other
541 %{_datadir}/factory/etc/pam.d/system-auth
542
543 %{_localstatedir}/log/journal
544
545 %{_datadir}/upgrade/scripts/500.systemd_upgrade.sh
546
547 %files -n libsystemd
548 %manifest %{name}.manifest
549 %license LICENSE.LGPL2.1
550 %if %{?with_multiuser}
551 %{_libdir}/security/pam_systemd.so
552 %endif
553 %{_libdir}/libsystemd.so.*
554 %{_libdir}/libudev.so.*
555 %{_libdir}/libnss_myhostname.so.2
556 %if %{?WITH_MACHINED}
557 %{_libdir}/libnss_mymachines.so.2
558 %endif
559
560 %files extension-kdbus
561 %manifest %{name}.manifest
562 %license LICENSE.LGPL2.1  LICENSE.GPL2
563 %{_sysconfdir}/systemd/extension-kdbus
564 %{_prefix}/lib/systemd/user/busnames.target
565 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
566 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
567
568 %files devel
569 %manifest %{name}.manifest
570 %{_libdir}/libudev.so
571 %{_libdir}/libsystemd.so
572 %dir %{_includedir}/systemd
573 %{_includedir}/systemd/sd-bus.h
574 %{_includedir}/systemd/sd-bus-protocol.h
575 %{_includedir}/systemd/sd-bus-vtable.h
576 %{_includedir}/systemd/sd-event.h
577 %{_includedir}/systemd/_sd-common.h
578 %{_includedir}/systemd/sd-daemon.h
579 %{_includedir}/systemd/sd-id128.h
580 %{_includedir}/systemd/sd-journal.h
581 %{_includedir}/systemd/sd-login.h
582 %{_includedir}/systemd/sd-messages.h
583 %{_includedir}/libudev.h
584 %{_libdir}/pkgconfig/libudev.pc
585 %{_libdir}/pkgconfig/libsystemd.pc
586 %{_datadir}/pkgconfig/systemd.pc
587 %{_datadir}/pkgconfig/udev.pc
588 %{_libdir}/pkgconfig/libsystemd-daemon.pc
589 %{_libdir}/pkgconfig/libsystemd-id128.pc
590 %{_libdir}/pkgconfig/libsystemd-journal.pc
591 %{_libdir}/pkgconfig/libsystemd-login.pc
592 %{_sysconfdir}/rpm/macros.systemd
593
594 %files analyze
595 %manifest %{name}.manifest
596 %{_bindir}/systemd-analyze
597
598 %files tests
599 %manifest %{name}.manifest
600 %{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
601 %{_prefix}/lib/dbus-tests/runner/systemd-tests
602
603 %docs_package