Set the smack label of executable binary tools
[platform/upstream/systemd.git] / packaging / systemd.spec
1 # "enable foo" will turn into --enable-foo or --disable-foo
2 # depending "with_foo" macro
3 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
4
5 %define WITH_RANDOMSEED 0
6 %define WITH_BASH_COMPLETION 0
7 %define WITH_ZSH_COMPLETION 0
8 %define WITH_COREDUMP 0
9 %define WITH_BACKLIGHT 0
10 %define WITH_TIMEDATED 0
11 %define WITH_RFKILL 0
12 %define WITH_MACHINED 0
13 %define WITH_DOC 0
14 %define WITH_HOSTNAMED 0
15
16 Name:           systemd
17 Version:        231
18 Release:        0%{?release_flags}
19 # For a breakdown of the licensing, see README
20 License:        LGPL-2.1+ and GPL-2.0+
21 Summary:        A System and Service Manager
22 Url:            http://www.freedesktop.org/wiki/Software/systemd
23 Group:          Base/Startup
24 Source0:        https://github.com/systemd/systemd/archive/v%{version}.tar.gz
25 Source1:        pamconsole-tmp.conf
26 Source2:        %{name}-rpmlintrc
27 Source3:        test-runner.c
28 Source1001:     systemd.manifest
29 BuildRequires:  gperf
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libacl-devel
32 BuildRequires:  libblkid-devel >= 2.20
33 BuildRequires:  libcap-devel
34 BuildRequires:  libgcrypt-devel
35 BuildRequires:  libkmod-devel >= 14
36 %if %{?WITH_DOC}
37 BuildRequires:  xsltproc
38 BuildRequires:  docbook-xsl-stylesheets
39 %endif
40 BuildRequires:  pam-devel
41 BuildRequires:  pkgconfig
42 # BuildRequires:  pkgconfig(dbus-1)     # for remove circular dependency on OBS
43 BuildRequires:  pkgconfig(glib-2.0)
44 BuildRequires:  pkgconfig(liblzma)
45 BuildRequires:  pkgconfig(libkmod)
46 BuildRequires:  pkgconfig(mount)
47 # Requires:       dbus                  # for remove circular dependency on OBS
48 Requires:       filesystem
49 Requires(post): coreutils
50 Requires(pre):  coreutils
51 Requires(pre):  /usr/bin/getent
52 Requires(pre):  /usr/sbin/groupadd
53
54 Obsoletes:      SysVinit < 2.86-24
55 Obsoletes:      sysvinit < 2.86-24
56 Provides:       SysVinit = 2.86-24
57 Provides:       sysvinit = 2.86-24
58 Provides:       /bin/systemctl
59 Provides:       /sbin/shutdown
60 Provides:       udev = %{version}
61 Obsoletes:      udev < 183
62
63 %description
64 systemd is a system and service manager for Linux, compatible with
65 SysV and LSB init scripts. systemd provides aggressive parallelization
66 capabilities, uses socket and D-Bus activation for starting services,
67 offers on-demand starting of daemons, keeps track of processes using
68 Linux cgroups, supports snapshotting and restoring of the system
69 state, maintains mount and automount points and implements an
70 elaborate transactional dependency-based service control logic. It can
71 work as a drop-in replacement for sysvinit.
72
73 %package -n libsystemd
74 License:        LGPL-2.1+
75 Summary:        Systemd libraries
76 Group:          Base/Startup
77 Obsoletes:      libudev < 183
78 Provides:       libudev = %{version}
79 Obsoletes:      systemd < 185-4
80 Conflicts:      systemd < 185-4
81
82 %description -n libsystemd
83 Libraries for systemd and udev, as well as the systemd PAM module.
84
85 %package devel
86 License:        LGPL-2.1+
87 Summary:        Development headers for systemd
88 Requires:       %{name} = %{version}
89 Requires:               libsystemd = %{version}
90 Provides:       libudev-devel = %{version}
91 Obsoletes:      libudev-devel < 183
92
93 %description devel
94 Development headers and auxiliary files for developing applications for systemd.
95
96 %package analyze
97 License:        LGPL-2.1+
98 Summary:        Tool for processing systemd profiling information
99 Requires:       %{name} = %{version}
100 Obsoletes:      systemd < 38-5
101
102 %description analyze
103 'systemd-analyze blame' lists which systemd unit needed how much time to finish
104 initialization at boot.
105 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
106 at boot.
107
108 %package tests
109 License:        LGPL-2.1+ and BSD-2-Clause
110 Summary:        Set of tests for sd-bus component
111 Requires:       %{name} = %{version}
112
113 %description tests
114 This package is part of 'dbus-integratnion-tests' framework and contains set of tests
115 for sd-bus component (DBUS API C library).
116
117 %package extension-kdbus
118 Summary:        Extension for systemd to support KDBUS in Tizen
119 Requires:       %{name} = %{version}-%{release}
120
121 %description extension-kdbus
122 This modifies systemd to support KDBUS in Tizen.
123
124 %prep
125 %setup -q
126 cp %{SOURCE1001} .
127 cp %{SOURCE3} .
128
129 %build
130 %autogen
131 %configure \
132         --enable-kdbus \
133 %if ! %{WITH_RANDOMSEED}
134         --disable-randomseed \
135 %endif
136 %if ! %{?WITH_COREDUMP}
137         --disable-coredump \
138 %endif
139 %if ! %{?WITH_BACKLIGHT}
140         --disable-backlight \
141 %endif
142 %if ! %{?WITH_TIMEDATED}
143         --disable-timedated \
144 %endif
145 %if ! %{WITH_RFKILL}
146         --disable-rfkill \
147 %endif
148         --enable-compat-libs \
149         --disable-hwdb \
150         --disable-sysusers \
151         --disable-firstboot \
152         --disable-polkit \
153         --disable-timesyncd \
154         --disable-resolved \
155         --disable-networkd \
156 %if ! %{?WITH_MACHINED}
157         --disable-machined \
158 %endif
159 %if ! %{?WITH_HOSTNAMED}
160         --disable-hostnamed \
161 %endif
162         --disable-importd \
163         --disable-gcrypt \
164         --libexecdir=%{_prefix}/lib \
165         --docdir=%{_docdir}/systemd \
166 %if ! %{?WITH_DOC}
167         --disable-manpages \
168 %endif
169         --disable-static \
170         --with-rpmmacrosdir=%{_sysconfdir}/rpm/ \
171         --with-sysvinit-path= \
172         --with-sysvrcnd-path= \
173         --with-smack-run-label=System::Privileged \
174         cc_cv_CFLAGS__flto=no
175 make %{?_smp_mflags} \
176         systemunitdir=%{_unitdir} \
177         userunitdir=%{_unitdir_user}
178
179 # compile test-runner for 'dbus-integration-test' framework
180 %__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
181
182 %install
183 %make_install
184 %find_lang %{name}
185 cat <<EOF >> systemd.lang
186 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
187 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
188 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
189 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
190 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
191 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
192 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
193 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
194 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
195 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
196 EOF
197
198 # udev links
199 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
200 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
201 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
202
203 # Create SysV compatibility symlinks. systemctl/systemd are smart
204 # enough to detect in which way they are called.
205 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
206 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
207 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
208 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
209 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
210 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
211 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
212 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
213
214 # legacy links
215 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
216
217 # We create all wants links manually at installation time to make sure
218 # they are not owned and hence overriden by rpm after the used deleted
219 # them.
220 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
221
222 # Make sure these directories are properly owned
223 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
224 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
225 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
226 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
227
228 # Make sure the user generators dir exists too
229 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
230 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
231
232 # Create new-style configuration files so that we can ghost-own them
233 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
234 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
235 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
236 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
237 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
238 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
239
240 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
241 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
242
243 # Make sure the shutdown/sleep drop-in dirs exist
244 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
245 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
246
247 # Make sure the NTP units dir exists
248 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
249
250 # Install modprobe fragment
251 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
252
253 # Fix the dangling /var/lock -> /run/lock symlink
254 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
255
256 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
257
258 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
259
260 rm -rf %{buildroot}/%{_docdir}/%{name}
261
262 # Disable some useless services in Tizen
263 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
264 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
265 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
266 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
267 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
268 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
269 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-tmpfiles-clean.timer
270 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-tmpfiles-clean.service
271 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/timers.target.wants/systemd-tmpfiles-clean.timer
272
273 # Exclude ELF binaries
274 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
275 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
276 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
277 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
278
279 # Marker file for kdbus
280 touch %{buildroot}/%{_sysconfdir}/systemd/extension-kdbus
281
282 # Preapre tests for 'dbus-integration-test' framework
283 install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
284 mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
285 mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
286
287 # Shell Completion
288 %if ! %{?WITH_BASH_COMPLETION}
289 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
290 %endif
291 %if ! %{?WITH_ZSH_COMPLETION}
292 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
293 %endif
294
295 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
296
297 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
298 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
299 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
300 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
301
302 # end of install
303 %pre
304 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
305 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
306 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
307 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
308 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
309
310 # Rename configuration files that changed their names
311 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
312 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
313
314 %post
315 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
316 %if %{WITH_RANDOMSEED}
317 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
318 %endif
319 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
320 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
321 /usr/bin/mkdir -p /etc/systemd/network
322 /usr/bin/ln -sf /dev/null /etc/systemd/network/99-default.link
323
324 # link system, user unit directory in conf dir to opt conf dir
325 /usr/bin/mkdir -p /opt/etc/systemd
326 /usr/bin/mv /etc/systemd/system /opt/etc/systemd/system 
327 /usr/bin/mv /etc/systemd/user /opt/etc/systemd/user
328 /usr/bin/ln -s ../../opt/etc/systemd/system /etc/systemd/system
329 /usr/bin/ln -s ../../opt/etc/systemd/user /etc/systemd/user
330
331 # Set the smack label of executable binary tools
332 chsmack %{_bindir}/bootctl -a "System::Tools"
333 chsmack %{_bindir}/busctl -a "System::Tools"
334 chsmack %{_bindir}/kernel-install -a "System::Tools"
335 %if %{?WITH_MACHINED}
336 chsmack %{_bindir}/machinectl -a "System::Tools"
337 %endif
338 chsmack %{_bindir}/systemd-run -a "System::Tools"
339 %if %{?WITH_HOSTNAMED}
340 chsmack %{_bindir}/hostnamectl -a "System::Tools"
341 %endif
342 chsmack %{_bindir}/localectl -a "System::Tools"
343 %if %{?WITH_COREDUMP}
344 chsmack %{_bindir}/coredumpctl -a "System::Tools"
345 %endif
346 %if %{?WITH_TIMEDATED}
347 chsmack %{_bindir}/timedatectl -a "System::Tools"
348 %endif
349 chsmack %{_bindir}/systemd -a "System::Tools"
350 chsmack %{_bindir}/systemctl -a "System::Tools"
351 chsmack %{_bindir}/systemd-notify -a "System::Tools"
352 chsmack %{_bindir}/systemd-ask-password -a "System::Tools"
353 chsmack %{_bindir}/systemd-tty-ask-password-agent -a "System::Tools"
354 chsmack %{_bindir}/systemd-machine-id-setup -a "System::Tools"
355 chsmack %{_bindir}/systemd-socket-activate -a "System::Tools"
356 chsmack %{_bindir}/loginctl -a "System::Tools"
357 chsmack %{_bindir}/systemd-loginctl -a "System::Tools"
358 chsmack %{_bindir}/journalctl -a "System::Tools"
359 chsmack %{_bindir}/systemd-tmpfiles -a "System::Tools"
360 chsmack %{_bindir}/systemd-nspawn -a "System::Tools"
361 chsmack %{_bindir}/systemd-stdio-bridge -a "System::Tools"
362 chsmack %{_bindir}/systemd-cat -a "System::Tools"
363 chsmack %{_bindir}/systemd-cgls -a "System::Tools"
364 chsmack %{_bindir}/systemd-cgtop -a "System::Tools"
365 chsmack %{_bindir}/systemd-delta -a "System::Tools"
366 chsmack %{_bindir}/systemd-detect-virt -a "System::Tools"
367 chsmack %{_bindir}/systemd-inhibit -a "System::Tools"
368 chsmack %{_bindir}/udevadm -a "System::Tools"
369 chsmack %{_bindir}/systemd-escape -a "System::Tools"
370 chsmack %{_bindir}/systemd-path -a "System::Tools"
371 chsmack %{_prefix}/lib/systemd/* -a "System::Tools"
372
373 %postun
374 if [ $1 -ge 1 ] ; then
375         /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
376         /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
377 fi
378
379 %preun
380 if [ $1 -eq 0 ] ; then
381         /usr/bin/systemctl disable \
382                 getty@.service \
383                 remote-fs.target \
384                 systemd-readahead-replay.service \
385                 systemd-readahead-collect.service >/dev/null 2>&1 || :
386 fi
387
388 %post -n libsystemd -p /sbin/ldconfig
389 %postun -n libsystemd  -p /sbin/ldconfig
390
391 %lang_package
392
393 %files
394 %manifest %{name}.manifest
395 %license LICENSE.LGPL2.1  LICENSE.GPL2
396 %config %{_sysconfdir}/pam.d/systemd-user
397 %{_bindir}/bootctl
398 %{_bindir}/busctl
399 %{_bindir}/kernel-install
400 %if %{?WITH_MACHINED}
401 %{_bindir}/machinectl
402 %endif
403 %{_bindir}/systemd-run
404 %dir %{_prefix}/lib/kernel
405 %dir %{_prefix}/lib/kernel/install.d
406 %{_prefix}/lib/kernel/install.d/50-depmod.install
407 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
408 %if %{?WITH_HOSTNAMED}
409 %{_bindir}/hostnamectl
410 %endif
411 %{_bindir}/localectl
412 %if %{?WITH_COREDUMP}
413 %{_bindir}/coredumpctl
414 %endif
415 %if %{?WITH_TIMEDATED}
416 %{_bindir}/timedatectl
417 %endif
418 %dir %{_sysconfdir}/systemd
419 %{_sysconfdir}/systemd/system
420 %{_sysconfdir}/systemd/user
421 %dir %{_sysconfdir}/tmpfiles.d
422 %dir %{_sysconfdir}/sysctl.d
423 %dir %{_sysconfdir}/modules-load.d
424 %dir %{_sysconfdir}/binfmt.d
425 %if %{?WITH_BASH_COMPLETION}
426 %{_datadir}/bash-completion/*
427 %endif
428 %if %{?WITH_ZSH_COMPLETION}
429 %dir %{_datadir}/zsh/site-functions
430 %{_datadir}/zsh/site-functions/*
431 %endif
432 %dir %{_sysconfdir}/udev
433 %dir %{_sysconfdir}/udev/rules.d
434 %dir %{_prefix}/lib/systemd
435 %dir %{_prefix}/lib/systemd/system
436 %dir %{_prefix}/lib/systemd/system-generators
437 %dir %{_prefix}/lib/systemd/user-generators
438 %dir %{_prefix}/lib/systemd/system-preset
439 %dir %{_prefix}/lib/systemd/user-preset
440 %dir %{_prefix}/lib/systemd/system-shutdown
441 %dir %{_prefix}/lib/systemd/system-sleep
442 %dir %{_prefix}/lib/tmpfiles.d
443 %dir %{_prefix}/lib/sysctl.d
444 %dir %{_prefix}/lib/modules-load.d
445 %dir %{_prefix}/lib/binfmt.d
446 %dir %{_prefix}/lib/firmware
447 %dir %{_prefix}/lib/firmware/updates
448 %dir %{_datadir}/systemd
449 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
450 %if %{?WITH_HOSTNAMED}
451 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
452 %endif
453 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
454 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
455 %if %{?WITH_TIMEDATED}
456 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
457 %endif
458 %if %{?WITH_MACHINED}
459 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
460 %endif
461 %if %{?WITH_COREDUMP}
462 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
463 %endif
464 %config(noreplace) %{_sysconfdir}/systemd/system.conf
465 %config(noreplace) %{_sysconfdir}/systemd/user.conf
466 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
467 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
468 %config(noreplace) %{_sysconfdir}/udev/udev.conf
469 %{_sysconfdir}/xdg/systemd
470 %ghost %config(noreplace) %{_sysconfdir}/hostname
471 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
472 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
473 %ghost %config(noreplace) %{_sysconfdir}/machine-id
474 %ghost %config(noreplace) %{_sysconfdir}/machine-info
475 %ghost %config(noreplace) %{_sysconfdir}/timezone
476 %exclude %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
477 %{_bindir}/systemd
478 %{_bindir}/systemctl
479 %{_bindir}/systemd-notify
480 %{_bindir}/systemd-ask-password
481 %{_bindir}/systemd-tty-ask-password-agent
482 %{_bindir}/systemd-machine-id-setup
483 %{_bindir}/systemd-socket-activate
484 %{_bindir}/loginctl
485 %{_bindir}/systemd-loginctl
486 %{_bindir}/journalctl
487 %{_bindir}/systemd-tmpfiles
488 %{_bindir}/systemd-nspawn
489 %{_bindir}/systemd-stdio-bridge
490 %{_bindir}/systemd-cat
491 %{_bindir}/systemd-cgls
492 %{_bindir}/systemd-cgtop
493 %{_bindir}/systemd-delta
494 %{_bindir}/systemd-detect-virt
495 %{_bindir}/systemd-inhibit
496 %{_bindir}/udevadm
497 %{_bindir}/systemd-escape
498 %{_bindir}/systemd-path
499 %{_prefix}/lib/sysctl.d/*.conf
500 %{_prefix}/lib/systemd/systemd
501 %{_prefix}/lib/systemd/system
502 %exclude %{_prefix}/lib/systemd/resolv.conf
503
504 %dir %{_prefix}/lib/systemd/system/basic.target.wants
505 %dir %{_prefix}/lib/systemd/user
506 %dir %{_prefix}/lib/systemd/network
507 %{_prefix}/lib/systemd/user/basic.target
508 %{_prefix}/lib/systemd/user/bluetooth.target
509 %{_prefix}/lib/systemd/user/exit.target
510 %{_prefix}/lib/systemd/user/printer.target
511 %{_prefix}/lib/systemd/user/shutdown.target
512 %{_prefix}/lib/systemd/user/sockets.target
513 %{_prefix}/lib/systemd/user/sound.target
514 %{_prefix}/lib/systemd/user/systemd-exit.service
515 %{_prefix}/lib/systemd/user/paths.target
516 %{_prefix}/lib/systemd/user/smartcard.target
517 %{_prefix}/lib/systemd/user/timers.target
518 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
519 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
520 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
521 %{_prefix}/lib/systemd/user/default.target
522 %{_prefix}/lib/systemd/network/99-default.link
523 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
524
525 %{_prefix}/lib/systemd/libsystemd-shared-231.so
526 %{_prefix}/lib/systemd/libsystemd-shared.so
527 %{_prefix}/lib/systemd/systemd-*
528 %dir %{_prefix}/lib/systemd/catalog
529 %{_prefix}/lib/systemd/catalog/systemd.catalog
530 %{_prefix}/lib/udev
531 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
532 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
533 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
534 %{_prefix}/lib/tmpfiles.d/home.conf
535 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
536 %{_prefix}/lib/tmpfiles.d/legacy.conf
537 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
538 %{_prefix}/lib/tmpfiles.d/systemd.conf
539 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
540 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
541 %{_prefix}/lib/tmpfiles.d/tmp.conf
542 %{_prefix}/lib/tmpfiles.d/var.conf
543 %{_prefix}/lib/tmpfiles.d/x11.conf
544 %{_sbindir}/init
545 %{_sbindir}/reboot
546 %{_sbindir}/halt
547 %{_sbindir}/poweroff
548 %{_sbindir}/shutdown
549 %{_sbindir}/telinit
550 %{_sbindir}/runlevel
551 %{_sbindir}/udevadm
552 %{_datadir}/systemd/graphinfo.gvpr
553 %{_datadir}/systemd/kbd-model-map
554 %{_datadir}/systemd/language-fallback-map
555 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
556 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
557 %if %{?WITH_HOSTNAMED}
558 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
559 %endif
560 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
561 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
562 %if %{?WITH_TIMEDATED}
563 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
564 %endif
565 %if %{?WITH_MACHINED}
566 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
567 %endif
568 %dir %{_datadir}/factory/
569 %dir %{_datadir}/factory/etc
570 %dir %{_datadir}/factory/etc/pam.d
571 %{_datadir}/factory/etc/nsswitch.conf
572 %{_datadir}/factory/etc/pam.d/other
573 %{_datadir}/factory/etc/pam.d/system-auth
574
575 %{_localstatedir}/log/journal
576
577 %files -n libsystemd
578 %manifest %{name}.manifest
579 %license LICENSE.LGPL2.1
580 %{_libdir}/security/pam_systemd.so
581 %{_libdir}/libsystemd.so.*
582 %{_libdir}/libudev.so.*
583 %{_libdir}/libnss_myhostname.so.2
584 %if %{?WITH_MACHINED}
585 %{_libdir}/libnss_mymachines.so.2
586 %endif
587
588 %files extension-kdbus
589 %manifest %{name}.manifest
590 %license LICENSE.LGPL2.1  LICENSE.GPL2
591 %{_sysconfdir}/systemd/extension-kdbus
592 %{_prefix}/lib/systemd/user/busnames.target
593 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
594 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
595
596 %files devel
597 %manifest %{name}.manifest
598 %{_libdir}/libudev.so
599 %{_libdir}/libsystemd.so
600 %dir %{_includedir}/systemd
601 %{_includedir}/systemd/sd-bus.h
602 %{_includedir}/systemd/sd-bus-protocol.h
603 %{_includedir}/systemd/sd-bus-vtable.h
604 %{_includedir}/systemd/sd-event.h
605 %{_includedir}/systemd/_sd-common.h
606 %{_includedir}/systemd/sd-daemon.h
607 %{_includedir}/systemd/sd-id128.h
608 %{_includedir}/systemd/sd-journal.h
609 %{_includedir}/systemd/sd-login.h
610 %{_includedir}/systemd/sd-messages.h
611 %{_includedir}/libudev.h
612 %{_libdir}/pkgconfig/libudev.pc
613 %{_libdir}/pkgconfig/libsystemd.pc
614 %{_datadir}/pkgconfig/systemd.pc
615 %{_datadir}/pkgconfig/udev.pc
616 %{_libdir}/pkgconfig/libsystemd-daemon.pc
617 %{_libdir}/pkgconfig/libsystemd-id128.pc
618 %{_libdir}/pkgconfig/libsystemd-journal.pc
619 %{_libdir}/pkgconfig/libsystemd-login.pc
620 %{_sysconfdir}/rpm/macros.systemd
621
622 %files analyze
623 %manifest %{name}.manifest
624 %license LICENSE.LGPL2.1
625 %{_bindir}/systemd-analyze
626
627 %files tests
628 %manifest %{name}.manifest
629 %{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
630 %{_prefix}/lib/dbus-tests/runner/systemd-tests
631
632 %if %{?WITH_DOC}
633 %docs_package
634 %endif