0517c1d624c164a131e44639178df97207c8c319
[platform/upstream/systemd.git] / packaging / systemd.spec
1 # "enable foo" will turn into --enable-foo or --disable-foo
2 # depending "with_foo" macro
3 %define enable() %{expand:%%{?with_%{1}:--enable-%{1}}%%{!?with_%{1}:--disable-%{1}}}
4
5 %define WITH_RANDOMSEED 0
6 %define WITH_BASH_COMPLETION 0
7 %define WITH_ZSH_COMPLETION 0
8 %define WITH_COREDUMP 0
9 %define WITH_BACKLIGHT 0
10 %define WITH_TIMEDATED 0
11 %define WITH_RFKILL 0
12 %define WITH_MACHINED 0
13 %define WITH_DOC 0
14 %define WITH_HOSTNAMED 0
15
16 Name:           systemd
17 Version:        231
18 Release:        0%{?release_flags}
19 # For a breakdown of the licensing, see README
20 License:        LGPL-2.1+ and GPL-2.0+
21 Summary:        A System and Service Manager
22 Url:            http://www.freedesktop.org/wiki/Software/systemd
23 Group:          Base/Startup
24 Source0:        https://github.com/systemd/systemd/archive/v%{version}.tar.gz
25 Source1:        pamconsole-tmp.conf
26 Source2:        %{name}-rpmlintrc
27 Source3:        test-runner.c
28 Source1001:     systemd.manifest
29 BuildRequires:  gperf
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libacl-devel
32 BuildRequires:  libblkid-devel >= 2.20
33 BuildRequires:  libcap-devel
34 BuildRequires:  libgcrypt-devel
35 BuildRequires:  libkmod-devel >= 14
36 %if %{?WITH_DOC}
37 BuildRequires:  xsltproc
38 BuildRequires:  docbook-xsl-stylesheets
39 %endif
40 BuildRequires:  pam-devel
41 BuildRequires:  pkgconfig
42 # BuildRequires:  pkgconfig(dbus-1)     # for remove circular dependency on OBS
43 BuildRequires:  pkgconfig(glib-2.0)
44 BuildRequires:  pkgconfig(liblzma)
45 BuildRequires:  pkgconfig(libkmod)
46 BuildRequires:  pkgconfig(mount)
47 # Requires:       dbus                  # for remove circular dependency on OBS
48 Requires:       filesystem
49 Requires(post): coreutils
50 Requires(pre):  coreutils
51 Requires(pre):  /usr/bin/getent
52 Requires(pre):  /usr/sbin/groupadd
53
54 Obsoletes:      SysVinit < 2.86-24
55 Obsoletes:      sysvinit < 2.86-24
56 Provides:       SysVinit = 2.86-24
57 Provides:       sysvinit = 2.86-24
58 Provides:       /bin/systemctl
59 Provides:       /sbin/shutdown
60 Provides:       udev = %{version}
61 Obsoletes:      udev < 183
62
63 %description
64 systemd is a system and service manager for Linux, compatible with
65 SysV and LSB init scripts. systemd provides aggressive parallelization
66 capabilities, uses socket and D-Bus activation for starting services,
67 offers on-demand starting of daemons, keeps track of processes using
68 Linux cgroups, supports snapshotting and restoring of the system
69 state, maintains mount and automount points and implements an
70 elaborate transactional dependency-based service control logic. It can
71 work as a drop-in replacement for sysvinit.
72
73 %package -n libsystemd
74 License:        LGPL-2.1+
75 Summary:        Systemd libraries
76 Group:          Base/Startup
77 Obsoletes:      libudev < 183
78 Provides:       libudev = %{version}
79 Obsoletes:      systemd < 185-4
80 Conflicts:      systemd < 185-4
81
82 %description -n libsystemd
83 Libraries for systemd and udev, as well as the systemd PAM module.
84
85 %package devel
86 License:        LGPL-2.1+
87 Summary:        Development headers for systemd
88 Requires:       %{name} = %{version}
89 Requires:               libsystemd = %{version}
90 Provides:       libudev-devel = %{version}
91 Obsoletes:      libudev-devel < 183
92
93 %description devel
94 Development headers and auxiliary files for developing applications for systemd.
95
96 %package analyze
97 License:        LGPL-2.1+
98 Summary:        Tool for processing systemd profiling information
99 Requires:       %{name} = %{version}
100 Obsoletes:      systemd < 38-5
101
102 %description analyze
103 'systemd-analyze blame' lists which systemd unit needed how much time to finish
104 initialization at boot.
105 'systemd-analyze plot' renders an SVG visualizing the parallel start of units
106 at boot.
107
108 %package tests
109 License:        LGPL-2.1+ and BSD-2-Clause
110 Summary:        Set of tests for sd-bus component
111 Requires:       %{name} = %{version}
112
113 %description tests
114 This package is part of 'dbus-integratnion-tests' framework and contains set of tests
115 for sd-bus component (DBUS API C library).
116
117 %package extension-kdbus
118 Summary:        Extension for systemd to support KDBUS in Tizen
119 Requires:       %{name} = %{version}-%{release}
120
121 %description extension-kdbus
122 This modifies systemd to support KDBUS in Tizen.
123
124 %prep
125 %setup -q
126 cp %{SOURCE1001} .
127 cp %{SOURCE3} .
128
129 %build
130 %autogen
131 %configure \
132         --enable-kdbus \
133 %if ! %{WITH_RANDOMSEED}
134         --disable-randomseed \
135 %endif
136 %if ! %{?WITH_COREDUMP}
137         --disable-coredump \
138 %endif
139 %if ! %{?WITH_BACKLIGHT}
140         --disable-backlight \
141 %endif
142 %if ! %{?WITH_TIMEDATED}
143         --disable-timedated \
144 %endif
145 %if ! %{WITH_RFKILL}
146         --disable-rfkill \
147 %endif
148         --enable-compat-libs \
149         --disable-hwdb \
150         --disable-sysusers \
151         --disable-firstboot \
152         --disable-polkit \
153         --disable-timesyncd \
154         --disable-resolved \
155         --disable-networkd \
156 %if ! %{?WITH_MACHINED}
157         --disable-machined \
158 %endif
159 %if ! %{?WITH_HOSTNAMED}
160         --disable-hostnamed \
161 %endif
162         --disable-importd \
163         --disable-gcrypt \
164         --libexecdir=%{_prefix}/lib \
165         --docdir=%{_docdir}/systemd \
166 %if ! %{?WITH_DOC}
167         --disable-manpages \
168 %endif
169         --disable-static \
170         --with-rpmmacrosdir=%{_sysconfdir}/rpm/ \
171         --with-sysvinit-path= \
172         --with-sysvrcnd-path= \
173         --with-smack-run-label=System::Privileged \
174         cc_cv_CFLAGS__flto=no
175 make %{?_smp_mflags} \
176         systemunitdir=%{_unitdir} \
177         userunitdir=%{_unitdir_user}
178
179 # compile test-runner for 'dbus-integration-test' framework
180 %__cc %{_builddir}/%{name}-%{version}/test-runner.c -o %{_builddir}/%{name}-%{version}/systemd-tests
181
182 %install
183 %make_install
184 %find_lang %{name}
185 cat <<EOF >> systemd.lang
186 %lang(be) /usr/lib/systemd/catalog/systemd.be.catalog
187 %lang(be) /usr/lib/systemd/catalog/systemd.be@latin.catalog
188 %lang(bg) /usr/lib/systemd/catalog/systemd.bg.catalog
189 %lang(fr) /usr/lib/systemd/catalog/systemd.fr.catalog
190 %lang(it) /usr/lib/systemd/catalog/systemd.it.catalog
191 %lang(pl) /usr/lib/systemd/catalog/systemd.pl.catalog
192 %lang(pt_BR) /usr/lib/systemd/catalog/systemd.pt_BR.catalog
193 %lang(ru) /usr/lib/systemd/catalog/systemd.ru.catalog
194 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_CN.catalog
195 %lang(zh) /usr/lib/systemd/catalog/systemd.zh_TW.catalog
196 EOF
197
198 # udev links
199 /usr/bin/mkdir -p %{buildroot}/%{_sbindir}
200 /usr/bin/ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
201 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/firmware/updates
202
203 # Create SysV compatibility symlinks. systemctl/systemd are smart
204 # enough to detect in which way they are called.
205 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_sbindir}/init
206 /usr/bin/ln -s ../lib/systemd/systemd %{buildroot}%{_bindir}/systemd
207 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/reboot
208 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/halt
209 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/poweroff
210 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/shutdown
211 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/telinit
212 /usr/bin/ln -s ../bin/systemctl %{buildroot}%{_sbindir}/runlevel
213
214 # legacy links
215 /usr/bin/ln -s loginctl %{buildroot}%{_bindir}/systemd-loginctl
216
217 # We create all wants links manually at installation time to make sure
218 # they are not owned and hence overriden by rpm after the used deleted
219 # them.
220 /usr/bin/rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
221
222 # Make sure these directories are properly owned
223 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/basic.target.wants
224 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/default.target.wants
225 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/dbus.target.wants
226 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system/syslog.target.wants
227
228 # Make sure the user generators dir exists too
229 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-generators
230 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-generators
231
232 # Create new-style configuration files so that we can ghost-own them
233 /usr/bin/touch %{buildroot}%{_sysconfdir}/hostname
234 /usr/bin/touch %{buildroot}%{_sysconfdir}/vconsole.conf
235 /usr/bin/touch %{buildroot}%{_sysconfdir}/locale.conf
236 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-id
237 /usr/bin/touch %{buildroot}%{_sysconfdir}/machine-info
238 /usr/bin/touch %{buildroot}%{_sysconfdir}/timezone
239
240 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-preset/
241 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/user-preset/
242
243 # Make sure the shutdown/sleep drop-in dirs exist
244 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-shutdown/
245 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/system-sleep/
246
247 # Make sure the NTP units dir exists
248 /usr/bin/mkdir -p %{buildroot}%{_prefix}/lib/systemd/ntp-units.d/
249
250 # Install modprobe fragment
251 /usr/bin/mkdir -p %{buildroot}%{_sysconfdir}/modprobe.d/
252
253 # Fix the dangling /var/lock -> /run/lock symlink
254 install -Dm644 tmpfiles.d/legacy.conf %{buildroot}%{_prefix}/lib/tmpfiles.d/legacy.conf
255
256 install -m644 %{SOURCE1} %{buildroot}%{_prefix}/lib/tmpfiles.d/
257
258 install -m 755 -d %{buildroot}/%{_prefix}/lib/systemd/system
259
260 rm -rf %{buildroot}/%{_docdir}/%{name}
261
262 # Disable some useless services in Tizen
263 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/dev-hugepages.mount
264 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/sys-fs-fuse-connections.mount
265 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-binfmt.service
266 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-modules-load.service
267 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path
268 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/multi-user.target.wants/systemd-ask-password-wall.path
269 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-tmpfiles-clean.timer
270 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/systemd-tmpfiles-clean.service
271 rm -rf %{buildroot}/%{_prefix}/lib/systemd/system/timers.target.wants/systemd-tmpfiles-clean.timer
272
273 # Exclude ELF binaries
274 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-debug-generator
275 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-efi-boot-generator
276 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-gpt-auto-generator
277 rm -f %{buildroot}/%{_prefix}/lib/systemd/system-generators/systemd-hibernate-resume-generator
278
279 # Marker file for kdbus
280 touch %{buildroot}/%{_sysconfdir}/systemd/extension-kdbus
281
282 # Preapre tests for 'dbus-integration-test' framework
283 install -D -m 755 %{_builddir}/%{name}-%{version}/systemd-tests %{buildroot}%{_prefix}/lib/dbus-tests/runner/systemd-tests
284 mkdir -p %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
285 mv %{_builddir}/%{name}-%{version}/test-bus-* %{buildroot}%{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
286
287 # Shell Completion
288 %if ! %{?WITH_BASH_COMPLETION}
289 rm -rf %{buildroot}/%{_datadir}/bash-completion/*
290 %endif
291 %if ! %{?WITH_ZSH_COMPLETION}
292 rm -rf %{buildroot}/%{_datadir}/zsh/site-functions/*
293 %endif
294
295 mkdir -p %{buildroot}/%{_localstatedir}/log/journal
296
297 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-daemon.pc
298 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-id128.pc
299 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-journal.pc
300 ln -sf ./libsystemd.pc %{buildroot}%{_libdir}/pkgconfig/libsystemd-login.pc
301
302 # end of install
303 %pre
304 /usr/bin/getent group cdrom >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
305 /usr/bin/getent group tape >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 33 tape >/dev/null 2>&1 || :
306 /usr/bin/getent group dialout >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 18 dialout >/dev/null 2>&1 || :
307 /usr/bin/getent group floppy >/dev/null 2>&1 || /usr/sbin/groupadd -r -g 19 floppy >/dev/null 2>&1 || :
308 /usr/bin/systemctl stop systemd-udevd-control.socket systemd-udevd-kernel.socket systemd-udevd.service >/dev/null 2>&1 || :
309
310 # Rename configuration files that changed their names
311 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-logind.conf %{_sysconfdir}/systemd/logind.conf >/dev/null 2>&1 || :
312 /usr/bin/mv -n %{_sysconfdir}/systemd/systemd-journald.conf %{_sysconfdir}/systemd/journald.conf >/dev/null 2>&1 || :
313
314 %post
315 /usr/bin/systemd-machine-id-setup > /dev/null 2>&1 || :
316 %if %{WITH_RANDOMSEED}
317 /usr/lib/systemd/systemd-random-seed save > /dev/null 2>&1 || :
318 %endif
319 /usr/bin/systemctl daemon-reexec > /dev/null 2>&1 || :
320 /usr/bin/systemctl start systemd-udevd.service >/dev/null 2>&1 || :
321 /usr/bin/mkdir -p /etc/systemd/network
322 /usr/bin/ln -sf /dev/null /etc/systemd/network/99-default.link
323
324 #link system, user unit directory in conf dir to opt conf dir
325 /usr/bin/mkdir -p /opt/etc/systemd
326 /usr/bin/mv /etc/systemd/system /opt/etc/systemd/system 
327 /usr/bin/mv /etc/systemd/user /opt/etc/systemd/user
328 /usr/bin/ln -s ../../opt/etc/systemd/system /etc/systemd/system
329 /usr/bin/ln -s ../../opt/etc/systemd/user /etc/systemd/user
330
331 %postun
332 if [ $1 -ge 1 ] ; then
333         /usr/bin/systemctl daemon-reload > /dev/null 2>&1 || :
334         /usr/bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
335 fi
336
337 %preun
338 if [ $1 -eq 0 ] ; then
339         /usr/bin/systemctl disable \
340                 getty@.service \
341                 remote-fs.target \
342                 systemd-readahead-replay.service \
343                 systemd-readahead-collect.service >/dev/null 2>&1 || :
344 fi
345
346 %post -n libsystemd -p /sbin/ldconfig
347 %postun -n libsystemd  -p /sbin/ldconfig
348
349 %lang_package
350
351 %files
352 %manifest %{name}.manifest
353 %license LICENSE.LGPL2.1  LICENSE.GPL2
354 %config %{_sysconfdir}/pam.d/systemd-user
355 %{_bindir}/bootctl
356 %{_bindir}/busctl
357 %{_bindir}/kernel-install
358 %if %{?WITH_MACHINED}
359 %{_bindir}/machinectl
360 %endif
361 %{_bindir}/systemd-run
362 %dir %{_prefix}/lib/kernel
363 %dir %{_prefix}/lib/kernel/install.d
364 %{_prefix}/lib/kernel/install.d/50-depmod.install
365 %{_prefix}/lib/kernel/install.d/90-loaderentry.install
366 %if %{?WITH_HOSTNAMED}
367 %{_bindir}/hostnamectl
368 %endif
369 %{_bindir}/localectl
370 %if %{?WITH_COREDUMP}
371 %{_bindir}/coredumpctl
372 %endif
373 %if %{?WITH_TIMEDATED}
374 %{_bindir}/timedatectl
375 %endif
376 %dir %{_sysconfdir}/systemd
377 %{_sysconfdir}/systemd/system
378 %{_sysconfdir}/systemd/user
379 %dir %{_sysconfdir}/tmpfiles.d
380 %dir %{_sysconfdir}/sysctl.d
381 %dir %{_sysconfdir}/modules-load.d
382 %dir %{_sysconfdir}/binfmt.d
383 %if %{?WITH_BASH_COMPLETION}
384 %{_datadir}/bash-completion/*
385 %endif
386 %if %{?WITH_ZSH_COMPLETION}
387 %dir %{_datadir}/zsh/site-functions
388 %{_datadir}/zsh/site-functions/*
389 %endif
390 %dir %{_sysconfdir}/udev
391 %dir %{_sysconfdir}/udev/rules.d
392 %dir %{_prefix}/lib/systemd
393 %dir %{_prefix}/lib/systemd/system
394 %dir %{_prefix}/lib/systemd/system-generators
395 %dir %{_prefix}/lib/systemd/user-generators
396 %dir %{_prefix}/lib/systemd/system-preset
397 %dir %{_prefix}/lib/systemd/user-preset
398 %dir %{_prefix}/lib/systemd/system-shutdown
399 %dir %{_prefix}/lib/systemd/system-sleep
400 %dir %{_prefix}/lib/tmpfiles.d
401 %dir %{_prefix}/lib/sysctl.d
402 %dir %{_prefix}/lib/modules-load.d
403 %dir %{_prefix}/lib/binfmt.d
404 %dir %{_prefix}/lib/firmware
405 %dir %{_prefix}/lib/firmware/updates
406 %dir %{_datadir}/systemd
407 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.systemd1.conf
408 %if %{?WITH_HOSTNAMED}
409 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.hostname1.conf
410 %endif
411 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.login1.conf
412 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.locale1.conf
413 %if %{?WITH_TIMEDATED}
414 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
415 %endif
416 %if %{?WITH_MACHINED}
417 %config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
418 %endif
419 %if %{?WITH_COREDUMP}
420 %config(noreplace) %{_sysconfdir}/systemd/coredump.conf
421 %endif
422 %config(noreplace) %{_sysconfdir}/systemd/system.conf
423 %config(noreplace) %{_sysconfdir}/systemd/user.conf
424 %config(noreplace) %{_sysconfdir}/systemd/logind.conf
425 %config(noreplace) %{_sysconfdir}/systemd/journald.conf
426 %config(noreplace) %{_sysconfdir}/udev/udev.conf
427 %{_sysconfdir}/xdg/systemd
428 %ghost %config(noreplace) %{_sysconfdir}/hostname
429 %ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
430 %ghost %config(noreplace) %{_sysconfdir}/locale.conf
431 %ghost %config(noreplace) %{_sysconfdir}/machine-id
432 %ghost %config(noreplace) %{_sysconfdir}/machine-info
433 %ghost %config(noreplace) %{_sysconfdir}/timezone
434 %exclude %{_sysconfdir}/X11/xinit/xinitrc.d/50-systemd-user.sh
435 %{_bindir}/systemd
436 %{_bindir}/systemctl
437 %{_bindir}/systemd-notify
438 %{_bindir}/systemd-ask-password
439 %{_bindir}/systemd-tty-ask-password-agent
440 %{_bindir}/systemd-machine-id-setup
441 %{_bindir}/systemd-socket-activate
442 %{_bindir}/loginctl
443 %{_bindir}/systemd-loginctl
444 %{_bindir}/journalctl
445 %{_bindir}/systemd-tmpfiles
446 %{_bindir}/systemd-nspawn
447 %{_bindir}/systemd-stdio-bridge
448 %{_bindir}/systemd-cat
449 %{_bindir}/systemd-cgls
450 %{_bindir}/systemd-cgtop
451 %{_bindir}/systemd-delta
452 %{_bindir}/systemd-detect-virt
453 %{_bindir}/systemd-inhibit
454 %{_bindir}/udevadm
455 %{_bindir}/systemd-escape
456 %{_bindir}/systemd-path
457 %{_prefix}/lib/sysctl.d/*.conf
458 %{_prefix}/lib/systemd/systemd
459 %{_prefix}/lib/systemd/system
460 %exclude %{_prefix}/lib/systemd/resolv.conf
461
462 %dir %{_prefix}/lib/systemd/system/basic.target.wants
463 %dir %{_prefix}/lib/systemd/user
464 %dir %{_prefix}/lib/systemd/network
465 %{_prefix}/lib/systemd/user/basic.target
466 %{_prefix}/lib/systemd/user/bluetooth.target
467 %{_prefix}/lib/systemd/user/exit.target
468 %{_prefix}/lib/systemd/user/printer.target
469 %{_prefix}/lib/systemd/user/shutdown.target
470 %{_prefix}/lib/systemd/user/sockets.target
471 %{_prefix}/lib/systemd/user/sound.target
472 %{_prefix}/lib/systemd/user/systemd-exit.service
473 %{_prefix}/lib/systemd/user/paths.target
474 %{_prefix}/lib/systemd/user/smartcard.target
475 %{_prefix}/lib/systemd/user/timers.target
476 %exclude %{_prefix}/lib/systemd/network/80-container-ve.network
477 %exclude %{_prefix}/lib/systemd/network/80-container-host0.network
478 %exclude %{_prefix}/lib/systemd/network/80-container-vz.network
479 %{_prefix}/lib/systemd/user/default.target
480 %{_prefix}/lib/systemd/network/99-default.link
481 %exclude %{_prefix}/lib/systemd/system-preset/90-systemd.preset
482
483 %{_prefix}/lib/systemd/libsystemd-shared-231.so
484 %{_prefix}/lib/systemd/libsystemd-shared.so
485 %{_prefix}/lib/systemd/systemd-*
486 %dir %{_prefix}/lib/systemd/catalog
487 %{_prefix}/lib/systemd/catalog/systemd.catalog
488 %{_prefix}/lib/udev
489 %{_prefix}/lib/systemd/system-generators/systemd-getty-generator
490 %{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
491 %{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
492 %{_prefix}/lib/tmpfiles.d/home.conf
493 %{_prefix}/lib/tmpfiles.d/journal-nocow.conf
494 %{_prefix}/lib/tmpfiles.d/legacy.conf
495 %{_prefix}/lib/tmpfiles.d/pamconsole-tmp.conf
496 %{_prefix}/lib/tmpfiles.d/systemd.conf
497 %{_prefix}/lib/tmpfiles.d/systemd-nologin.conf
498 %{_prefix}/lib/tmpfiles.d/systemd-nspawn.conf
499 %{_prefix}/lib/tmpfiles.d/tmp.conf
500 %{_prefix}/lib/tmpfiles.d/var.conf
501 %{_prefix}/lib/tmpfiles.d/x11.conf
502 %{_sbindir}/init
503 %{_sbindir}/reboot
504 %{_sbindir}/halt
505 %{_sbindir}/poweroff
506 %{_sbindir}/shutdown
507 %{_sbindir}/telinit
508 %{_sbindir}/runlevel
509 %{_sbindir}/udevadm
510 %{_datadir}/systemd/graphinfo.gvpr
511 %{_datadir}/systemd/kbd-model-map
512 %{_datadir}/systemd/language-fallback-map
513 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
514 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
515 %if %{?WITH_HOSTNAMED}
516 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
517 %endif
518 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
519 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
520 %if %{?WITH_TIMEDATED}
521 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
522 %endif
523 %if %{?WITH_MACHINED}
524 %{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
525 %endif
526 %dir %{_datadir}/factory/
527 %dir %{_datadir}/factory/etc
528 %dir %{_datadir}/factory/etc/pam.d
529 %{_datadir}/factory/etc/nsswitch.conf
530 %{_datadir}/factory/etc/pam.d/other
531 %{_datadir}/factory/etc/pam.d/system-auth
532
533 %{_localstatedir}/log/journal
534
535 %files -n libsystemd
536 %manifest %{name}.manifest
537 %license LICENSE.LGPL2.1
538 %{_libdir}/security/pam_systemd.so
539 %{_libdir}/libsystemd.so.*
540 %{_libdir}/libudev.so.*
541 %{_libdir}/libnss_myhostname.so.2
542 %if %{?WITH_MACHINED}
543 %{_libdir}/libnss_mymachines.so.2
544 %endif
545
546 %files extension-kdbus
547 %manifest %{name}.manifest
548 %license LICENSE.LGPL2.1  LICENSE.GPL2
549 %{_sysconfdir}/systemd/extension-kdbus
550 %{_prefix}/lib/systemd/user/busnames.target
551 %{_prefix}/lib/systemd/system-generators/systemd-dbus1-generator
552 %{_prefix}/lib/systemd/user-generators/systemd-dbus1-generator
553
554 %files devel
555 %manifest %{name}.manifest
556 %{_libdir}/libudev.so
557 %{_libdir}/libsystemd.so
558 %dir %{_includedir}/systemd
559 %{_includedir}/systemd/sd-bus.h
560 %{_includedir}/systemd/sd-bus-protocol.h
561 %{_includedir}/systemd/sd-bus-vtable.h
562 %{_includedir}/systemd/sd-event.h
563 %{_includedir}/systemd/_sd-common.h
564 %{_includedir}/systemd/sd-daemon.h
565 %{_includedir}/systemd/sd-id128.h
566 %{_includedir}/systemd/sd-journal.h
567 %{_includedir}/systemd/sd-login.h
568 %{_includedir}/systemd/sd-messages.h
569 %{_includedir}/libudev.h
570 %{_libdir}/pkgconfig/libudev.pc
571 %{_libdir}/pkgconfig/libsystemd.pc
572 %{_datadir}/pkgconfig/systemd.pc
573 %{_datadir}/pkgconfig/udev.pc
574 %{_libdir}/pkgconfig/libsystemd-daemon.pc
575 %{_libdir}/pkgconfig/libsystemd-id128.pc
576 %{_libdir}/pkgconfig/libsystemd-journal.pc
577 %{_libdir}/pkgconfig/libsystemd-login.pc
578 %{_sysconfdir}/rpm/macros.systemd
579
580 %files analyze
581 %manifest %{name}.manifest
582 %license LICENSE.LGPL2.1
583 %{_bindir}/systemd-analyze
584
585 %files tests
586 %manifest %{name}.manifest
587 %{_prefix}/lib/dbus-tests/test-suites/systemd-tests/
588 %{_prefix}/lib/dbus-tests/runner/systemd-tests
589
590 %if %{?WITH_DOC}
591 %docs_package
592 %endif