Merge "Fix always active issue of sysapp-launcher after boot-up. And removed tts...
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with x
2 %bcond_with wayland
3 %bcond_with emulator
4
5 %define PROFILE common
6 %define FORMFACTOR none
7
8 #Main applications
9 %define powerkey_popup off
10 %define crash_popup off
11 %define system_popup off
12 %define notification_service off
13 %define signal_sender off
14 #sub-popups of system-popup
15 %define battery_popup off
16 %define mmc_popup off
17 %define usb_popup off
18 %define watchdog_popup off
19 %define overheat_popup off
20 %define storage_popup off
21 %define system_cooperator off
22
23 %if "%{?profile}" == "mobile"
24 %define PROFILE mobile
25 #Main applicaitons
26 %define powerkey_popup on
27 %define crash_popup on
28 %define system_popup on
29 %define notification_service on
30 %define signal_sender on
31 %define system_cooperator on
32 #sub-popups of system-popup
33 %define battery_popup on
34 %define mmc_popup on
35 %define usb_popup on
36 %define watchdog_popup on
37 %if %{?system_popup} == on
38 %define overheat_popup on
39 %endif
40 %define storage_popup on
41 %endif
42
43 %if "%{?profile}" == "wearable"
44 %define PROFILE wearable
45 %if "%_repository" == "target-circle" || "%_repository" == "emulator-circle"
46         %define FORMFACTOR circle
47 %else
48         %define FORMFACTOR rectangle
49 %endif
50 #Main applicaitons
51 %define powerkey_popup on
52 %define crash_popup on
53 %define system_popup on
54 %define system_cooperator on
55 #sub-popups of system-popup
56 %define storage_popup on
57 %define watchdog_popup on
58 %define battery_popup on
59 %if %{?system_popup} == on
60 %define overheat_popup on
61 %endif
62 %endif
63
64 %if "%{?profile}" == "tv"
65 %define PROFILE tv
66 #Main applications
67 %define crash_popup on
68 #sub-popups of system-popup
69 %endif
70
71 Name:       system-servant
72 Summary:    Servant application for System FW
73 Version:    0.2.0
74 Release:    1
75 Group:      System/Utilities
76 License:    Apache-2.0
77 Source0:    %{name}-%{version}.tar.gz
78 Source1:    %{name}.manifest
79 Source1001:    org.tizen.powerkey-syspopup.manifest
80 Source1015:    org.tizen.crash-syspopup.manifest
81 Source2001:    org.tizen.system-syspopup.manifest
82 Source2003:    org.tizen.system-signal-sender.manifest
83 BuildRequires:  pkgconfig(appsvc)
84 BuildRequires:  pkgconfig(pkgmgr-info)
85 BuildRequires:  pkgconfig(elementary)
86 BuildRequires:  pkgconfig(appcore-efl)
87 BuildRequires:  pkgconfig(syspopup)
88 BuildRequires:  pkgconfig(syspopup-caller)
89 BuildRequires:  pkgconfig(notification)
90 BuildRequires:  pkgconfig(vconf)
91 BuildRequires:  pkgconfig(glib-2.0)
92 BuildRequires:  pkgconfig(dlog)
93 BuildRequires:  pkgconfig(dbus-1)
94 BuildRequires:  pkgconfig(edbus)
95 BuildRequires:  pkgconfig(deviced)
96 BuildRequires:  pkgconfig(feedback)
97 BuildRequires:  pkgconfig(efl-extension)
98 BuildRequires:  pkgconfig(libtzplatform-config)
99 BuildRequires:  edje-bin
100 BuildRequires:  pkgconfig(capi-media-sound-manager)
101 BuildRequires:  pkgconfig(capi-media-wav-player)
102
103 %if %{with x}
104 BuildRequires:  pkgconfig(ecore-x)
105 BuildRequires:  pkgconfig(utilX)
106 %endif
107 BuildRequires:  cmake
108 BuildRequires:  gettext-devel
109
110 %description
111 System applications such as app-launcher
112 and service file for dbus activation
113
114 %if %{?crash_popup} == on
115 %package -n org.tizen.crash-syspopup
116 Summary:    System popup application (crash system popup)
117 Group:      System/Utilities
118 Requires:   %{name} = %{version}-%{release}
119
120 %description -n org.tizen.crash-syspopup
121 to inform user crash information. It is activated
122 when crash event is happend
123 %endif
124
125 %if %{?powerkey_popup} == on
126 %package -n org.tizen.powerkey-syspopup
127 Summary:    Powerkey-popup application
128 Group:      System/Utilities
129 Requires:   %{name} = %{version}-%{release}
130
131 %description -n org.tizen.powerkey-syspopup
132 to inform user powerkey information. It is activated
133 when user power key event is happened
134 %endif
135
136 %if %{?signal_sender} == on
137 %package -n org.tizen.system-signal-sender
138 Summary:    System FW signal sender
139 Group:      System/Utilities
140 Requires:   %{name} = %{version}-%{release}
141
142 %description -n org.tizen.system-signal-sender
143 to inform user system FW signal sender. It is activated
144 when system event is happend
145 %endif
146
147 %if %{?system_popup} == on
148 %package -n org.tizen.system-syspopup
149 Summary:    System popup application
150 Group:      System/Utilities
151 Requires:   %{name} = %{version}-%{release}
152
153 %description -n org.tizen.system-syspopup
154 to inform user system information. It is activated
155 when system event is happend
156
157 %endif # system_popup
158
159 %prep
160 %setup -q
161
162 %build
163 chmod 0644 %{SOURCE1}
164 cp %{SOURCE1} .
165
166 %if %{powerkey_popup} == on
167 chmod 0644 %{SOURCE1001}
168 cp %{SOURCE1001} .
169 %endif
170
171 %if %{crash_popup} == on
172 chmod 0644 %{SOURCE1015}
173 cp %{SOURCE1015} .
174 %endif
175
176 %if %{system_popup} == on
177 chmod 0644 %{SOURCE2001}
178 cp %{SOURCE2001} .
179 %endif
180
181 %if %{signal_sender} == on
182 chmod 0644 %{SOURCE2003}
183 cp %{SOURCE2003} .
184 %endif
185
186 %define DPMS none
187 %if %{with x}
188 %define DPMS x
189 %endif
190 %if %{with wayland}
191 %define DPMS wayland
192 %endif
193
194 %cmake . \
195                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
196                 -DPKGNAME=%{name} \
197                 -DPROFILE=%{PROFILE} \
198                 -DFORMFACTOR=%{FORMFACTOR} \
199                 -DDPMS=%{DPMS} \
200                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
201                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
202                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
203                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
204                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
205                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
206                 -DPOWERKEY_POPUP=%{powerkey_popup} \
207                 -DCRASH_POPUP=%{crash_popup} \
208                 -DNOTIFICATION_SERVICE=%{notification_service} \
209                 -DBATTERY_POPUP=%{battery_popup} \
210                 -DSYSTEM_POPUP=%{system_popup} \
211                 -DSIGNAL_SENDER=%{signal_sender} \
212                 -DSYSTEM_COOPERATOR=%{system_cooperator} \
213                 -DMMC_POPUP=%{mmc_popup} \
214                 -DSTORAGE_POPUP=%{storage_popup} \
215                 -DUSB_POPUP=%{usb_popup} \
216                 -DWATCHDOG_POPUP=%{watchdog_popup} \
217                 -DOVERHEAT_POPUP=%{overheat_popup} \
218
219 make %{?jobs:-j%jobs}
220
221 %install
222 rm -rf %{buildroot}
223 %make_install
224
225
226 %files
227 %manifest %{name}.manifest
228 %{_bindir}/sysapp-launcher
229 %{_datadir}/license/sysapp-launcher
230 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
231 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
232
233 #po files to support multi-languages
234 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
235 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
236 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
237 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
238 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
239 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
240 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
241 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
242 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
243 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
244 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
245 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
246 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
247 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
248 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
249 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
250 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
251 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
252 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
253 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
254 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
255 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
256 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
257 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
258 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
259 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
260 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
261 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
262 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
263 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
264 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
265 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
266 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
267 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
268 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
269 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
270 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
271 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
272 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
273 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
274 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
275 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
276 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
277 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
278 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
279 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
280 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
281 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
282 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
283 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
284 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
285 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
286 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
287 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
288 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
289 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
290 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
291 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
292 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
293 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
294
295 %if %{notification_service} == on
296 %{_datadir}/system-apps/res/icons/batt_full_icon.png
297 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
298 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/datausage_warning.png
299 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/led_torch.png
300 %endif
301
302 %if %{system_cooperator} == on
303 %{_bindir}/system-cooperator
304 %endif
305
306 %if %{crash_popup} == on
307 %files -n org.tizen.crash-syspopup
308 %manifest org.tizen.crash-syspopup.manifest
309 %license LICENSE
310 %defattr(-,root,root,-)
311 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
312 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
313 %endif
314
315 %if %{system_popup} == on
316 %files -n org.tizen.system-syspopup
317 %manifest org.tizen.system-syspopup.manifest
318 %defattr(-,root,root,-)
319 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
320 %if %{overheat_popup} == on
321 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/system-syspopup.edj
322 %endif
323 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
324 %endif
325
326 %if %{powerkey_popup} == on
327 %files -n org.tizen.powerkey-syspopup
328 %manifest org.tizen.powerkey-syspopup.manifest
329 %license LICENSE
330 %defattr(-,root,root,-)
331 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
332 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
333 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
334 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
335 %endif
336
337 %if %{signal_sender} == on
338 %files -n org.tizen.system-signal-sender
339 %manifest org.tizen.system-signal-sender.manifest
340 %defattr(-,root,root,-)
341 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
342 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
343 %endif