Merge "Remove unused and dangerous CMake Option" into tizen
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with x
2 %bcond_with wayland
3 %bcond_with emulator
4
5 %define PROFILE common
6 %define FORMFACTOR none
7
8 #Main applications
9 %define powerkey_popup off
10 %define overheat_popup off
11 %define crash_popup off
12 %define system_popup off
13 %define notification_service off
14 %define signal_sender off
15 #sub-popups of system-popup
16 %define battery_popup off
17 %define cooldown_popup off
18 %define mmc_popup off
19 %define power_popup off
20 %define usb_popup off
21 %define watchdog_popup off
22 %define storage_popup off
23 %define system_cooperator off
24
25 %if "%{?profile}" == "mobile"
26 %define PROFILE mobile
27 #Main applicaitons
28 %define powerkey_popup on
29 %define overheat_popup on
30 %define crash_popup on
31 %define system_popup on
32 %define notification_service on
33 %define signal_sender on
34 %define system_cooperator on
35 #sub-popups of system-popup
36 %define battery_popup on
37 %define cooldown_popup on
38 %define mmc_popup on
39 %define power_popup on
40 %define usb_popup on
41 %define watchdog_popup on
42 %define storage_popup on
43 %endif
44
45 %if "%{?profile}" == "wearable"
46 %define PROFILE wearable
47 #Main applicaitons
48 %define powerkey_popup on
49 %define overheat_popup off
50 %define crash_popup on
51 %define system_popup on
52 %define system_cooperator on
53 #sub-popups of system-popup
54 %define storage_popup on
55 %define watchdog_popup on
56 %define battery_popup on
57 %define cooldown_popup on
58 %define power_popup on
59 %endif
60
61 %if "%{?profile}" == "tv"
62 %define PROFILE tv
63 #Main applications
64 %define crash_popup on
65 #sub-popups of system-popup
66 %endif
67
68 Name:       system-servant
69 Summary:    Servant application for System FW
70 Version:    0.2.0
71 Release:    1
72 Group:      System/Utilities
73 License:    Apache-2.0
74 Source0:    %{name}-%{version}.tar.gz
75 Source1:    %{name}.manifest
76 Source1001:    org.tizen.powerkey-syspopup.manifest
77 Source1002:    org.tizen.overheat-syspopup.manifest
78 Source1015:    org.tizen.crash-syspopup.manifest
79 Source2001:    org.tizen.system-syspopup.manifest
80 Source2003:    org.tizen.system-signal-sender.manifest
81 BuildRequires:  pkgconfig(appsvc)
82 BuildRequires:  pkgconfig(pkgmgr-info)
83 BuildRequires:  pkgconfig(elementary)
84 BuildRequires:  pkgconfig(appcore-efl)
85 BuildRequires:  pkgconfig(syspopup)
86 BuildRequires:  pkgconfig(syspopup-caller)
87 BuildRequires:  pkgconfig(notification)
88 BuildRequires:  pkgconfig(vconf)
89 BuildRequires:  pkgconfig(glib-2.0)
90 BuildRequires:  pkgconfig(dlog)
91 BuildRequires:  pkgconfig(dbus-1)
92 BuildRequires:  pkgconfig(edbus)
93 BuildRequires:  pkgconfig(deviced)
94 BuildRequires:  pkgconfig(feedback)
95 BuildRequires:  pkgconfig(efl-extension)
96 BuildRequires:  pkgconfig(libtzplatform-config)
97 BuildRequires:  edje-bin
98 BuildRequires:  pkgconfig(capi-media-sound-manager)
99 BuildRequires:  pkgconfig(capi-media-wav-player)
100 BuildRequires:  pkgconfig(capi-appfw-application)
101 BuildRequires:  pkgconfig(capi-appfw-app-manager)
102 BuildRequires:  pkgconfig(capi-media-recorder)
103 BuildRequires:  model-build-features
104
105 %if "%{?model_build_feature_formfactor}" == "circle"
106         %define FORMFACTOR circle
107 %else
108         %define FORMFACTOR rectangle
109 %endif
110
111 %if %{with x}
112 BuildRequires:  pkgconfig(ecore-x)
113 BuildRequires:  pkgconfig(utilX)
114 %endif
115 BuildRequires:  cmake
116 BuildRequires:  gettext-devel
117
118 %description
119 System applications such as app-launcher
120 and service file for dbus activation
121
122 %if %{?crash_popup} == on
123 %package -n org.tizen.crash-syspopup
124 Summary:    System popup application (crash system popup)
125 Group:      System/Utilities
126 Requires:   %{name} = %{version}-%{release}
127
128 %description -n org.tizen.crash-syspopup
129 to inform user crash information. It is activated
130 when crash event is happend
131 %endif
132
133 %if %{?powerkey_popup} == on
134 %package -n org.tizen.powerkey-syspopup
135 Summary:    Powerkey-popup application
136 Group:      System/Utilities
137 Requires:   %{name} = %{version}-%{release}
138
139 %description -n org.tizen.powerkey-syspopup
140 to inform user powerkey information. It is activated
141 when user power key event is happened
142 %endif
143
144 %if %{?overheat_popup} == on
145 %package -n org.tizen.overheat-syspopup
146 Summary:    Overheat-popup application
147 Group:      System/Utilities
148 Requires:   %{name} = %{version}-%{release}
149
150 %description -n org.tizen.overheat-syspopup
151 to inform user overheat information. It is activated
152 when overheat event is happened
153 %endif
154
155 %if %{?signal_sender} == on
156 %package -n org.tizen.system-signal-sender
157 Summary:    System FW signal sender
158 Group:      System/Utilities
159 Requires:   %{name} = %{version}-%{release}
160
161 %description -n org.tizen.system-signal-sender
162 to inform user system FW signal sender. It is activated
163 when system event is happend
164 %endif
165
166 %if %{?system_popup} == on
167 %package -n org.tizen.system-syspopup
168 Summary:    System popup application
169 Group:      System/Utilities
170 Requires:   %{name} = %{version}-%{release}
171
172 %description -n org.tizen.system-syspopup
173 to inform user system information. It is activated
174 when system event is happend
175
176 %endif # system_popup
177
178 %prep
179 %setup -q
180
181 %build
182 chmod 0644 %{SOURCE1}
183 cp %{SOURCE1} .
184
185 %if %{powerkey_popup} == on
186 chmod 0644 %{SOURCE1001}
187 cp %{SOURCE1001} .
188 %endif
189
190 %if %{overheat_popup} == on
191 chmod 0644 %{SOURCE1002}
192 cp %{SOURCE1002} .
193 %endif
194
195 %if %{crash_popup} == on
196 chmod 0644 %{SOURCE1015}
197 cp %{SOURCE1015} .
198 %endif
199
200 %if %{system_popup} == on
201 chmod 0644 %{SOURCE2001}
202 cp %{SOURCE2001} .
203 %endif
204
205 %if %{signal_sender} == on
206 chmod 0644 %{SOURCE2003}
207 cp %{SOURCE2003} .
208 %endif
209
210 %define DPMS none
211 %if %{with x}
212 %define DPMS x
213 %endif
214 %if %{with wayland}
215 %define DPMS wayland
216 %endif
217
218 %cmake . \
219                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
220                 -DPKGNAME=%{name} \
221                 -DPROFILE=%{PROFILE} \
222                 -DFORMFACTOR=%{FORMFACTOR} \
223                 -DDPMS=%{DPMS} \
224                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
225                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
226                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
227                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
228                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
229                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
230                 -DPOWERKEY_POPUP=%{powerkey_popup} \
231                 -DCRASH_POPUP=%{crash_popup} \
232                 -DNOTIFICATION_SERVICE=%{notification_service} \
233                 -DBATTERY_POPUP=%{battery_popup} \
234                 -DCOOLDOWN_POPUP=%{cooldown_popup} \
235                 -DSYSTEM_POPUP=%{system_popup} \
236                 -DSIGNAL_SENDER=%{signal_sender} \
237                 -DSYSTEM_COOPERATOR=%{system_cooperator} \
238                 -DMMC_POPUP=%{mmc_popup} \
239                 -DSTORAGE_POPUP=%{storage_popup} \
240                 -DUSB_POPUP=%{usb_popup} \
241                 -DWATCHDOG_POPUP=%{watchdog_popup} \
242                 -DOVERHEAT_POPUP=%{overheat_popup} \
243                 -DPOWER_POPUP=%{power_popup} \
244
245 make %{?jobs:-j%jobs}
246
247 %install
248 rm -rf %{buildroot}
249 %make_install
250
251
252 %files
253 %manifest %{name}.manifest
254 %{_bindir}/sysapp-launcher
255 %{_datadir}/license/sysapp-launcher
256 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
257 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
258
259 #po files to support multi-languages
260 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
261 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
262 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
263 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
264 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
265 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
266 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
267 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
268 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
269 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
270 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
271 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
272 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
273 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
274 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
275 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
276 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
277 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
278 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
279 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
280 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
281 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
282 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
283 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
284 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
285 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
286 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
287 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
288 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
289 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
290 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
291 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
292 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
293 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
294 %lang(ko_KR) %{_datadir}/locale/ko_KR/LC_MESSAGES/system-servant.mo
295 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
296 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
297 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
298 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
299 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
300 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
301 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
302 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
303 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
304 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
305 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
306 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
307 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
308 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
309 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
310 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
311 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
312 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
313 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
314 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
315 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
316 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
317 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
318 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
319 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
320 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
321
322 %if %{notification_service} == on
323 %{_datadir}/system-apps/res/icons/batt_full_icon.png
324 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
325 %{_datadir}/system-apps/res/icons/noti_cooling_down.png
326 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/datausage_warning.png
327 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/led_torch.png
328 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/usb_icon.png
329 %endif
330
331 %if %{system_cooperator} == on
332 %{_bindir}/system-cooperator
333 %endif
334
335 %if %{crash_popup} == on
336 %files -n org.tizen.crash-syspopup
337 %manifest org.tizen.crash-syspopup.manifest
338 %license LICENSE
339 %defattr(-,root,root,-)
340 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
341 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
342 %endif
343
344 %if %{system_popup} == on
345 %files -n org.tizen.system-syspopup
346 %manifest org.tizen.system-syspopup.manifest
347 %defattr(-,root,root,-)
348 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
349 %if "%{?profile}" == "mobile"
350 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/system-syspopup.edj
351 %endif
352 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
353 %endif
354
355 %if %{powerkey_popup} == on
356 %files -n org.tizen.powerkey-syspopup
357 %manifest org.tizen.powerkey-syspopup.manifest
358 %license LICENSE
359 %defattr(-,root,root,-)
360 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
361 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
362 %if "%{?profile}" == "mobile"
363 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
364 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
365 %endif
366 %if "%{?profile}" == "wearable"
367 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
368 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
369 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/saving_device_options_power_off.png
370 %endif
371 %endif
372
373 %if %{overheat_popup} == on
374 %files -n org.tizen.overheat-syspopup
375 %manifest org.tizen.overheat-syspopup.manifest
376 %license LICENSE
377 %defattr(-,root,root,-)
378 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/bin/overheat-popup
379 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/shared/res/overheat-popup.edj
380 %{TZ_SYS_RO_SHARE}/packages/org.tizen.overheat-syspopup.xml
381 %endif
382
383 %if %{signal_sender} == on
384 %files -n org.tizen.system-signal-sender
385 %manifest org.tizen.system-signal-sender.manifest
386 %defattr(-,root,root,-)
387 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
388 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
389 %endif