Generate powerkey-syspopup rpm for common profile
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with wayland
2
3 Name:       system-servant
4 Summary:    Servant application for System FW
5 Version:    0.2.2
6 Release:    1
7 Group:      System/Utilities
8 License:    Apache-2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Source1:    %{name}.manifest
11 Source1001:    org.tizen.powerkey-syspopup.manifest
12 Source1002:    org.tizen.overheat-syspopup.manifest
13 Source1015:    org.tizen.crash-syspopup.manifest
14 Source2001:    org.tizen.system-syspopup.manifest
15 Source2003:    org.tizen.system-signal-sender.manifest
16 BuildRequires:  pkgconfig(appsvc)
17 BuildRequires:  pkgconfig(pkgmgr-info)
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(appcore-efl)
20 BuildRequires:  pkgconfig(syspopup)
21 BuildRequires:  pkgconfig(syspopup-caller)
22 BuildRequires:  pkgconfig(notification)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(dlog)
26 BuildRequires:  pkgconfig(dbus-1)
27 BuildRequires:  pkgconfig(edbus)
28 BuildRequires:  pkgconfig(deviced)
29 BuildRequires:  pkgconfig(feedback)
30 BuildRequires:  pkgconfig(efl-extension)
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 BuildRequires:  edje-bin
33 BuildRequires:  pkgconfig(capi-media-sound-manager)
34 BuildRequires:  pkgconfig(capi-media-wav-player)
35 BuildRequires:  pkgconfig(capi-appfw-application)
36 BuildRequires:  pkgconfig(capi-appfw-app-manager)
37 BuildRequires:  pkgconfig(capi-media-recorder)
38 BuildRequires:  pkgconfig(capi-system-info)
39 Requires:       system-servant-compat = %{version}-%{release}
40 Recommends:     system-servant-profile_common = %{version}-%{release}
41
42 BuildRequires:  cmake
43 BuildRequires:  gettext-devel
44
45 %description
46 System applications such as app-launcher
47 and service file for dbus activation
48
49 %package profile_common
50 Summary:        System-servant configured for common profile
51 Provides:       system-servant-compat = %{version}-%{release}
52 Requires:       org.tizen.powerkey-syspopup.common
53 Conflicts:      system-servant-profile_mobile
54 Conflicts:      system-servant-extension-rectangle-profile_wearable
55 Conflicts:      system-servant-extension-circle-profile_wearable
56 Conflicts:      system-servant-extension-profile_tv
57 %description profile_common
58 System-popup (system-servant) configured for common profile.
59 The binary is shared between common/tv.
60
61 %package profile_tv
62 Summary:        System-servant configured for TV profile
63 Provides:       system-servant-compat = %{version}-%{release}
64 Requires:       org.tizen.crash-syspopup
65 Conflicts:      system-servant-profile_mobile
66 Conflicts:      system-servant-extension-rectangle-profile_wearable
67 Conflicts:      system-servant-extension-circle-profile_wearable
68 Conflicts:      system-servant-profile_common
69 %description profile_tv
70 System-popup (system-servant) configured for TV profile.
71 The binary is shared between common/tv.
72
73 %package profile_mobile
74 Summary:        System-servant configured for mobile profile
75 Provides:       system-servant-compat = %{version}-%{release}
76 Requires:       org.tizen.crash-syspopup
77 Requires:       org.tizen.overheat-syspopup
78 Requires:       org.tizen.system-signal-sender
79 Requires:       org.tizen.powerkey-syspopup.mobile
80 Requires:       org.tizen.system-syspopup.mobile
81 Conflicts:      system-servant-extension-rectangle-profile_wearable
82 Conflicts:      system-servant-extension-circle-profile_wearable
83 Conflicts:      system-servant-profile_common
84 Conflicts:      system-servant-extension-profile_tv
85 %description profile_mobile
86 System-popup (system-servant) configured for mobile profile.
87
88 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
89 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
90 %package extension-circle-profile_wearable
91 Summary:        System-servant configured for wearable profile
92 Provides:       system-servant-compat = %{version}-%{release}
93 Provides:       system-servant-profile_wearable = %{version}-%{release}
94 Requires:       org.tizen.crash-syspopup
95 Requires:       org.tizen.powerkey-syspopup.wearable
96 Requires:       org.tizen.system-syspopup.wearable
97 Provides:       system-servant-profile_wearable
98 Provides:       system-servant-compat
99 Conflicts:      system-servant-profile_mobile
100 Conflicts:      system-servant-extension-rectangle-profile_wearable
101 Conflicts:      system-servant-profile_common
102 Conflicts:      system-servant-extension-profile_tv
103 %description extension-circle-profile_wearable
104 System-popup (system-servant) configured for wearable profile.
105
106 %package extension-rectangle-profile_wearable
107 Summary:        System-servant configured for wearable profile
108 Provides:       system-servant-compat = %{version}-%{release}
109 Provides:       system-servant-profile_wearable = %{version}-%{release}
110 Requires:       org.tizen.crash-syspopup
111 Requires:       org.tizen.powerkey-syspopup.wearable
112 Requires:       org.tizen.system-syspopup.wearable
113 Provides:       system-servant-profile_wearable
114 Provides:       system-servant-compat
115 Conflicts:      system-servant-profile_mobile
116 Conflicts:      system-servant-extension-circle-profile_wearable
117 Conflicts:      system-servant-profile_common
118 Conflicts:      system-servant-extension-profile_tv
119 %description extension-rectangle-profile_wearable
120 System-popup (system-servant) configured for wearable profile.
121 %endif
122
123 %package -n org.tizen.crash-syspopup
124 Summary:    System popup application (crash system popup)
125 Group:      System/Utilities
126 Requires:   %{name} = %{version}-%{release}
127
128 %description -n org.tizen.crash-syspopup
129 to inform user crash information. It is activated
130 when crash event is happend
131
132 %package -n org.tizen.powerkey-syspopup.common
133 Summary:    Powerkey-popup application
134 Group:      System/Utilities
135 Requires:   %{name} = %{version}-%{release}
136
137 %description -n org.tizen.powerkey-syspopup.common
138 to inform user powerkey information. It is activated
139 when user power key event is happened
140
141 %package -n org.tizen.powerkey-syspopup.mobile
142 Summary:    Powerkey-popup application
143 Group:      System/Utilities
144 Requires:   %{name} = %{version}-%{release}
145
146 %description -n org.tizen.powerkey-syspopup.mobile
147 to inform user powerkey information. It is activated
148 when user power key event is happened
149
150 %package -n org.tizen.powerkey-syspopup.wearable
151 Summary:    Powerkey-popup application
152 Group:      System/Utilities
153 Requires:   %{name} = %{version}-%{release}
154
155 %description -n org.tizen.powerkey-syspopup.wearable
156 to inform user powerkey information. It is activated
157 when user power key event is happened
158
159 %package -n org.tizen.overheat-syspopup
160 Summary:    Overheat-popup application
161 Group:      System/Utilities
162 Requires:   %{name} = %{version}-%{release}
163
164 %description -n org.tizen.overheat-syspopup
165 to inform user overheat information. It is activated
166 when overheat event is happened
167
168 %package -n org.tizen.system-signal-sender
169 Summary:    System FW signal sender
170 Group:      System/Utilities
171 Requires:   %{name} = %{version}-%{release}
172
173 %description -n org.tizen.system-signal-sender
174 to inform user system FW signal sender. It is activated
175 when system event is happend
176
177 %package -n org.tizen.system-syspopup.mobile
178 Summary:    System popup application
179 Group:      System/Utilities
180 Requires:   %{name} = %{version}-%{release}
181
182 %description -n org.tizen.system-syspopup.mobile
183 to inform user system information. It is activated
184 when system event is happend
185
186 %package -n org.tizen.system-syspopup.wearable
187 Summary:    System popup application
188 Group:      System/Utilities
189 Requires:   %{name} = %{version}-%{release}
190
191 %description -n org.tizen.system-syspopup.wearable
192 to inform user system information. It is activated
193 when system event is happend
194
195 %prep
196 %setup -q
197
198 %build
199 chmod 0644 %{SOURCE1}
200 cp %{SOURCE1} .
201
202 chmod 0644 %{SOURCE1001}
203 cp %{SOURCE1001} .
204
205 chmod 0644 %{SOURCE1002}
206 cp %{SOURCE1002} .
207
208 chmod 0644 %{SOURCE1015}
209 cp %{SOURCE1015} .
210
211 chmod 0644 %{SOURCE2001}
212 cp %{SOURCE2001} .
213
214 chmod 0644 %{SOURCE2003}
215 cp %{SOURCE2003} .
216
217 %define DPMS none
218 %if %{with wayland}
219 %define DPMS wayland
220 %endif
221
222
223 # BUILD MOBILE
224 echo T1
225 mkdir -p build_mobile
226 pushd build_mobile
227 %cmake .. \
228                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
229                 -DPKGNAME=%{name} \
230                 -DPROFILE=mobile \
231                 -DFORMFACTOR=rectangle \
232                 -DDPMS=%{DPMS} \
233                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
234                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
235                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
236                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
237                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
238                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
239                 -DNOTIFICATION_SERVICE=on \
240
241 echo T2
242
243 make %{?jobs:-j%jobs}
244 rm -rf %{buildroot}
245 %make_install
246 popd
247
248 mkdir -p profile_mobile
249 mkdir -p profile_mobile/%{_bindir}
250 mkdir -p profile_mobile/%{_datadir}/system-apps/res/icons
251 mkdir -p profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
252 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
253 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
254 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
255 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
256 mv %{buildroot}/%{_bindir}/sysapp-launcher profile_mobile/%{_bindir}/sysapp-launcher.mobile
257 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
258 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
259 mv %{buildroot}/%{_datadir}/system-apps/res/icons/*.png profile_mobile/%{_datadir}/system-apps/res/icons
260 %if "%{_datadir}" != "%{TZ_SYS_RO_SHARE}"
261 mv %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/*.png profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
262 %endif
263 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
264 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
265 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
266 ls -la profile_mobile/%{_bindir}
267 ls -la profile_mobile/%{_datadir}/system-apps/res/icons
268 ls -la profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
269 ls -la profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
270
271 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
272 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
273 # BUILD WEARABLE
274 mkdir -p build_rec_wearable
275 pushd build_rec_wearable
276 %cmake .. \
277                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
278                 -DPKGNAME=%{name} \
279                 -DPROFILE=wearable \
280                 -DFORMFACTOR=rectangle \
281                 -DDPMS=%{DPMS} \
282                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
283                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
284                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
285                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
286                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
287                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
288                 -DNOTIFICATION_SERVICE=off
289
290 make %{?jobs:-j%jobs}
291 rm -rf %{buildroot}
292 %make_install
293 popd
294
295 mkdir -p rec-profile_wearable/%{_bindir}
296 mkdir -p rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
297 mkdir -p rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
298 mv %{buildroot}/%{_bindir}/sysapp-launcher rec-profile_wearable/%{_bindir}/sysapp-launcher.wearable
299 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
300 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
301
302 mkdir -p rec-profile_wearable/shared/res
303 mkdir -p rec-profile_wearable/res/
304 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj rec-profile_wearable/shared/res/
305 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png rec-profile_wearable/res/
306
307 # BUILD WEARABLE CIRCLE EXTENSION
308 mkdir -p build_cir_wearable
309 pushd build_cir_wearable
310 %cmake .. \
311                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
312                 -DPKGNAME=%{name} \
313                 -DPROFILE=wearable \
314                 -DFORMFACTOR=circle \
315                 -DDPMS=%{DPMS} \
316                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
317                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
318                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
319                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
320                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
321                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
322                 -DNOTIFICATION_SERVICE=off
323
324 make %{?jobs:-j%jobs}
325 rm -rf %{buildroot}
326 %make_install
327 popd
328
329 mkdir -p cir-profile_wearable
330 mkdir -p cir-profile_wearable/%{_bindir}
331 mkdir -p cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
332 mkdir -p cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
333 mv %{buildroot}/%{_bindir}/sysapp-launcher cir-profile_wearable/%{_bindir}/sysapp-launcher.wearable
334 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
335 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
336
337 mkdir -p cir-profile_wearable/shared/res
338 mkdir -p cir-profile_wearable/res/
339 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj cir-profile_wearable/shared/res/
340 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png cir-profile_wearable/res/
341 %endif
342
343 # BUILD COMMON/TV
344 mkdir -p build_common
345 pushd build_common
346 %cmake .. \
347                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
348                 -DPKGNAME=%{name} \
349                 -DPROFILE=common \
350                 -DFORMFACTOR=rectangle \
351                 -DDPMS=%{DPMS} \
352                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
353                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
354                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
355                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
356                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
357                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
358                 -DNOTIFICATION_SERVICE=off
359
360 make %{?jobs:-j%jobs}
361 rm -rf %{buildroot}
362 %make_install
363 popd
364
365 mkdir -p profile_common
366 mkdir -p profile_common/%{_bindir}
367 mv %{buildroot}/%{_bindir}/sysapp-launcher profile_common/%{_bindir}/sysapp-launcher.common
368
369 %install
370 pushd build_common
371 %make_install
372 popd
373
374 #for mobile profile
375 mkdir -p %{buildroot}/%{_bindir}
376 install -m 0755 profile_mobile/%{_bindir}/* %{buildroot}/%{_bindir}
377 mkdir -p %{buildroot}/%{_datadir}/system-apps/res/icons/
378 install -m 0644 profile_mobile/%{_datadir}/system-apps/res/icons/*.png %{buildroot}/%{_datadir}/system-apps/res/icons/
379 %if "%{_datadir}" != "%{TZ_SYS_RO_SHARE}"
380 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/
381 install -m 0644 profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/*.png %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/
382 %endif
383 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
384 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
385 install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
386 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
387 install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
388 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
389 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
390
391 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
392 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
393 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
394 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res
395 install -m 0644 rec-profile_wearable/shared/res/*.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
396 install -m 0644 rec-profile_wearable/res/*.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
397 install -m 0755 cir-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
398 install -m 0755 rec-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
399 install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
400 install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
401 install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
402 install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
403 install -m 0644 data/gear_device_options_bg.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
404 install -m 0644 data/gear_device_options_power_off.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
405 install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
406 install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
407 %endif
408
409 #for common profile
410 install -m 0755 profile_common/%{_bindir}/* %{buildroot}/%{_bindir}
411
412 # This is not used. (mobile/wearable has its own postfixed version)
413 rm %{buildroot}%{_bindir}/sysapp-launcher
414 rm %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
415 rm %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
416
417
418 %post profile_mobile
419 # This does not support proper uninstall. To uninstall profile_mobile with
420 # correct system-servant kept, you need to reinstall system-servant after
421 # uninstalling profile_mobile
422 mv /%{_bindir}/sysapp-launcher.mobile /%{_bindir}/sysapp-launcher
423 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
424
425 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
426 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
427 %post extension-circle-profile_wearable
428 # This does not support proper uninstall. To uninstall profile_wearable-circle with
429 # correct system-servant kept, you need to reinstall system-servant after
430 # uninstalling profile_wearable-circle
431 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
432 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
433
434 %post extension-rectangle-profile_wearable
435 # This does not support proper uninstall. To uninstall profile_wearable-rectangle with
436 # correct system-servant kept, you need to reinstall system-servant after
437 # uninstalling profile_wearable-rectangle
438 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
439 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
440 %endif
441
442 %post profile_common
443 # This does not support proper uninstall. To uninstall profile_common with
444 # correct system-servant kept, you need to reinstall system-servant after
445 # uninstalling profile_common
446 mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
447
448 %post -n org.tizen.powerkey-syspopup.common
449 mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
450
451 %post -n org.tizen.powerkey-syspopup.mobile
452 mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
453
454 %post -n org.tizen.powerkey-syspopup.wearable
455 mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
456
457 %files
458 %manifest %{name}.manifest
459 %license LICENSE.Apache-2.0
460 %{_unitdir}/system-popup.service
461 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
462 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
463
464 #po files to support multi-languages
465 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
466 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
467 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
468 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
469 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
470 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
471 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
472 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
473 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
474 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
475 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
476 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
477 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
478 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
479 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
480 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
481 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
482 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
483 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
484 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
485 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
486 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
487 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
488 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
489 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
490 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
491 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
492 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
493 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
494 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
495 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
496 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
497 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
498 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
499 %lang(ko_KR) %{_datadir}/locale/ko_KR/LC_MESSAGES/system-servant.mo
500 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
501 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
502 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
503 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
504 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
505 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
506 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
507 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
508 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
509 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
510 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
511 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
512 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
513 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
514 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
515 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
516 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
517 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
518 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
519 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
520 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
521 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
522 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
523 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
524 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
525 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
526
527 %files profile_mobile
528 %license LICENSE.Apache-2.0
529 %defattr(-,root,root,-)
530 %{_bindir}/sysapp-launcher.mobile
531 %{_bindir}/system-cooperator
532 %{_datadir}/system-apps/res/icons/batt_full_icon.png
533 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
534 %{_datadir}/system-apps/res/icons/noti_charging_battery_low.png
535 %{_datadir}/system-apps/res/icons/noti_cooling_down.png
536 %{_datadir}/system-apps/res/icons/datausage_warning.png
537 %{_datadir}/system-apps/res/icons/led_torch.png
538 %{_datadir}/system-apps/res/icons/usb_icon.png
539
540 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
541 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
542 %files extension-circle-profile_wearable
543 %license LICENSE.Apache-2.0
544 %defattr(-,root,root,-)
545 %{_bindir}/sysapp-launcher.wearable
546 %{_bindir}/system-cooperator
547
548 %files extension-rectangle-profile_wearable
549 %license LICENSE.Apache-2.0
550 %defattr(-,root,root,-)
551 %{_bindir}/sysapp-launcher.wearable
552 %{_bindir}/system-cooperator
553 %endif
554
555 %files profile_common
556 %license LICENSE.Apache-2.0
557 %defattr(-,root,root,-)
558 %{_bindir}/sysapp-launcher.common
559
560 %files -n org.tizen.crash-syspopup
561 %manifest org.tizen.crash-syspopup.manifest
562 %license LICENSE.Apache-2.0
563 %defattr(-,root,root,-)
564 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
565 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
566
567 %files -n org.tizen.system-syspopup.mobile
568 %manifest org.tizen.system-syspopup.manifest
569 %license LICENSE.Apache-2.0
570 %defattr(-,root,root,-)
571 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
572 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj
573 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
574
575 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
576 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
577 %files -n org.tizen.system-syspopup.wearable
578 %manifest org.tizen.system-syspopup.manifest
579 %license LICENSE.Apache-2.0
580 %defattr(-,root,root,-)
581 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
582 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj
583 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png
584 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_check.png
585 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_delete.png
586 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
587
588 %files -n org.tizen.powerkey-syspopup.wearable
589 %manifest org.tizen.powerkey-syspopup.manifest
590 %license LICENSE.Apache-2.0
591 %defattr(-,root,root,-)
592 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
593 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
594 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
595 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/gear_device_options_bg.png
596 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/gear_device_options_power_off.png
597 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
598 %endif
599
600 %files -n org.tizen.powerkey-syspopup.common
601 %manifest org.tizen.powerkey-syspopup.manifest
602 %license LICENSE.Apache-2.0
603 %defattr(-,root,root,-)
604 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
605 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
606 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
607 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
608
609 %files -n org.tizen.powerkey-syspopup.mobile
610 %manifest org.tizen.powerkey-syspopup.manifest
611 %license LICENSE.Apache-2.0
612 %defattr(-,root,root,-)
613 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
614 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
615 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
616 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
617
618 %files -n org.tizen.overheat-syspopup
619 %manifest org.tizen.overheat-syspopup.manifest
620 %license LICENSE.Apache-2.0
621 %defattr(-,root,root,-)
622 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/bin/overheat-popup
623 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/shared/res/overheat-popup.edj
624 %{TZ_SYS_RO_SHARE}/packages/org.tizen.overheat-syspopup.xml
625
626 %files -n org.tizen.system-signal-sender
627 %manifest org.tizen.system-signal-sender.manifest
628 %license LICENSE.Apache-2.0
629 %defattr(-,root,root,-)
630 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
631 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
632
633 # The followings are meta packages to keep the compatibility with conventional profiles.
634 %files profile_tv