Fix a bug that images in buttons are not shown on wearable target
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with wayland
2
3 Name:       system-servant
4 Summary:    Servant application for System FW
5 Version:    0.2.2
6 Release:    1
7 Group:      System/Utilities
8 License:    Apache-2.0
9 Source0:    %{name}-%{version}.tar.gz
10 Source1:    %{name}.manifest
11 Source1001:    org.tizen.powerkey-syspopup.manifest
12 Source1002:    org.tizen.overheat-syspopup.manifest
13 Source1015:    org.tizen.crash-syspopup.manifest
14 Source2001:    org.tizen.system-syspopup.manifest
15 Source2003:    org.tizen.system-signal-sender.manifest
16 BuildRequires:  pkgconfig(appsvc)
17 BuildRequires:  pkgconfig(pkgmgr-info)
18 BuildRequires:  pkgconfig(elementary)
19 BuildRequires:  pkgconfig(appcore-efl)
20 BuildRequires:  pkgconfig(syspopup)
21 BuildRequires:  pkgconfig(syspopup-caller)
22 BuildRequires:  pkgconfig(notification)
23 BuildRequires:  pkgconfig(vconf)
24 BuildRequires:  pkgconfig(glib-2.0)
25 BuildRequires:  pkgconfig(dlog)
26 BuildRequires:  pkgconfig(dbus-1)
27 BuildRequires:  pkgconfig(edbus)
28 BuildRequires:  pkgconfig(deviced)
29 BuildRequires:  pkgconfig(feedback)
30 BuildRequires:  pkgconfig(efl-extension)
31 BuildRequires:  pkgconfig(libtzplatform-config)
32 BuildRequires:  edje-bin
33 BuildRequires:  pkgconfig(capi-media-sound-manager)
34 BuildRequires:  pkgconfig(capi-media-wav-player)
35 BuildRequires:  pkgconfig(capi-appfw-application)
36 BuildRequires:  pkgconfig(capi-appfw-app-manager)
37 BuildRequires:  pkgconfig(capi-media-recorder)
38 BuildRequires:  pkgconfig(capi-system-info)
39 Requires:       system-servant-compat = %{version}-%{release}
40 Recommends:     system-servant-profile_common = %{version}-%{release}
41
42 BuildRequires:  cmake
43 BuildRequires:  gettext-devel
44
45 %description
46 System applications such as app-launcher
47 and service file for dbus activation
48
49 %package profile_common
50 Summary:        System-servant configured for common profile
51 Provides:       system-servant-compat = %{version}-%{release}
52 Conflicts:      system-servant-profile_mobile
53 Conflicts:      system-servant-extension-rectangle-profile_wearable
54 Conflicts:      system-servant-extension-circle-profile_wearable
55 Conflicts:      system-servant-extension-profile_tv
56 %description profile_common
57 System-popup (system-servant) configured for common profile.
58 The binary is shared between common/tv.
59
60 %package profile_tv
61 Summary:        System-servant configured for TV profile
62 Provides:       system-servant-compat = %{version}-%{release}
63 Requires:       org.tizen.crash-syspopup
64 Conflicts:      system-servant-profile_mobile
65 Conflicts:      system-servant-extension-rectangle-profile_wearable
66 Conflicts:      system-servant-extension-circle-profile_wearable
67 Conflicts:      system-servant-profile_common
68 %description profile_tv
69 System-popup (system-servant) configured for TV profile.
70 The binary is shared between common/tv.
71
72 %package profile_mobile
73 Summary:        System-servant configured for mobile profile
74 Provides:       system-servant-compat = %{version}-%{release}
75 Requires:       org.tizen.crash-syspopup
76 Requires:       org.tizen.overheat-syspopup
77 Requires:       org.tizen.system-signal-sender
78 Requires:       org.tizen.powerkey-syspopup.mobile
79 Requires:       org.tizen.system-syspopup.mobile
80 Conflicts:      system-servant-extension-rectangle-profile_wearable
81 Conflicts:      system-servant-extension-circle-profile_wearable
82 Conflicts:      system-servant-profile_common
83 Conflicts:      system-servant-extension-profile_tv
84 %description profile_mobile
85 System-popup (system-servant) configured for mobile profile.
86
87 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
88 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
89 %package extension-circle-profile_wearable
90 Summary:        System-servant configured for wearable profile
91 Provides:       system-servant-compat = %{version}-%{release}
92 Provides:       system-servant-profile_wearable = %{version}-%{release}
93 Requires:       org.tizen.crash-syspopup
94 Requires:       org.tizen.powerkey-syspopup.wearable
95 Requires:       org.tizen.system-syspopup.wearable
96 Provides:       system-servant-profile_wearable
97 Provides:       system-servant-compat
98 Conflicts:      system-servant-profile_mobile
99 Conflicts:      system-servant-extension-rectangle-profile_wearable
100 Conflicts:      system-servant-profile_common
101 Conflicts:      system-servant-extension-profile_tv
102 %description extension-circle-profile_wearable
103 System-popup (system-servant) configured for wearable profile.
104
105 %package extension-rectangle-profile_wearable
106 Summary:        System-servant configured for wearable profile
107 Provides:       system-servant-compat = %{version}-%{release}
108 Provides:       system-servant-profile_wearable = %{version}-%{release}
109 Requires:       org.tizen.crash-syspopup
110 Requires:       org.tizen.powerkey-syspopup.wearable
111 Requires:       org.tizen.system-syspopup.wearable
112 Provides:       system-servant-profile_wearable
113 Provides:       system-servant-compat
114 Conflicts:      system-servant-profile_mobile
115 Conflicts:      system-servant-extension-circle-profile_wearable
116 Conflicts:      system-servant-profile_common
117 Conflicts:      system-servant-extension-profile_tv
118 %description extension-rectangle-profile_wearable
119 System-popup (system-servant) configured for wearable profile.
120 %endif
121
122 %package -n org.tizen.crash-syspopup
123 Summary:    System popup application (crash system popup)
124 Group:      System/Utilities
125 Requires:   %{name} = %{version}-%{release}
126
127 %description -n org.tizen.crash-syspopup
128 to inform user crash information. It is activated
129 when crash event is happend
130
131 %package -n org.tizen.powerkey-syspopup.mobile
132 Summary:    Powerkey-popup application
133 Group:      System/Utilities
134 Requires:   %{name} = %{version}-%{release}
135
136 %description -n org.tizen.powerkey-syspopup.mobile
137 to inform user powerkey information. It is activated
138 when user power key event is happened
139
140 %package -n org.tizen.powerkey-syspopup.wearable
141 Summary:    Powerkey-popup application
142 Group:      System/Utilities
143 Requires:   %{name} = %{version}-%{release}
144
145 %description -n org.tizen.powerkey-syspopup.wearable
146 to inform user powerkey information. It is activated
147 when user power key event is happened
148
149 %package -n org.tizen.overheat-syspopup
150 Summary:    Overheat-popup application
151 Group:      System/Utilities
152 Requires:   %{name} = %{version}-%{release}
153
154 %description -n org.tizen.overheat-syspopup
155 to inform user overheat information. It is activated
156 when overheat event is happened
157
158 %package -n org.tizen.system-signal-sender
159 Summary:    System FW signal sender
160 Group:      System/Utilities
161 Requires:   %{name} = %{version}-%{release}
162
163 %description -n org.tizen.system-signal-sender
164 to inform user system FW signal sender. It is activated
165 when system event is happend
166
167 %package -n org.tizen.system-syspopup.mobile
168 Summary:    System popup application
169 Group:      System/Utilities
170 Requires:   %{name} = %{version}-%{release}
171
172 %description -n org.tizen.system-syspopup.mobile
173 to inform user system information. It is activated
174 when system event is happend
175
176 %package -n org.tizen.system-syspopup.wearable
177 Summary:    System popup application
178 Group:      System/Utilities
179 Requires:   %{name} = %{version}-%{release}
180
181 %description -n org.tizen.system-syspopup.wearable
182 to inform user system information. It is activated
183 when system event is happend
184
185 %prep
186 %setup -q
187
188 %build
189 chmod 0644 %{SOURCE1}
190 cp %{SOURCE1} .
191
192 chmod 0644 %{SOURCE1001}
193 cp %{SOURCE1001} .
194
195 chmod 0644 %{SOURCE1002}
196 cp %{SOURCE1002} .
197
198 chmod 0644 %{SOURCE1015}
199 cp %{SOURCE1015} .
200
201 chmod 0644 %{SOURCE2001}
202 cp %{SOURCE2001} .
203
204 chmod 0644 %{SOURCE2003}
205 cp %{SOURCE2003} .
206
207 %define DPMS none
208 %if %{with wayland}
209 %define DPMS wayland
210 %endif
211
212
213 # BUILD MOBILE
214 echo T1
215 mkdir -p build_mobile
216 pushd build_mobile
217 %cmake .. \
218                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
219                 -DPKGNAME=%{name} \
220                 -DPROFILE=mobile \
221                 -DFORMFACTOR=rectangle \
222                 -DDPMS=%{DPMS} \
223                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
224                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
225                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
226                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
227                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
228                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
229                 -DNOTIFICATION_SERVICE=on \
230
231 echo T2
232
233 make %{?jobs:-j%jobs}
234 rm -rf %{buildroot}
235 %make_install
236 popd
237
238 mkdir -p profile_mobile
239 mkdir -p profile_mobile/%{_bindir}
240 mkdir -p profile_mobile/%{_datadir}/system-apps/res/icons
241 mkdir -p profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
242 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
243 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
244 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
245 mkdir -p profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
246 mv %{buildroot}/%{_bindir}/sysapp-launcher profile_mobile/%{_bindir}/sysapp-launcher.mobile
247 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
248 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
249 mv %{buildroot}/%{_datadir}/system-apps/res/icons/*.png profile_mobile/%{_datadir}/system-apps/res/icons
250 %if "%{_datadir}" != "%{TZ_SYS_RO_SHARE}"
251 mv %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/*.png profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
252 %endif
253 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
254 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
255 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res
256 ls -la profile_mobile/%{_bindir}
257 ls -la profile_mobile/%{_datadir}/system-apps/res/icons
258 ls -la profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons
259 ls -la profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
260
261 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
262 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
263 # BUILD WEARABLE
264 mkdir -p build_rec_wearable
265 pushd build_rec_wearable
266 %cmake .. \
267                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
268                 -DPKGNAME=%{name} \
269                 -DPROFILE=wearable \
270                 -DFORMFACTOR=rectangle \
271                 -DDPMS=%{DPMS} \
272                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
273                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
274                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
275                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
276                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
277                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
278                 -DNOTIFICATION_SERVICE=off
279
280 make %{?jobs:-j%jobs}
281 rm -rf %{buildroot}
282 %make_install
283 popd
284
285 mkdir -p rec-profile_wearable/%{_bindir}
286 mkdir -p rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
287 mkdir -p rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
288 mv %{buildroot}/%{_bindir}/sysapp-launcher rec-profile_wearable/%{_bindir}/sysapp-launcher.wearable
289 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
290 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup rec-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
291
292 mkdir -p rec-profile_wearable/shared/res
293 mkdir -p rec-profile_wearable/res/
294 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj rec-profile_wearable/shared/res/
295 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png rec-profile_wearable/res/
296
297 # BUILD WEARABLE CIRCLE EXTENSION
298 mkdir -p build_cir_wearable
299 pushd build_cir_wearable
300 %cmake .. \
301                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
302                 -DPKGNAME=%{name} \
303                 -DPROFILE=wearable \
304                 -DFORMFACTOR=circle \
305                 -DDPMS=%{DPMS} \
306                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
307                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
308                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
309                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
310                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
311                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
312                 -DNOTIFICATION_SERVICE=off
313
314 make %{?jobs:-j%jobs}
315 rm -rf %{buildroot}
316 %make_install
317 popd
318
319 mkdir -p cir-profile_wearable
320 mkdir -p cir-profile_wearable/%{_bindir}
321 mkdir -p cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin
322 mkdir -p cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin
323 mv %{buildroot}/%{_bindir}/sysapp-launcher cir-profile_wearable/%{_bindir}/sysapp-launcher.wearable
324 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
325 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
326
327 mkdir -p cir-profile_wearable/shared/res
328 mkdir -p cir-profile_wearable/res/
329 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj cir-profile_wearable/shared/res/
330 mv %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png cir-profile_wearable/res/
331 %endif
332
333 # BUILD COMMON/TV
334 mkdir -p build_common
335 pushd build_common
336 %cmake .. \
337                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
338                 -DPKGNAME=%{name} \
339                 -DPROFILE=common \
340                 -DFORMFACTOR=rectangle \
341                 -DDPMS=%{DPMS} \
342                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
343                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
344                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
345                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
346                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
347                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
348                 -DNOTIFICATION_SERVICE=off
349
350 make %{?jobs:-j%jobs}
351 rm -rf %{buildroot}
352 %make_install
353 popd
354
355 mkdir -p profile_common
356 mkdir -p profile_common/%{_bindir}
357 mv %{buildroot}/%{_bindir}/sysapp-launcher profile_common/%{_bindir}/sysapp-launcher.common
358
359 %install
360 pushd build_common
361 %make_install
362 popd
363
364 #for mobile profile
365 mkdir -p %{buildroot}/%{_bindir}
366 install -m 0755 profile_mobile/%{_bindir}/* %{buildroot}/%{_bindir}
367 mkdir -p %{buildroot}/%{_datadir}/system-apps/res/icons/
368 install -m 0644 profile_mobile/%{_datadir}/system-apps/res/icons/*.png %{buildroot}/%{_datadir}/system-apps/res/icons/
369 %if "%{_datadir}" != "%{TZ_SYS_RO_SHARE}"
370 mkdir -p %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/
371 install -m 0644 profile_mobile/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/*.png %{buildroot}/%{TZ_SYS_RO_SHARE}/system-apps/res/icons/
372 %endif
373 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
374 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
375 install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
376 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
377 install -m 0755 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
378 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
379 install -m 0644 profile_mobile/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
380
381 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
382 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
383 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res
384 mkdir -p %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res
385 install -m 0644 rec-profile_wearable/shared/res/*.edj %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/
386 install -m 0644 rec-profile_wearable/res/*.png %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
387 install -m 0755 cir-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
388 install -m 0755 rec-profile_wearable/%{_bindir}/* %{buildroot}/%{_bindir}
389 install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
390 install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
391 install -m 0644 data/circle_btn_check.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
392 install -m 0644 data/circle_btn_delete.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/
393 install -m 0644 data/gear_device_options_bg.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
394 install -m 0644 data/gear_device_options_power_off.png %{buildroot}%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/
395 install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
396 install -m 0755 cir-profile_wearable/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
397 %endif
398
399 #for common profile
400 install -m 0755 profile_common/%{_bindir}/* %{buildroot}/%{_bindir}
401
402 # This is not used. (mobile/wearable has its own postfixed version)
403 rm %{buildroot}%{_bindir}/sysapp-launcher
404 rm %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
405 rm %{buildroot}/%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
406
407
408 %post profile_mobile
409 # This does not support proper uninstall. To uninstall profile_mobile with
410 # correct system-servant kept, you need to reinstall system-servant after
411 # uninstalling profile_mobile
412 mv /%{_bindir}/sysapp-launcher.mobile /%{_bindir}/sysapp-launcher
413 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
414
415 # Because of CAPI incompatibility from EFL-EXT, circle is buildable only for wearable and "unified (undefined)"
416 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
417 %post extension-circle-profile_wearable
418 # This does not support proper uninstall. To uninstall profile_wearable-circle with
419 # correct system-servant kept, you need to reinstall system-servant after
420 # uninstalling profile_wearable-circle
421 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
422 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
423
424 %post extension-rectangle-profile_wearable
425 # This does not support proper uninstall. To uninstall profile_wearable-rectangle with
426 # correct system-servant kept, you need to reinstall system-servant after
427 # uninstalling profile_wearable-rectangle
428 mv /%{_bindir}/sysapp-launcher.wearable /%{_bindir}/sysapp-launcher
429 mv /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable /%{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
430 %endif
431
432 %post profile_common
433 # This does not support proper uninstall. To uninstall profile_common with
434 # correct system-servant kept, you need to reinstall system-servant after
435 # uninstalling profile_common
436 mv /%{_bindir}/sysapp-launcher.common /%{_bindir}/sysapp-launcher
437
438 %post -n org.tizen.powerkey-syspopup.mobile
439 mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
440
441 %post -n org.tizen.powerkey-syspopup.wearable
442 mv /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable /%{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
443
444 %files
445 %manifest %{name}.manifest
446 %license LICENSE.Apache-2.0
447 %{_unitdir}/system-popup.service
448 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
449 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
450
451 #po files to support multi-languages
452 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
453 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
454 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
455 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
456 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
457 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
458 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
459 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
460 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
461 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
462 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
463 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
464 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
465 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
466 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
467 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
468 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
469 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
470 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
471 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
472 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
473 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
474 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
475 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
476 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
477 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
478 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
479 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
480 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
481 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
482 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
483 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
484 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
485 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
486 %lang(ko_KR) %{_datadir}/locale/ko_KR/LC_MESSAGES/system-servant.mo
487 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
488 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
489 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
490 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
491 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
492 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
493 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
494 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
495 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
496 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
497 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
498 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
499 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
500 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
501 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
502 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
503 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
504 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
505 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
506 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
507 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
508 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
509 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
510 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
511 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
512 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
513
514 %files profile_mobile
515 %license LICENSE.Apache-2.0
516 %defattr(-,root,root,-)
517 %{_bindir}/sysapp-launcher.mobile
518 %{_bindir}/system-cooperator
519 %{_datadir}/system-apps/res/icons/batt_full_icon.png
520 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
521 %{_datadir}/system-apps/res/icons/noti_charging_battery_low.png
522 %{_datadir}/system-apps/res/icons/noti_cooling_down.png
523 %{_datadir}/system-apps/res/icons/datausage_warning.png
524 %{_datadir}/system-apps/res/icons/led_torch.png
525 %{_datadir}/system-apps/res/icons/usb_icon.png
526
527 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
528 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
529 %files extension-circle-profile_wearable
530 %license LICENSE.Apache-2.0
531 %defattr(-,root,root,-)
532 %{_bindir}/sysapp-launcher.wearable
533 %{_bindir}/system-cooperator
534
535 %files extension-rectangle-profile_wearable
536 %license LICENSE.Apache-2.0
537 %defattr(-,root,root,-)
538 %{_bindir}/sysapp-launcher.wearable
539 %{_bindir}/system-cooperator
540 %endif
541
542 %files profile_common
543 %license LICENSE.Apache-2.0
544 %defattr(-,root,root,-)
545 %{_bindir}/sysapp-launcher.common
546
547 %files -n org.tizen.crash-syspopup
548 %manifest org.tizen.crash-syspopup.manifest
549 %license LICENSE.Apache-2.0
550 %defattr(-,root,root,-)
551 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
552 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
553
554 %files -n org.tizen.system-syspopup.mobile
555 %manifest org.tizen.system-syspopup.manifest
556 %license LICENSE.Apache-2.0
557 %defattr(-,root,root,-)
558 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.mobile
559 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/usb-popup.edj
560 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
561
562 # Because of CAPI incompatibility from EFL-EXT, wearable is buildable only for wearable and "unified (undefined)"
563 %if "%{?profile}"!="mobile" && "%{?profile}"!="tv" && "%{?profile}"!="common"
564 %files -n org.tizen.system-syspopup.wearable
565 %manifest org.tizen.system-syspopup.manifest
566 %license LICENSE.Apache-2.0
567 %defattr(-,root,root,-)
568 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup.wearable
569 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/shared/res/cooldown-popup.edj
570 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/overheat.png
571 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_check.png
572 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/res/circle_btn_delete.png
573 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
574
575 %files -n org.tizen.powerkey-syspopup.wearable
576 %manifest org.tizen.powerkey-syspopup.manifest
577 %license LICENSE.Apache-2.0
578 %defattr(-,root,root,-)
579 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.wearable
580 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
581 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
582 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/gear_device_options_bg.png
583 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/gear_device_options_power_off.png
584 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
585 %endif
586
587 %files -n org.tizen.powerkey-syspopup.mobile
588 %manifest org.tizen.powerkey-syspopup.manifest
589 %license LICENSE.Apache-2.0
590 %defattr(-,root,root,-)
591 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup.mobile
592 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
593 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
594 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
595
596 %files -n org.tizen.overheat-syspopup
597 %manifest org.tizen.overheat-syspopup.manifest
598 %license LICENSE.Apache-2.0
599 %defattr(-,root,root,-)
600 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/bin/overheat-popup
601 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/shared/res/overheat-popup.edj
602 %{TZ_SYS_RO_SHARE}/packages/org.tizen.overheat-syspopup.xml
603
604 %files -n org.tizen.system-signal-sender
605 %manifest org.tizen.system-signal-sender.manifest
606 %license LICENSE.Apache-2.0
607 %defattr(-,root,root,-)
608 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
609 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
610
611 # The followings are meta packages to keep the compatibility with conventional profiles.
612 %files profile_tv