b14521f98db0f0bbb2f96c5fcea58376e79be77c
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with x
2 %bcond_with wayland
3 %bcond_with emulator
4
5 %define PROFILE common
6 %define FORMFACTOR none
7
8 #Main applications
9 %define powerkey_popup off
10 %define overheat_popup off
11 %define crash_popup off
12 %define system_popup off
13 %define notification_service off
14 %define signal_sender off
15 #sub-popups of system-popup
16 %define battery_popup off
17 %define cooldown_popup off
18 %define mmc_popup off
19 %define usb_popup off
20 %define watchdog_popup off
21 %define storage_popup off
22 %define system_cooperator off
23
24 %if "%{?profile}" == "mobile"
25 %define PROFILE mobile
26 #Main applicaitons
27 %define powerkey_popup on
28 %define overheat_popup on
29 %define crash_popup on
30 %define system_popup on
31 %define notification_service on
32 %define signal_sender on
33 %define system_cooperator on
34 #sub-popups of system-popup
35 %define battery_popup on
36 %define cooldown_popup on
37 %define mmc_popup on
38 %define usb_popup on
39 %define watchdog_popup on
40 %define storage_popup on
41 %endif
42
43 %if "%{?profile}" == "wearable"
44 %define PROFILE wearable
45 %if "%_repository" == "target-circle" || "%_repository" == "emulator-circle"
46         %define FORMFACTOR circle
47 %else
48         %define FORMFACTOR rectangle
49 %endif
50 #Main applicaitons
51 %define powerkey_popup on
52 %define overheat_popup off
53 %define crash_popup on
54 %define system_popup on
55 %define system_cooperator on
56 #sub-popups of system-popup
57 %define storage_popup on
58 %define watchdog_popup on
59 %define battery_popup on
60 %define cooldown_popup on
61 %endif
62
63 %if "%{?profile}" == "tv"
64 %define PROFILE tv
65 #Main applications
66 %define crash_popup on
67 #sub-popups of system-popup
68 %endif
69
70 Name:       system-servant
71 Summary:    Servant application for System FW
72 Version:    0.2.0
73 Release:    1
74 Group:      System/Utilities
75 License:    Apache-2.0
76 Source0:    %{name}-%{version}.tar.gz
77 Source1:    %{name}.manifest
78 Source1001:    org.tizen.powerkey-syspopup.manifest
79 Source1002:    org.tizen.overheat-syspopup.manifest
80 Source1015:    org.tizen.crash-syspopup.manifest
81 Source2001:    org.tizen.system-syspopup.manifest
82 Source2003:    org.tizen.system-signal-sender.manifest
83 BuildRequires:  pkgconfig(appsvc)
84 BuildRequires:  pkgconfig(pkgmgr-info)
85 BuildRequires:  pkgconfig(elementary)
86 BuildRequires:  pkgconfig(appcore-efl)
87 BuildRequires:  pkgconfig(syspopup)
88 BuildRequires:  pkgconfig(syspopup-caller)
89 BuildRequires:  pkgconfig(notification)
90 BuildRequires:  pkgconfig(vconf)
91 BuildRequires:  pkgconfig(glib-2.0)
92 BuildRequires:  pkgconfig(dlog)
93 BuildRequires:  pkgconfig(dbus-1)
94 BuildRequires:  pkgconfig(edbus)
95 BuildRequires:  pkgconfig(deviced)
96 BuildRequires:  pkgconfig(feedback)
97 BuildRequires:  pkgconfig(efl-extension)
98 BuildRequires:  pkgconfig(libtzplatform-config)
99 BuildRequires:  edje-bin
100 BuildRequires:  pkgconfig(capi-media-sound-manager)
101 BuildRequires:  pkgconfig(capi-media-wav-player)
102
103 %if %{with x}
104 BuildRequires:  pkgconfig(ecore-x)
105 BuildRequires:  pkgconfig(utilX)
106 %endif
107 BuildRequires:  cmake
108 BuildRequires:  gettext-devel
109
110 %description
111 System applications such as app-launcher
112 and service file for dbus activation
113
114 %if %{?crash_popup} == on
115 %package -n org.tizen.crash-syspopup
116 Summary:    System popup application (crash system popup)
117 Group:      System/Utilities
118 Requires:   %{name} = %{version}-%{release}
119
120 %description -n org.tizen.crash-syspopup
121 to inform user crash information. It is activated
122 when crash event is happend
123 %endif
124
125 %if %{?powerkey_popup} == on
126 %package -n org.tizen.powerkey-syspopup
127 Summary:    Powerkey-popup application
128 Group:      System/Utilities
129 Requires:   %{name} = %{version}-%{release}
130
131 %description -n org.tizen.powerkey-syspopup
132 to inform user powerkey information. It is activated
133 when user power key event is happened
134 %endif
135
136 %if %{?overheat_popup} == on
137 %package -n org.tizen.overheat-syspopup
138 Summary:    Overheat-popup application
139 Group:      System/Utilities
140 Requires:   %{name} = %{version}-%{release}
141
142 %description -n org.tizen.overheat-syspopup
143 to inform user overheat information. It is activated
144 when overheat event is happened
145 %endif
146
147 %if %{?signal_sender} == on
148 %package -n org.tizen.system-signal-sender
149 Summary:    System FW signal sender
150 Group:      System/Utilities
151 Requires:   %{name} = %{version}-%{release}
152
153 %description -n org.tizen.system-signal-sender
154 to inform user system FW signal sender. It is activated
155 when system event is happend
156 %endif
157
158 %if %{?system_popup} == on
159 %package -n org.tizen.system-syspopup
160 Summary:    System popup application
161 Group:      System/Utilities
162 Requires:   %{name} = %{version}-%{release}
163
164 %description -n org.tizen.system-syspopup
165 to inform user system information. It is activated
166 when system event is happend
167
168 %endif # system_popup
169
170 %prep
171 %setup -q
172
173 %build
174 chmod 0644 %{SOURCE1}
175 cp %{SOURCE1} .
176
177 %if %{powerkey_popup} == on
178 chmod 0644 %{SOURCE1001}
179 cp %{SOURCE1001} .
180 %endif
181
182 %if %{overheat_popup} == on
183 chmod 0644 %{SOURCE1002}
184 cp %{SOURCE1002} .
185 %endif
186
187 %if %{crash_popup} == on
188 chmod 0644 %{SOURCE1015}
189 cp %{SOURCE1015} .
190 %endif
191
192 %if %{system_popup} == on
193 chmod 0644 %{SOURCE2001}
194 cp %{SOURCE2001} .
195 %endif
196
197 %if %{signal_sender} == on
198 chmod 0644 %{SOURCE2003}
199 cp %{SOURCE2003} .
200 %endif
201
202 %define DPMS none
203 %if %{with x}
204 %define DPMS x
205 %endif
206 %if %{with wayland}
207 %define DPMS wayland
208 %endif
209
210 %cmake . \
211                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
212                 -DPKGNAME=%{name} \
213                 -DPROFILE=%{PROFILE} \
214                 -DFORMFACTOR=%{FORMFACTOR} \
215                 -DDPMS=%{DPMS} \
216                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
217                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
218                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
219                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
220                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
221                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
222                 -DPOWERKEY_POPUP=%{powerkey_popup} \
223                 -DCRASH_POPUP=%{crash_popup} \
224                 -DNOTIFICATION_SERVICE=%{notification_service} \
225                 -DBATTERY_POPUP=%{battery_popup} \
226                 -DCOOLDOWN_POPUP=%{cooldown_popup} \
227                 -DSYSTEM_POPUP=%{system_popup} \
228                 -DSIGNAL_SENDER=%{signal_sender} \
229                 -DSYSTEM_COOPERATOR=%{system_cooperator} \
230                 -DMMC_POPUP=%{mmc_popup} \
231                 -DSTORAGE_POPUP=%{storage_popup} \
232                 -DUSB_POPUP=%{usb_popup} \
233                 -DWATCHDOG_POPUP=%{watchdog_popup} \
234                 -DOVERHEAT_POPUP=%{overheat_popup} \
235
236 make %{?jobs:-j%jobs}
237
238 %install
239 rm -rf %{buildroot}
240 %make_install
241
242
243 %files
244 %manifest %{name}.manifest
245 %{_bindir}/sysapp-launcher
246 %{_datadir}/license/sysapp-launcher
247 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
248 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
249
250 #po files to support multi-languages
251 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
252 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
253 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
254 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
255 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
256 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
257 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
258 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
259 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
260 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
261 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
262 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
263 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
264 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
265 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
266 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
267 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
268 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
269 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
270 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
271 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
272 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
273 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
274 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
275 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
276 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
277 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
278 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
279 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
280 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
281 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
282 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
283 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
284 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
285 %lang(ko_KR) %{_datadir}/locale/ko_KR/LC_MESSAGES/system-servant.mo
286 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
287 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
288 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
289 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
290 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
291 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
292 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
293 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
294 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
295 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
296 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
297 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
298 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
299 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
300 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
301 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
302 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
303 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
304 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
305 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
306 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
307 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
308 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
309 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
310 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
311 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
312
313 %if %{notification_service} == on
314 %{_datadir}/system-apps/res/icons/batt_full_icon.png
315 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
316 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/datausage_warning.png
317 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/led_torch.png
318 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/usb_icon.png
319 %endif
320
321 %if %{system_cooperator} == on
322 %{_bindir}/system-cooperator
323 %endif
324
325 %if %{crash_popup} == on
326 %files -n org.tizen.crash-syspopup
327 %manifest org.tizen.crash-syspopup.manifest
328 %license LICENSE
329 %defattr(-,root,root,-)
330 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
331 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
332 %endif
333
334 %if %{system_popup} == on
335 %files -n org.tizen.system-syspopup
336 %manifest org.tizen.system-syspopup.manifest
337 %defattr(-,root,root,-)
338 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
339 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
340 %endif
341
342 %if %{powerkey_popup} == on
343 %files -n org.tizen.powerkey-syspopup
344 %manifest org.tizen.powerkey-syspopup.manifest
345 %license LICENSE
346 %defattr(-,root,root,-)
347 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
348 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
349 %if "%{?profile}" == "mobile"
350 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_power_off.png
351 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/core_restart.png
352 %endif
353 %if "%{?profile}" == "wearable"
354 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
355 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
356 %endif
357 %endif
358
359 %if %{overheat_popup} == on
360 %files -n org.tizen.overheat-syspopup
361 %manifest org.tizen.overheat-syspopup.manifest
362 %license LICENSE
363 %defattr(-,root,root,-)
364 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/bin/overheat-popup
365 %{TZ_SYS_RO_APP}/org.tizen.overheat-syspopup/shared/res/overheat-popup.edj
366 %{TZ_SYS_RO_SHARE}/packages/org.tizen.overheat-syspopup.xml
367 %endif
368
369 %if %{signal_sender} == on
370 %files -n org.tizen.system-signal-sender
371 %manifest org.tizen.system-signal-sender.manifest
372 %defattr(-,root,root,-)
373 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
374 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
375 %endif