Added unmount popup and removed useless source
[platform/core/system/system-popup.git] / packaging / system-servant.spec
1 %bcond_with x
2 %bcond_with wayland
3 %bcond_with emulator
4
5 %define PROFILE common
6 %define FORMFACTOR none
7
8 #Main applications
9 %define powerkey_popup off
10 %define crash_popup off
11 %define system_popup off
12 %define notification_service off
13 %define signal_sender off
14 #sub-popups of system-popup
15 %define battery_popup off
16 %define mmc_popup off
17 %define usb_popup off
18 %define watchdog_popup off
19 %define overheat_popup off
20 %define storage_popup off
21
22 %if "%{?profile}" == "mobile"
23 %define PROFILE mobile
24 #Main applicaitons
25 %define powerkey_popup on
26 %define crash_popup on
27 %define system_popup on
28 %define notification_service on
29 %define signal_sender on
30 #sub-popups of system-popup
31 %define battery_popup on
32 %define mmc_popup on
33 %define usb_popup on
34 %define watchdog_popup on
35 %define overheat_popup on
36 %define storage_popup on
37 %endif
38
39 %if "%{?profile}" == "wearable"
40 %define PROFILE wearable
41 %if "%_repository" == "target-circle" || "%_repository" == "emulator-circle"
42         %define FORMFACTOR circle
43 %else
44         %define FORMFACTOR rectangle
45 %endif
46 #Main applicaitons
47 %define powerkey_popup on
48 %define crash_popup on
49 %define system_popup on
50 #sub-popups of system-popup
51 %define storage_popup on
52 %define watchdog_popup on
53 %define battery_popup on
54 %define overheat_popup on
55 %endif
56
57 %if "%{?profile}" == "tv"
58 %define PROFILE tv
59 #Main applications
60 %define crash_popup on
61 %endif
62
63 Name:       system-servant
64 Summary:    Servant application for System FW
65 Version:    0.2.0
66 Release:    1
67 Group:      System/Utilities
68 License:    Apache-2.0
69 Source0:    %{name}-%{version}.tar.gz
70 Source1:    %{name}.manifest
71 Source1001:    org.tizen.powerkey-syspopup.manifest
72 Source1015:    org.tizen.crash-syspopup.manifest
73 Source2001:    org.tizen.system-syspopup.manifest
74 Source2003:    org.tizen.system-signal-sender.manifest
75 BuildRequires:  pkgconfig(appsvc)
76 BuildRequires:  pkgconfig(pkgmgr-info)
77 BuildRequires:  pkgconfig(elementary)
78 BuildRequires:  pkgconfig(appcore-efl)
79 BuildRequires:  pkgconfig(syspopup)
80 BuildRequires:  pkgconfig(syspopup-caller)
81 BuildRequires:  pkgconfig(notification)
82 BuildRequires:  pkgconfig(vconf)
83 BuildRequires:  pkgconfig(glib-2.0)
84 BuildRequires:  pkgconfig(dlog)
85 BuildRequires:  pkgconfig(dbus-1)
86 BuildRequires:  pkgconfig(edbus)
87 BuildRequires:  pkgconfig(deviced)
88 BuildRequires:  pkgconfig(feedback)
89 BuildRequires:  pkgconfig(efl-extension)
90 BuildRequires:  pkgconfig(libtzplatform-config)
91 %if %{with x}
92 BuildRequires:  pkgconfig(ecore-x)
93 BuildRequires:  pkgconfig(utilX)
94 %endif
95 BuildRequires:  cmake
96 BuildRequires:  gettext-devel
97
98 %description
99 System applications such as app-launcher
100 and service file for dbus activation
101
102 %if %{?crash_popup} == on
103 %package -n org.tizen.crash-syspopup
104 Summary:    System popup application (crash system popup)
105 Group:      System/Utilities
106 Requires:   %{name} = %{version}-%{release}
107
108 %description -n org.tizen.crash-syspopup
109 to inform user crash information. It is activated
110 when crash event is happend
111 %endif
112
113 %if %{?powerkey_popup} == on
114 %package -n org.tizen.powerkey-syspopup
115 Summary:    Powerkey-popup application
116 Group:      System/Utilities
117 Requires:   %{name} = %{version}-%{release}
118
119 %description -n org.tizen.powerkey-syspopup
120 to inform user powerkey information. It is activated
121 when user power key event is happened
122 %endif
123
124 %if %{?signal_sender} == on
125 %package -n org.tizen.system-signal-sender
126 Summary:    System FW signal sender
127 Group:      System/Utilities
128 Requires:   %{name} = %{version}-%{release}
129
130 %description -n org.tizen.system-signal-sender
131 to inform user system FW signal sender. It is activated
132 when system event is happend
133 %endif
134
135 %if %{?system_popup} == on
136 %package -n org.tizen.system-syspopup
137 Summary:    System popup application
138 Group:      System/Utilities
139 Requires:   %{name} = %{version}-%{release}
140
141 %description -n org.tizen.system-syspopup
142 to inform user system information. It is activated
143 when system event is happend
144
145 %endif # system_popup
146
147 %prep
148 %setup -q
149
150 %build
151 chmod 0644 %{SOURCE1}
152 cp %{SOURCE1} .
153
154 %if %{powerkey_popup} == on
155 chmod 0644 %{SOURCE1001}
156 cp %{SOURCE1001} .
157 %endif
158
159 %if %{crash_popup} == on
160 chmod 0644 %{SOURCE1015}
161 cp %{SOURCE1015} .
162 %endif
163
164 %if %{system_popup} == on
165 chmod 0644 %{SOURCE2001}
166 cp %{SOURCE2001} .
167 %endif
168
169 %if %{signal_sender} == on
170 chmod 0644 %{SOURCE2003}
171 cp %{SOURCE2003} .
172 %endif
173
174 %define DPMS none
175 %if %{with x}
176 %define DPMS x
177 %endif
178 %if %{with wayland}
179 %define DPMS wayland
180 %endif
181
182 %cmake . \
183                 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
184                 -DPKGNAME=%{name} \
185                 -DPROFILE=%{PROFILE} \
186                 -DFORMFACTOR=%{FORMFACTOR} \
187                 -DDPMS=%{DPMS} \
188                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
189                 -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
190                 -DTZ_SYS_SMACK=%{TZ_SYS_SMACK} \
191                 -DTZ_SYS_SHARE=%{TZ_SYS_SHARE} \
192                 -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
193                 -DTZ_SYS_RO_APP=%{TZ_SYS_RO_APP} \
194                 -DPOWERKEY_POPUP=%{powerkey_popup} \
195                 -DCRASH_POPUP=%{crash_popup} \
196                 -DNOTIFICATION_SERVICE=%{notification_service} \
197                 -DBATTERY_POPUP=%{battery_popup} \
198                 -DSYSTEM_POPUP=%{system_popup} \
199                 -DSIGNAL_SENDER=%{signal_sender} \
200                 -DMMC_POPUP=%{mmc_popup} \
201                 -DSTORAGE_POPUP=%{storage_popup} \
202                 -DUSB_POPUP=%{usb_popup} \
203                 -DWATCHDOG_POPUP=%{watchdog_popup} \
204
205 make %{?jobs:-j%jobs}
206
207 %install
208 rm -rf %{buildroot}
209 %make_install
210
211
212 %files
213 %manifest %{name}.manifest
214 %{_bindir}/sysapp-launcher
215 %{_datadir}/license/sysapp-launcher
216 %{_datadir}/dbus-1/system-services/org.tizen.system.popup.service
217 %config %{_sysconfdir}/dbus-1/system.d/launcher.conf
218
219 #po files to support multi-languages
220 %lang(ar) %{_datadir}/locale/ar/LC_MESSAGES/system-servant.mo
221 %lang(az) %{_datadir}/locale/az/LC_MESSAGES/system-servant.mo
222 %lang(bg) %{_datadir}/locale/bg/LC_MESSAGES/system-servant.mo
223 %lang(bn) %{_datadir}/locale/bn/LC_MESSAGES/system-servant.mo
224 %lang(ca) %{_datadir}/locale/ca/LC_MESSAGES/system-servant.mo
225 %lang(cs) %{_datadir}/locale/cs/LC_MESSAGES/system-servant.mo
226 %lang(da) %{_datadir}/locale/da/LC_MESSAGES/system-servant.mo
227 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/system-servant.mo
228 %lang(el_GR) %{_datadir}/locale/el_GR/LC_MESSAGES/system-servant.mo
229 %lang(en_PH) %{_datadir}/locale/en_PH/LC_MESSAGES/system-servant.mo
230 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/system-servant.mo
231 %lang(en_US) %{_datadir}/locale/en_US/LC_MESSAGES/system-servant.mo
232 %lang(es_ES) %{_datadir}/locale/es_ES/LC_MESSAGES/system-servant.mo
233 %lang(es_US) %{_datadir}/locale/es_US/LC_MESSAGES/system-servant.mo
234 %lang(et) %{_datadir}/locale/et/LC_MESSAGES/system-servant.mo
235 %lang(eu) %{_datadir}/locale/eu/LC_MESSAGES/system-servant.mo
236 %lang(fa) %{_datadir}/locale/fa/LC_MESSAGES/system-servant.mo
237 %lang(fi) %{_datadir}/locale/fi/LC_MESSAGES/system-servant.mo
238 %lang(fr_CA) %{_datadir}/locale/fr_CA/LC_MESSAGES/system-servant.mo
239 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/system-servant.mo
240 %lang(ga) %{_datadir}/locale/ga/LC_MESSAGES/system-servant.mo
241 %lang(gl) %{_datadir}/locale/gl/LC_MESSAGES/system-servant.mo
242 %lang(gu) %{_datadir}/locale/gu/LC_MESSAGES/system-servant.mo
243 %lang(he) %{_datadir}/locale/he/LC_MESSAGES/system-servant.mo
244 %lang(hi) %{_datadir}/locale/hi/LC_MESSAGES/system-servant.mo
245 %lang(hr) %{_datadir}/locale/hr/LC_MESSAGES/system-servant.mo
246 %lang(hu) %{_datadir}/locale/hu/LC_MESSAGES/system-servant.mo
247 %lang(hy) %{_datadir}/locale/hy/LC_MESSAGES/system-servant.mo
248 %lang(is) %{_datadir}/locale/is/LC_MESSAGES/system-servant.mo
249 %lang(it_IT) %{_datadir}/locale/it_IT/LC_MESSAGES/system-servant.mo
250 %lang(ja_JP) %{_datadir}/locale/ja_JP/LC_MESSAGES/system-servant.mo
251 %lang(ka) %{_datadir}/locale/ka/LC_MESSAGES/system-servant.mo
252 %lang(kk) %{_datadir}/locale/kk/LC_MESSAGES/system-servant.mo
253 %lang(kn) %{_datadir}/locale/kn/LC_MESSAGES/system-servant.mo
254 %lang(lt) %{_datadir}/locale/lt/LC_MESSAGES/system-servant.mo
255 %lang(lv) %{_datadir}/locale/lv/LC_MESSAGES/system-servant.mo
256 %lang(mk) %{_datadir}/locale/mk/LC_MESSAGES/system-servant.mo
257 %lang(ml) %{_datadir}/locale/ml/LC_MESSAGES/system-servant.mo
258 %lang(nb) %{_datadir}/locale/nb/LC_MESSAGES/system-servant.mo
259 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/system-servant.mo
260 %lang(pl) %{_datadir}/locale/pl/LC_MESSAGES/system-servant.mo
261 %lang(pt_BR) %{_datadir}/locale/pt_BR/LC_MESSAGES/system-servant.mo
262 %lang(pt_PT) %{_datadir}/locale/pt_PT/LC_MESSAGES/system-servant.mo
263 %lang(ro) %{_datadir}/locale/ro/LC_MESSAGES/system-servant.mo
264 %lang(ru_RU) %{_datadir}/locale/ru_RU/LC_MESSAGES/system-servant.mo
265 %lang(si) %{_datadir}/locale/si/LC_MESSAGES/system-servant.mo
266 %lang(sk) %{_datadir}/locale/sk/LC_MESSAGES/system-servant.mo
267 %lang(sl) %{_datadir}/locale/sl/LC_MESSAGES/system-servant.mo
268 %lang(sr) %{_datadir}/locale/sr/LC_MESSAGES/system-servant.mo
269 %lang(sv) %{_datadir}/locale/sv/LC_MESSAGES/system-servant.mo
270 %lang(ta) %{_datadir}/locale/ta/LC_MESSAGES/system-servant.mo
271 %lang(te) %{_datadir}/locale/te/LC_MESSAGES/system-servant.mo
272 %lang(th) %{_datadir}/locale/th/LC_MESSAGES/system-servant.mo
273 %lang(tr_TR) %{_datadir}/locale/tr_TR/LC_MESSAGES/system-servant.mo
274 %lang(uk) %{_datadir}/locale/uk/LC_MESSAGES/system-servant.mo
275 %lang(ur) %{_datadir}/locale/ur/LC_MESSAGES/system-servant.mo
276 %lang(uz) %{_datadir}/locale/uz/LC_MESSAGES/system-servant.mo
277 %lang(zh_CN) %{_datadir}/locale/zh_CN/LC_MESSAGES/system-servant.mo
278 %lang(zh_HK) %{_datadir}/locale/zh_HK/LC_MESSAGES/system-servant.mo
279 %lang(zh_TW) %{_datadir}/locale/zh_TW/LC_MESSAGES/system-servant.mo
280
281 %if %{notification_service} == on
282 %{_datadir}/system-apps/res/icons/batt_full_icon.png
283 %{_datadir}/system-apps/res/icons/batt_full_indicator.png
284 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/datausage_warning.png
285 %{TZ_SYS_RO_SHARE}/system-apps/res/icons/led_torch.png
286 %endif
287
288 %if %{crash_popup} == on
289 %files -n org.tizen.crash-syspopup
290 %manifest org.tizen.crash-syspopup.manifest
291 %license LICENSE
292 %defattr(-,root,root,-)
293 %{TZ_SYS_RO_APP}/org.tizen.crash-syspopup/bin/crash-popup
294 %{TZ_SYS_RO_SHARE}/packages/org.tizen.crash-syspopup.xml
295 %endif
296
297 %if %{system_popup} == on
298 %files -n org.tizen.system-syspopup
299 %manifest org.tizen.system-syspopup.manifest
300 %defattr(-,root,root,-)
301 %{TZ_SYS_RO_APP}/org.tizen.system-syspopup/bin/system-syspopup
302 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-syspopup.xml
303 %endif
304
305 %if %{powerkey_popup} == on
306 %files -n org.tizen.powerkey-syspopup
307 %manifest org.tizen.powerkey-syspopup.manifest
308 %license LICENSE
309 %defattr(-,root,root,-)
310 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/bin/powerkey-popup
311 %{TZ_SYS_RO_SHARE}/packages/org.tizen.powerkey-syspopup.xml
312 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_check.png
313 %{TZ_SYS_RO_APP}/org.tizen.powerkey-syspopup/res/circle_btn_delete.png
314 %endif
315
316 %if %{signal_sender} == on
317 %files -n org.tizen.system-signal-sender
318 %manifest org.tizen.system-signal-sender.manifest
319 %defattr(-,root,root,-)
320 %{TZ_SYS_RO_APP}/org.tizen.system-signal-sender/bin/system-signal-sender
321 %{TZ_SYS_RO_SHARE}/packages/org.tizen.system-signal-sender.xml
322 %endif