Add dependency on vconftool to create initial vconf key
[platform/core/system/system-popup.git] / packaging / system-popup.spec
1 Name:       system-popup
2 Summary:    System Popup application (poweroff popup,sysevent-alert)
3 Version: 0.1.16
4 Release:    2
5 Group:      System/Utilities
6 License:    Apache-2.0
7 Source0:    %{name}-%{version}.tar.bz2
8 Source1001:    %{name}.manifest
9 Source1002:    org.tizen.lowmem-syspopup.manifest
10 Source1003:    org.tizen.lowbat-syspopup.manifest
11 Source1004:    org.tizen.mmc-syspopup.manifest
12 Source1005:    org.tizen.usb-syspopup.manifest
13 Source1006:    org.tizen.usbotg-syspopup.manifest
14 Source1007:    org.tizen.poweroff-syspopup.rule
15 Source1008:    org.tizen.lowmem-syspopup.rule
16 Source1009:    org.tizen.lowbat-syspopup.rule
17 Source1010:    org.tizen.mmc-syspopup.rule
18 Source1011:    org.tizen.usb-syspopup.rule
19 Source1012:    org.tizen.usbotg-syspopup.rule
20 Source1013:    org.tizen.poweroff-syspopup.manifest
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(ecore-input)
23 BuildRequires:  pkgconfig(ethumb)
24 BuildRequires:  pkgconfig(elementary)
25 BuildRequires:  pkgconfig(efreet)
26 BuildRequires:  pkgconfig(sysman)
27 BuildRequires:  pkgconfig(mm-sound)
28 BuildRequires:  pkgconfig(sensor)
29 BuildRequires:  pkgconfig(devman_haptic)
30 BuildRequires:  pkgconfig(appcore-efl)
31 BuildRequires:  pkgconfig(devman)
32 BuildRequires:  pkgconfig(utilX)
33 BuildRequires:  pkgconfig(syspopup)
34 BuildRequires:  pkgconfig(syspopup-caller)
35 BuildRequires:  pkgconfig(notification) 
36 BuildRequires:  pkgconfig(pmapi)
37 BuildRequires:  pkgconfig(appsvc)
38 BuildRequires:  pkgconfig(svi)
39 BuildRequires:  pkgconfig(bundle)
40 BuildRequires:  pkgconfig(vconf)
41 BuildRequires:  pkgconfig(dlog)
42 BuildRequires:  cmake
43 BuildRequires:  edje-bin
44 BuildRequires:  embryo-bin
45 BuildRequires:  gettext-devel
46 Requires(post): /usr/bin/vconftool
47
48 %description
49 System Popup application (poweroff popup,sysevent-alert).
50
51
52 %package -n org.tizen.poweroff-syspopup
53 Summary:    System Popup application (poweroff popup,sysevent-alert)
54 Requires:   %{name} = %{version}-%{release}
55
56 %description -n org.tizen.poweroff-syspopup
57 System Popup application (poweroff popup,sysevent-alert).
58
59 %package -n org.tizen.lowmem-syspopup
60 Summary:    System Popup application (lowbatt popup)
61 Requires:   %{name} = %{version}-%{release}
62
63 %description -n org.tizen.lowmem-syspopup
64 System Popup application (lowbatt popup).
65
66 %package -n org.tizen.lowbat-syspopup
67 Summary:    System Popup application (lowmem  popup)
68 Requires:   %{name} = %{version}-%{release}
69
70 %description -n org.tizen.lowbat-syspopup
71 System Popup application (lowmem  popup).
72
73 %package -n org.tizen.mmc-syspopup
74 Summary:    System Popup application (mmc  popup)
75 Requires:   %{name} = %{version}-%{release}
76
77 %description -n org.tizen.mmc-syspopup
78 System Popup application (mmc  popup).
79
80 %package -n org.tizen.usb-syspopup
81 Summary:    System Popup application (usb popup)
82 Requires:   %{name} = %{version}-%{release}
83
84 %description -n org.tizen.usb-syspopup
85 System Popup application (usb popup).
86
87 %package -n org.tizen.usbotg-syspopup
88 Summary:    System Popup application (usb otg popup)
89 Requires:   %{name} = %{version}-%{release}
90
91 %description -n org.tizen.usbotg-syspopup
92 System Popup application (usb otg popup).
93
94 %prep
95 %setup -q
96
97
98 %build
99 cp %{SOURCE1001} .
100 cp %{SOURCE1002} .
101 cp %{SOURCE1003} .
102 cp %{SOURCE1004} .
103 cp %{SOURCE1005} .
104 cp %{SOURCE1006} .
105 cp %{SOURCE1007} .
106 cp %{SOURCE1008} .
107 cp %{SOURCE1009} .
108 cp %{SOURCE1010} .
109 cp %{SOURCE1011} .
110 cp %{SOURCE1012} .
111 cp %{SOURCE1013} .
112
113 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
114 make %{?jobs:-j%jobs}
115
116 %install
117 rm -rf %{buildroot}
118 %make_install
119
120 %post
121 vconftool set -t int db/setting/select_popup_btn "0" -u 5000 -f
122
123 %files
124 %manifest %{name}.manifest
125 %defattr(-,root,root,-)
126
127
128 %files -n org.tizen.poweroff-syspopup
129 %manifest %{name}.manifest
130 %defattr(-,root,root,-)
131 /usr/apps/org.tizen.poweroff-syspopup/bin/poweroff-popup
132 /usr/apps/org.tizen.poweroff-syspopup/res/edje/poweroff/poweroff.edj
133 /usr/apps/org.tizen.poweroff-syspopup/res/icon/org.tizen.poweroff-syspopup.png
134 /usr/share/packages/org.tizen.poweroff-syspopup.xml
135 /usr/share/process-info/poweroff-popup.ini
136 /usr/apps/org.tizen.poweroff-syspopup/res/locale/*/LC_MESSAGES/*.mo
137 /opt/etc/smack/accesses.d/org.tizen.poweroff-syspopup.rule
138
139 %files -n org.tizen.lowmem-syspopup
140 %manifest %{name}.manifest
141 %defattr(-,root,root,-)
142 /usr/apps/org.tizen.lowmem-syspopup/bin/lowmem-popup
143 /usr/apps/org.tizen.lowmem-syspopup/res/keysound/02_Warning.wav
144 /usr/apps/org.tizen.lowmem-syspopup/res/edje/lowmem/lowmem.edj
145 /usr/apps/org.tizen.lowmem-syspopup/res/icon/org.tizen.lowmem-syspopup.png
146 /usr/share/packages/org.tizen.lowmem-syspopup.xml
147 /usr/share/process-info/lowmem-popup.ini
148 /usr/apps/org.tizen.lowmem-syspopup/res/locale/*/LC_MESSAGES/*.mo
149 /opt/etc/smack/accesses.d/org.tizen.lowmem-syspopup.rule
150
151 %files -n org.tizen.lowbat-syspopup
152 %manifest %{name}.manifest
153 %defattr(-,root,root,-)
154 /usr/apps/org.tizen.lowbat-syspopup/bin/lowbatt-popup
155 /usr/apps/org.tizen.lowbat-syspopup/res/edje/lowbatt/lowbatt.edj
156 /usr/apps/org.tizen.lowbat-syspopup/res/locale/*/LC_MESSAGES/*.mo
157 /usr/apps/org.tizen.lowbat-syspopup/res/icon/org.tizen.lowbat-syspopup.png
158 /usr/share/packages/org.tizen.lowbat-syspopup.xml
159 /usr/share/process-info/lowbatt-popup.ini
160 /opt/etc/smack/accesses.d/org.tizen.lowbat-syspopup.rule
161
162 %files -n org.tizen.mmc-syspopup
163 %manifest %{name}.manifest
164 %defattr(-,root,root,-)
165 /usr/apps/org.tizen.mmc-syspopup/bin/mmc-popup
166 /usr/share/packages/org.tizen.mmc-syspopup.xml
167 /usr/share/process-info/mmc-popup.ini
168 /usr/apps/org.tizen.mmc-syspopup/res/locale/*/LC_MESSAGES/*.mo
169 /opt/etc/smack/accesses.d/org.tizen.mmc-syspopup.rule
170
171 %files -n org.tizen.usb-syspopup
172 %manifest %{name}.manifest
173 %defattr(440,root,root,-)
174 %attr(555,app,app) /usr/apps/org.tizen.usb-syspopup/bin/usb-syspopup
175 %attr(440,app,app) /usr/apps/org.tizen.usb-syspopup/res/locale/*/LC_MESSAGES/usb-syspopup.mo
176 /usr/share/packages/org.tizen.usb-syspopup.xml
177 /opt/etc/smack/accesses.d/org.tizen.usb-syspopup.rule
178
179 %files -n org.tizen.usbotg-syspopup
180 %manifest %{name}.manifest
181 %defattr(440,root,root,-)
182 %attr(555,app,app) /usr/apps/org.tizen.usbotg-syspopup/bin/usbotg-syspopup
183 /usr/share/packages/org.tizen.usbotg-syspopup.xml
184 /opt/etc/smack/accesses.d/org.tizen.usbotg-syspopup.rule