Remove unused conf file
[platform/core/base/syspopup.git] / packaging / syspopup.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           syspopup
5 Summary:        Syspopup package
6 Version:        0.0.100
7 Release:        0
8 Group:          System/Libraries
9 License:        Apache-2.0
10 Source0:        syspopup-%{version}.tar.gz
11 Source1001:     %{name}.manifest
12 Source1002:     %{name}-devel.manifest
13 Source1003:     %{name}-caller.manifest
14 Source1004:     %{name}-caller-devel.manifest
15
16 BuildRequires:  cmake
17 BuildRequires:  pkgconfig(sqlite3)
18 BuildRequires:  pkgconfig(bundle)
19 BuildRequires:  pkgconfig(dlog)
20 BuildRequires:  pkgconfig(glib-2.0)
21 BuildRequires:  pkgconfig(gio-2.0)
22 %if %{with wayland}
23 BuildRequires:  pkgconfig(ecore-wayland)
24 BuildRequires:  pkgconfig(capi-ui-efl-util)
25 %else
26 %if %{with x}
27 BuildRequires:  pkgconfig(utilX)
28 BuildRequires:  pkgconfig(x11)
29 BuildRequires:  pkgconfig(ecore-x)
30 %endif
31 %endif
32 BuildRequires:  pkgconfig(evas)
33 BuildRequires:  pkgconfig(elementary)
34 BuildRequires:  pkgconfig(libtzplatform-config)
35 BuildRequires:  pkgconfig(capi-appfw-application)
36 BuildRequires:  pkgconfig(capi-system-system-settings)
37 BuildRequires:  pkgconfig(libsystemd-daemon)
38 BuildRequires:  pkgconfig(aul)
39
40 %define upgrade_script_path /usr/share/upgrade/scripts
41 %define upgrade_data_path /usr/share/upgrade/data
42
43 %if "%{?profile}" == "wearable"
44 %define profile_wearable 1
45 %else
46 %define profile_wearable 0
47 %endif
48
49 %description
50 syspopup package for popup
51
52 %package devel
53 Summary:    Syspopup development package
54 Group:      System/Libraries
55 Requires:   %{name} = %{version}-%{release}
56
57 %description devel
58 syspopup development package popup
59
60 %package caller
61 Summary:          Syspopup-caller package
62 Group:            System/Libraries
63 Requires:         %{name} = %{version}-%{release}
64 Requires(post):   /sbin/ldconfig
65 Requires(postun): /sbin/ldconfig
66
67 %description caller
68 syspopup-caller package for popup
69
70 %package caller-devel
71 Summary:    Syspopup-caller development package
72 Group:      System/Development
73 Requires:   %{name} = %{version}-%{release}
74
75 %description caller-devel
76 syspopup-caller development package for popup
77
78 %prep
79 %setup -q
80 sed -i %{SOURCE1001} -e "s|TZ_SYS_DB|%TZ_SYS_DB|g"
81 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} .
82
83 %build
84 %if %{?profile_wearable}
85 PROFILE_WEARABLE=ON
86 %endif
87
88 %cmake \
89 %if %{with wayland}
90         -Dwith_wayland=TRUE \
91 %else
92 %if %{with x}
93         -Dwith_x11=TRUE \
94 %endif
95 %endif
96         -DTZ_SYS_RO_PACKAGES=%{TZ_SYS_RO_PACKAGES} \
97         -DTZ_SYS_RO_SHARE=%{TZ_SYS_RO_SHARE} \
98         -DEXTRA_CFLAGS=-fPIC \
99         -DPROFILE_WEARABLE:BOOL=${PROFILE_WEARABLE} \
100         .
101
102 make %{?jobs:-j%jobs}
103
104 %install
105 %make_install
106 mkdir -p %{buildroot}%{TZ_SYS_RO_SHARE}/license
107 install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}
108 install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-devel
109 install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-caller
110 install LICENSE %{buildroot}%{TZ_SYS_RO_SHARE}/license/%{name}-caller-devel
111
112 mkdir -p %{buildroot}%{TZ_SYS_DB}
113 sqlite3 %{buildroot}%{TZ_SYS_DB}/.syspopup.db < %{buildroot}%{TZ_SYS_RO_SHARE}/syspopup/syspopup_db.sql
114 rm -rf %{buildroot}%{TZ_SYS_RO_SHARE}/syspopup/syspopup_db.sql
115 rm -rf %{buildroot}%{TZ_SYS_DB}/.syspopup.db-journal
116
117 touch %{buildroot}%{_datadir}/popup_noti_term
118
119 mkdir -p %{buildroot}%{upgrade_script_path}
120 mkdir -p %{buildroot}%{upgrade_data_path}
121 cp -f scripts/102.syspopup_upgrade.sh %{buildroot}%{upgrade_script_path}
122 cp -f %{buildroot}%{TZ_SYS_DB}/.syspopup.db %{buildroot}%{upgrade_data_path}
123
124 %post -p /sbin/ldconfig
125
126 %postun -p /sbin/ldconfig
127
128 %post caller -p /sbin/ldconfig
129
130 %postun caller -p /sbin/ldconfig
131
132 %files
133 %manifest %{name}.manifest
134 %defattr(-,root,root,-)
135 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
136 %{_bindir}/sp_test
137 %{_bindir}/syspopup-app
138 %{_libdir}/libsyspopup.so.0.1.0
139 %TZ_SYS_RO_PACKAGES/org.tizen.syspopup-app.xml
140 %{_datadir}/popup_noti_term
141 %attr(644,root,%{TZ_SYS_USER_GROUP}) %{TZ_SYS_DB}/.syspopup.db
142 %TZ_SYS_RO_SHARE/license/%{name}
143 %{upgrade_script_path}/102.syspopup_upgrade.sh
144 %{upgrade_data_path}/.syspopup.db
145
146 %files devel
147 %manifest %{name}-devel.manifest
148 %defattr(-,root,root,-)
149 %{_includedir}/SLP_SYSPOPUP_PG.h
150 %{_includedir}/syspopup.h
151 %{_libdir}/libsyspopup.so
152 %{_libdir}/pkgconfig/syspopup.pc
153 %TZ_SYS_RO_SHARE/license/%{name}-devel
154
155 %files caller
156 %manifest %{name}-caller.manifest
157 %defattr(-,root,root,-)
158 %{_libdir}/libsyspopup_caller.so.0.1.0
159 %TZ_SYS_RO_SHARE/license/%{name}-caller
160
161 %files caller-devel
162 %manifest %{name}-caller-devel.manifest
163 %defattr(-,root,root,-)
164 %{_libdir}/libsyspopup_caller.so
165 %{_includedir}/syspopup_caller.h
166 %{_libdir}/pkgconfig/syspopup-caller.pc
167 %TZ_SYS_RO_SHARE/license/%{name}-caller-devel
168
169
170 %changelog
171 * Tue Aug 13 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
172 - Add key handler for esc of keyboard
173
174 * Fri Jun 21 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
175 - Change end key term info of wifi-qs
176
177 * Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
178 - Remove drm syspopup requested by hakjoo.ko
179
180 * Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
181 - Add syspopup_reset_timeout api