apply new active window rotation guide
[platform/core/base/syspopup.git] / packaging / syspopup.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:           syspopup
5 Summary:        Syspopup package
6 Version:        0.0.96
7 Release:        0
8 Group:          System/Libraries
9 License:        Apache-2.0
10 Source0:        syspopup-%{version}.tar.gz
11 Source1001:     %{name}.manifest
12 Source1002:     %{name}-devel.manifest
13 Source1003:     %{name}-caller.manifest
14 Source1004:     %{name}-caller-devel.manifest
15
16 BuildRequires:  cmake
17 BuildRequires:  pkgconfig(sqlite3)
18 BuildRequires:  pkgconfig(bundle)
19 BuildRequires:  pkgconfig(dlog)
20 BuildRequires:  pkgconfig(dbus-glib-1)
21 %if %{with x}
22 BuildRequires:  pkgconfig(utilX)
23 BuildRequires:  pkgconfig(x11)
24 BuildRequires:  pkgconfig(ecore-x)
25 %endif
26 BuildRequires:  pkgconfig(aul)
27 BuildRequires:  pkgconfig(evas)
28 BuildRequires:  pkgconfig(appcore-efl)
29 BuildRequires:  pkgconfig(libtzplatform-config)
30
31 %description
32 syspopup package for popup
33
34
35 %package devel
36 Summary:    Syspopup development package
37 Group:      System/Libraries
38 Requires:   %{name} = %{version}-%{release}
39
40 %description devel
41 syspopup development package popup
42
43 %package caller
44 Summary:          Syspopup-caller package
45 Group:            System/Libraries
46 Requires:         %{name} = %{version}-%{release}
47 Requires(post):   /sbin/ldconfig
48 Requires(postun): /sbin/ldconfig
49
50 %description caller
51 syspopup-caller package for popup
52
53 %package caller-devel
54 Summary:    Syspopup-caller development package
55 Group:      System/Development
56 Requires:   %{name} = %{version}-%{release}
57
58 %description caller-devel
59 syspopup-caller development package for popup
60
61
62 %prep
63 %setup -q
64 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} .
65
66 %build
67 %cmake . \
68 %if %{with wayland} && !%{with x}
69 -Dwith_wayland=TRUE \
70 %endif
71 -DEXTRA_CFLAGS=-fPIC
72
73 make %{?jobs:-j%jobs}
74
75 %install
76 %make_install
77
78 mkdir -p %{buildroot}%{TZ_SYS_DB}
79 sqlite3 %{buildroot}%{TZ_SYS_DB}/.syspopup.db < %{buildroot}/usr/share/syspopup/syspopup_db.sql
80 rm -rf %{buildroot}/usr/share/syspopup/syspopup_db.sql
81
82 touch %{buildroot}%{_datadir}/popup_noti_term
83
84 %post -p /sbin/ldconfig
85
86 %postun -p /sbin/ldconfig
87
88 %post caller -p /sbin/ldconfig
89
90 %postun caller -p /sbin/ldconfig
91
92 %files
93 %manifest %{name}.manifest
94 %defattr(-,root,root,-)
95 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
96 %{_bindir}/sp_test
97 %{_bindir}/syspopup-app
98 %{_libdir}/libsyspopup.so.0.1.0
99 %TZ_SYS_RO_PACKAGES/org.tizen.syspopup-app.xml
100 %{_datadir}/popup_noti_term
101
102 %attr(644,root,%{TZ_SYS_USER_GROUP}) %{TZ_SYS_DB}/.syspopup.db
103 %attr(644,root,%{TZ_SYS_USER_GROUP}) %{TZ_SYS_DB}/.syspopup.db-journal
104
105
106 %files devel
107 %manifest %{name}-devel.manifest
108 %defattr(-,root,root,-)
109 %{_includedir}/SLP_SYSPOPUP_PG.h
110 %{_includedir}/syspopup.h
111 %{_libdir}/libsyspopup.so
112 %{_libdir}/pkgconfig/syspopup.pc
113
114 %files caller
115 %manifest %{name}-caller.manifest
116 %defattr(-,root,root,-)
117 %{_libdir}/libsyspopup_caller.so.0.1.0
118
119 %files caller-devel
120 %manifest %{name}-caller-devel.manifest
121 %defattr(-,root,root,-)
122 %{_libdir}/libsyspopup_caller.so
123 %{_includedir}/syspopup_caller.h
124 %{_libdir}/pkgconfig/syspopup-caller.pc
125
126 %changelog
127 * Fri Jun 21 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
128 - Change end key term info of wifi-qs
129
130 * Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
131 - Remove drm syspopup requested by hakjoo.ko
132
133 * Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
134 - Add syspopup_reset_timeout api