change focus info of system server syspopup
[framework/base/syspopup.git] / packaging / syspopup.spec
1 Name:       syspopup
2 Summary:    syspopup package
3 Version:    0.0.97
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    syspopup-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(sqlite3)
10 BuildRequires:  pkgconfig(bundle)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(utilX)
13 BuildRequires:  pkgconfig(dbus-glib-1)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(evas)
17 BuildRequires:  pkgconfig(appcore-efl)
18
19
20 %description
21 syspopup package for popup
22
23
24 %package devel
25 Summary:    syspopup development package
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 syspopup development package popup
31
32 %package caller
33 Summary:    syspopup-caller package
34 Group:      TO_BE/FILLED_IN
35 Requires:   %{name} = %{version}-%{release}
36 Requires(post): /sbin/ldconfig
37 Requires(postun): /sbin/ldconfig
38
39 %description caller
40 syspopup-caller package for popup
41
42 %package caller-devel
43 Summary:    syspopup-caller development package
44 Group:      TO_BE/FILLED_IN
45 Requires:   %{name} = %{version}-%{release}
46
47 %description caller-devel
48 syspopup-caller development package for popup
49
50 %package app
51 Summary:    org.tizen.syspopup-app test app
52 Group:      TO_BE/FILLED_IN
53 Requires:   %{name} = %{version}-%{release}
54
55 %description app
56 org.tizen.syspopup-app test app package
57
58 %prep
59 %setup -q
60
61 %build
62 %cmake . -DEXTRA_CFLAGS=-fPIC
63
64 make %{?jobs:-j%jobs}
65
66 %install
67 %make_install
68
69 mkdir -p %{buildroot}/opt/dbspace
70 sqlite3 %{buildroot}/opt/dbspace/.syspopup.db < %{buildroot}/usr/share/syspopup/syspopup_db.sql
71 rm -rf %{buildroot}/usr/share/syspopup/syspopup_db.sql
72
73 touch %{buildroot}%{_datadir}/popup_noti_term
74
75 %post -p /sbin/ldconfig
76
77 %postun -p /sbin/ldconfig
78
79 %post caller -p /sbin/ldconfig
80
81 %postun caller -p /sbin/ldconfig
82
83 %files
84 %manifest syspopup.manifest
85 %defattr(-,root,root,-)
86 %{_libdir}/libsyspopup.so.0.1.0
87 %{_datadir}/popup_noti_term
88 %attr(644,root,app) /opt/dbspace/.syspopup.db
89 %attr(644,root,app) /opt/dbspace/.syspopup.db-journal
90 %{_bindir}/sp_test
91
92 %files devel
93 %defattr(-,root,root,-)
94 %{_includedir}/SLP_SYSPOPUP_PG.h
95 %{_includedir}/syspopup.h
96 %{_libdir}/libsyspopup.so
97 %{_libdir}/pkgconfig/syspopup.pc
98
99 %files caller
100 %manifest syspopup-caller.manifest
101 %defattr(-,root,root,-)
102 %{_libdir}/libsyspopup_caller.so.0.1.0
103
104 %files caller-devel
105 %defattr(-,root,root,-)
106 %{_libdir}/libsyspopup_caller.so
107 %{_includedir}/syspopup_caller.h
108 %{_libdir}/pkgconfig/syspopup-caller.pc
109
110 %files app
111 %manifest org.tizen.syspopup-app.manifest
112 %defattr(-,root,root,-)
113 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
114 %{_bindir}/syspopup-app
115 /usr/share/packages/org.tizen.syspopup-app.xml
116
117 %changelog
118 * Fri Jun 21 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
119 - Change end key term info of wifi-qs
120
121 * Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
122 - Remove drm syspopup requested by hakjoo.ko
123
124 * Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
125 - Add syspopup_reset_timeout api