Upload Tizen2.0 source
[framework/base/syspopup.git] / packaging / syspopup.spec
1
2 Name:       syspopup
3 Summary:    syspopup package
4 Version:    0.0.80
5 Release:    1
6 Group:      System/Libraries
7 License:    Apache License, Version 2.0
8 Source0:    syspopup-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(post): /bin/touch
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(sqlite3)
14 BuildRequires:  pkgconfig(bundle)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(utilX)
17 BuildRequires:  pkgconfig(dbus-glib-1)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(aul)
20 BuildRequires:  pkgconfig(evas)
21 BuildRequires:  pkgconfig(appcore-efl)
22
23
24 %description
25 syspopup package for popup
26
27
28 %package devel
29 Summary:    syspopup development package
30 Group:      Development/Libraries
31 Requires:   %{name} = %{version}-%{release}
32
33 %description devel
34 syspopup development package popup
35
36 %package caller
37 Summary:    syspopup-caller package
38 Group:      TO_BE/FILLED_IN
39 Requires:   %{name} = %{version}-%{release}
40 Requires(post): /sbin/ldconfig
41 Requires(postun): /sbin/ldconfig
42
43 %description caller
44 syspopup-caller package for popup
45
46 %package caller-devel
47 Summary:    syspopup-caller development package
48 Group:      TO_BE/FILLED_IN
49 Requires:   %{name} = %{version}-%{release}
50
51 %description caller-devel
52 syspopup-caller development package for popup
53
54
55 %prep
56 %setup -q -n %{name}-%{version}
57
58 CFLAGS=${_cflags} cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DEXTRA_CFLAGS=-fPIC
59
60 %build
61
62
63 make %{?jobs:-j%jobs}
64
65 %install
66 rm -rf %{buildroot}
67 %make_install
68
69 mkdir -p %{buildroot}/opt/dbspace
70 #sqlite3 $(CURDIR)/debian/tmp/opt/dbspace/.syspopup.db < $(CURDIR)/data/syspopup_db.sql
71 touch %{buildroot}%{_datadir}/popup_noti_term
72
73
74
75 %post
76 /sbin/ldconfig
77
78 mkdir -p /opt/dbspace/
79 sqlite3 /opt/dbspace/.syspopup.db < /usr/share/syspopup/syspopup_db.sql
80
81 %postun -p /sbin/ldconfig
82
83
84
85
86 %post caller -p /sbin/ldconfig
87
88 %postun caller -p /sbin/ldconfig
89
90
91
92
93 %files
94 %defattr(-,root,root,-)
95 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
96 %{_bindir}/sp_test
97 %{_bindir}/syspopup-app
98 %{_libdir}/libsyspopup.so.0.1.0
99 /usr/share/syspopup/syspopup_db.sql
100 /usr/share/packages/org.tizen.syspopup-app.xml
101 %{_datadir}/popup_noti_term
102
103
104 %files devel
105 %defattr(-,root,root,-)
106 %{_includedir}/SLP_SYSPOPUP_PG.h
107 %{_includedir}/syspopup.h
108 %{_libdir}/libsyspopup.so
109 %{_libdir}/pkgconfig/syspopup.pc
110
111 %files caller
112 %defattr(-,root,root,-)
113 %{_libdir}/libsyspopup_caller.so.0.1.0
114
115 %files caller-devel
116 %defattr(-,root,root,-)
117 %{_libdir}/libsyspopup_caller.so
118 %{_includedir}/syspopup_caller.h
119 %{_libdir}/pkgconfig/syspopup-caller.pc
120