remove drm syspopup
[framework/base/syspopup.git] / packaging / syspopup.spec
1 Name:       syspopup
2 Summary:    syspopup package
3 Version:    0.0.92
4 Release:    1
5 Group:      System/Libraries
6 License:    Apache License, Version 2.0
7 Source0:    syspopup-%{version}.tar.gz
8 BuildRequires:  cmake
9 BuildRequires:  pkgconfig(sqlite3)
10 BuildRequires:  pkgconfig(bundle)
11 BuildRequires:  pkgconfig(dlog)
12 BuildRequires:  pkgconfig(utilX)
13 BuildRequires:  pkgconfig(dbus-glib-1)
14 BuildRequires:  pkgconfig(x11)
15 BuildRequires:  pkgconfig(aul)
16 BuildRequires:  pkgconfig(evas)
17 BuildRequires:  pkgconfig(appcore-efl)
18
19
20 %description
21 syspopup package for popup
22
23
24 %package devel
25 Summary:    syspopup development package
26 Group:      Development/Libraries
27 Requires:   %{name} = %{version}-%{release}
28
29 %description devel
30 syspopup development package popup
31
32 %package caller
33 Summary:    syspopup-caller package
34 Group:      TO_BE/FILLED_IN
35 Requires:   %{name} = %{version}-%{release}
36 Requires(post): /sbin/ldconfig
37 Requires(postun): /sbin/ldconfig
38
39 %description caller
40 syspopup-caller package for popup
41
42 %package caller-devel
43 Summary:    syspopup-caller development package
44 Group:      TO_BE/FILLED_IN
45 Requires:   %{name} = %{version}-%{release}
46
47 %description caller-devel
48 syspopup-caller development package for popup
49
50
51 %prep
52 %setup -q
53
54 %build
55 %cmake . -DEXTRA_CFLAGS=-fPIC
56
57 make %{?jobs:-j%jobs}
58
59 %install
60 %make_install
61
62 mkdir -p %{buildroot}/opt/dbspace
63 sqlite3 %{buildroot}/opt/dbspace/.syspopup.db < %{buildroot}/usr/share/syspopup/syspopup_db.sql
64 rm -rf %{buildroot}/usr/share/syspopup/syspopup_db.sql
65
66 touch %{buildroot}%{_datadir}/popup_noti_term
67
68 %post -p /sbin/ldconfig
69
70 %postun -p /sbin/ldconfig
71
72 %post caller -p /sbin/ldconfig
73
74 %postun caller -p /sbin/ldconfig
75
76 %files
77 %manifest syspopup.manifest
78 %defattr(-,root,root,-)
79 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
80 %{_bindir}/sp_test
81 %{_bindir}/syspopup-app
82 %{_libdir}/libsyspopup.so.0.1.0
83 /usr/share/packages/org.tizen.syspopup-app.xml
84 %{_datadir}/popup_noti_term
85
86 %attr(644,root,app) /opt/dbspace/.syspopup.db
87 %attr(644,root,app) /opt/dbspace/.syspopup.db-journal
88
89
90 %files devel
91 %defattr(-,root,root,-)
92 %{_includedir}/SLP_SYSPOPUP_PG.h
93 %{_includedir}/syspopup.h
94 %{_libdir}/libsyspopup.so
95 %{_libdir}/pkgconfig/syspopup.pc
96
97 %files caller
98 %manifest syspopup-caller.manifest
99 %defattr(-,root,root,-)
100 %{_libdir}/libsyspopup_caller.so.0.1.0
101
102 %files caller-devel
103 %defattr(-,root,root,-)
104 %{_libdir}/libsyspopup_caller.so
105 %{_includedir}/syspopup_caller.h
106 %{_libdir}/pkgconfig/syspopup-caller.pc
107
108 %changelog
109 * Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
110 - Remove drm syspopup requested by hakjoo.ko
111
112 * Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
113 - Add syspopup_reset_timeout api