tizen beta release
[framework/base/syspopup.git] / packaging / syspopup.spec
1
2 Name:       syspopup
3 Summary:    syspopup package
4 Version:    0.0.58
5 Release:    1
6 Group:      TO_BE/FILLED_IN
7 License:    TO_BE/FILLED_IN
8 Source0:    syspopup-%{version}.tar.gz
9 Requires(post): /sbin/ldconfig
10 Requires(post): /bin/touch
11 Requires(postun): /sbin/ldconfig
12 BuildRequires:  cmake
13 BuildRequires:  pkgconfig(sqlite3)
14 BuildRequires:  pkgconfig(bundle)
15 BuildRequires:  pkgconfig(dlog)
16 BuildRequires:  pkgconfig(utilX)
17 BuildRequires:  pkgconfig(dbus-glib-1)
18 BuildRequires:  pkgconfig(x11)
19 BuildRequires:  pkgconfig(heynoti)
20 BuildRequires:  pkgconfig(aul)
21 BuildRequires:  pkgconfig(evas)
22 BuildRequires:  pkgconfig(quickpanel)
23 BuildRequires:  pkgconfig(appcore-efl)
24
25
26 %description
27 syspopup package for popup
28
29
30 %package devel
31 Summary:    syspopup development package
32 Group:      Development/Libraries
33 Requires:   %{name} = %{version}-%{release}
34
35 %description devel
36 syspopup development package popup
37
38 %package caller
39 Summary:    syspopup-caller package
40 Group:      TO_BE/FILLED_IN
41 Requires:   %{name} = %{version}-%{release}
42 Requires(post): /sbin/ldconfig
43 Requires(postun): /sbin/ldconfig
44
45 %description caller
46 syspopup-caller package for popup
47
48 %package caller-devel
49 Summary:    syspopup-caller development package
50 Group:      TO_BE/FILLED_IN
51 Requires:   %{name} = %{version}-%{release}
52
53 %description caller-devel
54 syspopup-caller development package for popup
55
56
57 %prep
58 %setup -q -n %{name}-%{version}
59
60 CFLAGS=${_cflags} cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DEXTRA_CFLAGS=-fPIC
61
62 %build
63
64
65 make %{?jobs:-j%jobs}
66
67 %install
68 rm -rf %{buildroot}
69 %make_install
70
71 mkdir -p %{buildroot}/opt/dbspace
72 #sqlite3 $(CURDIR)/debian/tmp/opt/dbspace/.syspopup.db < $(CURDIR)/data/syspopup_db.sql
73 touch %{buildroot}%{_datadir}/popup_noti_term
74
75
76
77 %post
78 /sbin/ldconfig
79
80 mkdir -p /opt/dbspace/
81 sqlite3 /opt/dbspace/.syspopup.db < /opt/share/syspopup_db.sql
82 rm -rf /opt/share/syspopup_db.sql
83
84 %postun -p /sbin/ldconfig
85
86
87
88
89 %post caller -p /sbin/ldconfig
90
91 %postun caller -p /sbin/ldconfig
92
93
94
95
96 %files
97 %defattr(-,root,root,-)
98 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
99 %{_bindir}/sp_test
100 %{_bindir}/syspopup-app
101 %{_libdir}/libsyspopup.so.0.1.0
102 /opt/share/syspopup_db.sql
103 /opt/share/applications/org.tizen.syspopup-app.desktop
104 %{_datadir}/popup_noti_term
105
106
107 %files devel
108 %defattr(-,root,root,-)
109 %{_includedir}/SLP_SYSPOPUP_PG.h
110 %{_includedir}/syspopup.h
111 %{_libdir}/libsyspopup.so
112 %{_libdir}/pkgconfig/syspopup.pc
113
114 %files caller
115 %defattr(-,root,root,-)
116 %{_libdir}/libsyspopup_caller.so.0.1.0
117
118 %files caller-devel
119 %defattr(-,root,root,-)
120 %{_libdir}/libsyspopup_caller.so
121 %{_includedir}/syspopup_caller.h
122 %{_libdir}/pkgconfig/syspopup-caller.pc
123