024ac689730efd9c7f0eaa1f332de394036215cb
[platform/core/base/syspopup.git] / packaging / syspopup.spec
1 %bcond_with x
2 %bcond_with wayland
3
4 Name:       syspopup
5 Summary:    syspopup package
6 Version:    0.0.92
7 Release:    1
8 Group:      System/Libraries
9 License:    Apache-2.0
10 Source0:    syspopup-%{version}.tar.gz
11 Source1001:     %{name}.manifest
12 Source1002:     %{name}-devel.manifest
13 Source1003:     %{name}-caller.manifest
14 Source1004:     %{name}-caller-devel.manifest
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig(sqlite3)
17 BuildRequires:  pkgconfig(bundle)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(dbus-glib-1)
20 %if %{with x}
21 BuildRequires:  pkgconfig(utilX)
22 BuildRequires:  pkgconfig(x11)
23 BuildRequires:  pkgconfig(ecore-x)
24 %endif
25 BuildRequires:  pkgconfig(aul)
26 BuildRequires:  pkgconfig(evas)
27 BuildRequires:  pkgconfig(appcore-efl)
28
29 %description
30 syspopup package for popup
31
32
33 %package devel
34 Summary:    syspopup development package
35 Group:      System/Libraries
36 Requires:   %{name} = %{version}-%{release}
37
38 %description devel
39 syspopup development package popup
40
41 %package caller
42 Summary:    syspopup-caller package
43 Group:      System/Libraries
44 Requires:   %{name} = %{version}-%{release}
45 Requires(post): /sbin/ldconfig
46 Requires(postun): /sbin/ldconfig
47
48 %description caller
49 syspopup-caller package for popup
50
51 %package caller-devel
52 Summary:    syspopup-caller development package
53 Group:      System/Development
54 Requires:   %{name} = %{version}-%{release}
55
56 %description caller-devel
57 syspopup-caller development package for popup
58
59
60 %prep
61 %setup -q
62 cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} %{SOURCE1004} .
63
64 %build
65 %cmake . \
66 %if %{with wayland} && !%{with x}
67 -Dwith_wayland=TRUE\
68 %endif
69 -DEXTRA_CFLAGS=-fPIC
70
71 make %{?jobs:-j%jobs}
72
73 %install
74 %make_install
75
76 mkdir -p %{buildroot}/opt/dbspace
77 sqlite3 %{buildroot}/opt/dbspace/.syspopup.db < %{buildroot}/usr/share/syspopup/syspopup_db.sql
78 rm -rf %{buildroot}/usr/share/syspopup/syspopup_db.sql
79
80 touch %{buildroot}%{_datadir}/popup_noti_term
81
82 %post -p /sbin/ldconfig
83
84 %postun -p /sbin/ldconfig
85
86 %post caller -p /sbin/ldconfig
87
88 %postun caller -p /sbin/ldconfig
89
90 %files
91 %manifest %{name}.manifest
92 %defattr(-,root,root,-)
93 %{_datadir}/icons/default/small/org.tizen.syspopup-app.png
94 %{_bindir}/sp_test
95 %{_bindir}/syspopup-app
96 %{_libdir}/libsyspopup.so.0.1.0
97 /usr/share/packages/org.tizen.syspopup-app.xml
98 %{_datadir}/popup_noti_term
99
100 %attr(644,root,app) /opt/dbspace/.syspopup.db
101 %attr(644,root,app) /opt/dbspace/.syspopup.db-journal
102
103
104 %files devel
105 %manifest %{name}-devel.manifest
106 %defattr(-,root,root,-)
107 %{_includedir}/SLP_SYSPOPUP_PG.h
108 %{_includedir}/syspopup.h
109 %{_libdir}/libsyspopup.so
110 %{_libdir}/pkgconfig/syspopup.pc
111
112 %files caller
113 %manifest %{name}-caller.manifest
114 %defattr(-,root,root,-)
115 %{_libdir}/libsyspopup_caller.so.0.1.0
116
117 %files caller-devel
118 %manifest %{name}-caller-devel.manifest
119 %defattr(-,root,root,-)
120 %{_libdir}/libsyspopup_caller.so
121 %{_includedir}/syspopup_caller.h
122 %{_libdir}/pkgconfig/syspopup-caller.pc
123
124 %changelog
125 * Fri Apr 12 2013 - Hyungdeuk Kim <hd3.kim@samsung.com>
126 - Remove drm syspopup requested by hakjoo.ko
127
128 * Tue Apr 2 2013 - Hyugdeuk Kim <hd3.kim@samsung.com>
129 - Add syspopup_reset_timeout api