[mobile] Remove password lockscreen
[apps/native/starter.git] / packaging / starter.spec
1 %bcond_with wayland
2 %define __usrdir /usr/lib/systemd/user
3
4 Name:       starter
5 Summary:    starter
6 Version: 0.5.52
7 Release:    1
8 Group:      TO_BE/FILLED_IN
9 License:    Apache-2.0
10 Source0:    starter-%{version}.tar.gz
11 Source1:    starter.service
12 Source2:    starter.path
13 Source3:    starter-pre.service
14 Source4:    starter-pre.path
15
16 %if "%{profile}" == "tv"
17 ExcludeArch: %{arm} %ix86 x86_64
18 %endif
19
20 BuildRequires:  cmake
21 BuildRequires:  pkgconfig(appcore-efl)
22 BuildRequires:  pkgconfig(aul)
23 BuildRequires:  pkgconfig(capi-appfw-application)
24 BuildRequires:  pkgconfig(capi-appfw-app-manager)
25 BuildRequires:  pkgconfig(capi-system-media-key)
26 BuildRequires:  pkgconfig(capi-network-bluetooth)
27 BuildRequires:  pkgconfig(capi-system-system-settings)
28
29 %if "%{profile}" == "common"
30 BuildRequires:  tts
31 BuildRequires:  tts-devel
32 BuildRequires:  pkgconfig(capi-message-port)
33 BuildRequires:  pkgconfig(efl-extension)
34 %else if "%{profile}" == "mobile"
35 BuildRequires:  tts
36 BuildRequires:  tts-devel
37 BuildRequires:  pkgconfig(capi-message-port)
38 BuildRequires:  pkgconfig(efl-extension)
39 %else if "%{profile}" == "ivi"
40 BuildRequires:  tts
41 BuildRequires:  tts-devel
42 BuildRequires:  pkgconfig(capi-message-port)
43 BuildRequires:  pkgconfig(efl-extension)
44 %endif
45
46 BuildRequires:  pkgconfig(feedback)
47 BuildRequires:  pkgconfig(db-util)
48 BuildRequires:  pkgconfig(dlog)
49 BuildRequires:  pkgconfig(ecore)
50 BuildRequires:  pkgconfig(ecore-wayland)
51 BuildRequires:  pkgconfig(edje)
52 BuildRequires:  pkgconfig(edbus)
53 BuildRequires:  pkgconfig(eina)
54 BuildRequires:  pkgconfig(elementary)
55 BuildRequires:  pkgconfig(evas)
56 BuildRequires:  pkgconfig(glib-2.0)
57 BuildRequires:  pkgconfig(syspopup-caller)
58 BuildRequires:  pkgconfig(ui-gadget-1)
59 BuildRequires:  pkgconfig(vconf)
60 BuildRequires:  pkgconfig(alarm-service)
61 BuildRequires:  pkgconfig(pkgmgr-info)
62 BuildRequires:  pkgconfig(deviced)
63 BuildRequires:  pkgconfig(edbus)
64 BuildRequires:  pkgconfig(dbus-1)
65 BuildRequires:  pkgconfig(dbus-glib-1)
66 BuildRequires:  cmake
67 BuildRequires:  edje-bin
68 BuildRequires:  gettext
69 BuildRequires:  gettext-tools
70 Requires(post): /usr/bin/vconftool
71
72 %if !%{with wayland}
73 BuildRequires:  pkgconfig(utilX)
74 %endif
75
76 %description
77 Description: Starter
78
79
80 %prep
81 %setup -q
82
83 %build
84 %if 0%{?sec_build_binary_debug_enable}
85 export CFLAGS="$CFLAGS -DTIZEN_DEBUG_ENABLE"
86 export CXXFLAGS="$CXXFLAGS -DTIZEN_DEBUG_ENABLE"
87 export FFLAGS="$FFLAGS -DTIZEN_DEBUG_ENABLE"
88 %endif
89
90 %if "%{profile}" == "common"
91 %define TIZEN_PROFILE_NAME "COMMON"
92 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_COMMON"
93 export CXXFLAGS="$CXXFLAGS -DTIZEN_PROFILE_COMMON"
94 %endif
95
96 %if "%{profile}" == "mobile"
97 %define TIZEN_PROFILE_NAME "MOBILE"
98 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_MOBILE"
99 export CXXFLAGS="$CXXFLAGS -DTIZEN_PROFILE_MOBILE"
100 %endif
101
102 %if "%{profile}" == "wearable"
103 %define TIZEN_PROFILE_NAME "WEARABLE"
104 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_WEARABLE"
105 export CXXFLAGS="$CXXFLAGS -DTIZEN_PROFILE_WEARABLE"
106 %endif
107
108 %if "%{profile}" == "ivi"
109 %define TIZEN_PROFILE_NAME "IVI"
110 export CFLAGS="$CFLAGS -DTIZEN_PROFILE_IVI"
111 export CXXFLAGS="$CXXFLAGS -DTIZEN_PROFILE_IVI"
112 %endif
113
114 %ifarch %{arm}
115 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET"
116 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET"
117 %else
118 export CFLAGS="$CFLAGS -DTIZEN_BUILD_EMULATOR"
119 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_EMULATOR"
120 %endif
121
122 %ifarch aarch64
123 export CFLAGS="$CFLAGS -DTIZEN_BUILD_TARGET_64"
124 export CXXFLAGS="$CXXFLAGS -DTIZEN_BUILD_TARGET_64"
125 %endif
126
127 %if %{with wayland}
128 export WAYLAND_SUPPORT=On
129 export X11_SUPPORT=Off
130 %else
131 export WAYLAND_SUPPORT=Off
132 export X11_SUPPORT=On
133 %endif
134
135 cmake . -DTIZEN_PROFILE_NAME=%{TIZEN_PROFILE_NAME} -DCMAKE_INSTALL_PREFIX=%{_prefix} -DWAYLAND_SUPPORT=${WAYLAND_SUPPORT} -DX11_SUPPORT=${X11_SUPPORT}
136
137 make
138 make -j1
139 %install
140 rm -rf %{buildroot}
141 %make_install
142
143 mkdir -p %{buildroot}%{__usrdir}/default.target.wants
144 mkdir -p %{buildroot}%{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
145
146 install -m 0644 %SOURCE1 %{buildroot}%{__usrdir}/starter.service
147 ln -s ../starter.service %{buildroot}%{__usrdir}/default.target.wants/starter.service
148
149 install -m 0644 %SOURCE2 %{buildroot}%{__usrdir}/starter.path
150 ln -s ../starter.path %{buildroot}%{__usrdir}/default.target.wants/starter.path
151
152 install -m 0644 %SOURCE3 %{buildroot}%{__usrdir}/starter-pre.service
153 ln -s ../starter-pre.service %{buildroot}%{__usrdir}/default.target.wants/starter-pre.service
154
155 install -m 0644 %SOURCE4 %{buildroot}%{__usrdir}/starter-pre.path
156 ln -s ../starter-pre.path %{buildroot}%{__usrdir}/default.target.wants/starter-pre.path
157
158 mkdir -p %{buildroot}/usr/share/license
159 cp -f LICENSE %{buildroot}/usr/share/license/%{name}
160 mkdir -p %{buildroot}/opt/data/home-daemon
161
162 %post
163 change_file_executable()
164 {
165     chmod +x $@ 2>/dev/null
166     if [ $? -ne 0 ]; then
167         echo "Failed to change the perms of $@"
168     fi
169 }
170
171 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
172
173 #ln -sf /etc/init.d/rd4starter /etc/rc.d/rc4.d/S81starter
174 #ln -sf /etc/init.d/rd4starter /etc/rc.d/rc3.d/S81starter
175
176 sync
177
178 %files
179 %manifest starter.manifest
180 %defattr(-,root,root,-)
181 %{_sysconfdir}/init.d/rd4starter
182 %{_sysconfdir}/init.d/rd3starter
183 %{_bindir}/starter
184 %{__usrdir}/starter.service
185 %{__usrdir}/starter.path
186 %{__usrdir}/starter-pre.service
187 %{__usrdir}/starter-pre.path
188 %{__usrdir}/default.target.wants/starter.service
189 %{__usrdir}/default.target.wants/starter.path
190 %{__usrdir}/default.target.wants/starter-pre.service
191 %{__usrdir}/default.target.wants/starter-pre.path
192 /usr/share/license/%{name}
193 /opt/data/home-daemon
194 /usr/share/locale/*/LC_MESSAGES/*