update manifest file.
[apps/home/starter.git] / packaging / starter.spec
1 Name:       starter
2 Summary:    starter
3 Version: 0.4.54
4 Release:    1
5 Group:      TO_BE/FILLED_IN
6 License:    TO_BE/FILLED_IN
7 Source0:    starter-%{version}.tar.gz
8 Source1:    starter.service
9 Source2:    starter.path
10 Requires(post): /usr/bin/vconftool
11 BuildRequires:  cmake
12 BuildRequires:  pkgconfig(ail)
13 BuildRequires:  pkgconfig(appcore-efl)
14 BuildRequires:  pkgconfig(aul)
15 BuildRequires:  pkgconfig(capi-appfw-application)
16 BuildRequires:  pkgconfig(capi-system-media-key)
17 BuildRequires:  pkgconfig(db-util)
18 BuildRequires:  pkgconfig(dlog)
19 BuildRequires:  pkgconfig(ecore)
20 BuildRequires:  pkgconfig(edje)
21 BuildRequires:  pkgconfig(eet)
22 BuildRequires:  pkgconfig(eina)
23 BuildRequires:  pkgconfig(elementary)
24 BuildRequires:  pkgconfig(evas)
25 BuildRequires:  pkgconfig(glib-2.0)
26 BuildRequires:  pkgconfig(heynoti)
27 BuildRequires:  pkgconfig(sysman)
28 BuildRequires:  pkgconfig(syspopup-caller)
29 BuildRequires:  pkgconfig(tapi)
30 BuildRequires:  pkgconfig(ui-gadget-1)
31 BuildRequires:  pkgconfig(utilX)
32 BuildRequires:  pkgconfig(vconf)
33 BuildRequires:  pkgconfig(x11)
34 BuildRequires:  pkgconfig(xcomposite)
35 BuildRequires:  pkgconfig(xext)
36 BuildRequires:  cmake
37 BuildRequires:  edje-bin
38 BuildRequires: gettext-tools
39
40 Requires(post): /usr/bin/vconftool
41
42 %description
43 Description: Starter
44
45
46 %prep
47 %setup -q
48
49 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
50
51 %build
52
53 make -j1
54 %install
55 rm -rf %{buildroot}
56 %make_install
57
58 mkdir -p %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants
59 install -m 0644 %SOURCE1 %{buildroot}%{_libdir}/systemd/user/
60 install -m 0644 %SOURCE2 %{buildroot}%{_libdir}/systemd/user/
61 ln -s ../starter.path %{buildroot}%{_libdir}/systemd/user/core-efl.target.wants/starter.path
62 mkdir -p %{buildroot}/usr/share/license
63 cp -f LICENSE.Flora %{buildroot}/usr/share/license/%{name}
64 mkdir -p %{buildroot}/opt/data/home-daemon
65
66 %post
67 change_file_executable()
68 {
69     chmod +x $@ 2>/dev/null
70     if [ $? -ne 0 ]; then
71         echo "Failed to change the perms of $@"
72     fi
73 }
74
75 GOPTION="-u 5000 -f"
76
77 vconftool set -t int "memory/starter/sequence" 0 -i $GOPTION
78 vconftool set -t int "memory/starter/use_volume_key" 0 -i $GOPTION
79 vconftool set -t string file/private/lockscreen/pkgname "org.tizen.lockscreen" -u 5000 -g 5000 -f
80 vconftool set -t int memory/idle_lock/state "0" -i $GOPTION
81 vconftool set -t bool memory/lockscreen/phone_lock_verification 0 -i $GOPTION
82
83 vconftool set -t bool db/lockscreen/event_notification_display 1 $GOPTION
84 vconftool set -t bool db/lockscreen/clock_display 1 $GOPTION
85 vconftool set -t bool db/lockscreen/help_text_display 0 $GOPTION
86
87 vconftool set -t string memory/menuscreen/desktop "0" -i -f
88 vconftool set -t int memory/idle-screen/is_idle_screen_launched "0" -i -u 5000 -f
89 vconftool set -t int memory/idle-screen/top "0" -i -f
90 vconftool set -t int memory/idle-screen/safemode "0" -i -f
91
92 ln -sf /etc/init.d/rd4starter /etc/rc.d/rc4.d/S81starter
93 ln -sf /etc/init.d/rd3starter /etc/rc.d/rc3.d/S43starter
94
95
96 %files
97 %manifest starter.manifest
98 %defattr(-,root,root,-)
99 %{_sysconfdir}/init.d/rd4starter
100 %{_sysconfdir}/init.d/rd3starter
101 %{_bindir}/starter
102 /usr/ug/lib/libug-lockscreen-options.so
103 /usr/ug/lib/libug-lockscreen-options.so.0.1.0
104 /usr/ug/res/locale/*/LC_MESSAGES/*
105 %{_libdir}/systemd/user/starter.path
106 %{_libdir}/systemd/user/starter.service
107 %{_libdir}/systemd/user/core-efl.target.wants/starter.path
108 /usr/share/license/%{name}
109 /opt/data/home-daemon