Feature: write summary with negative cases
[platform/upstream/SSAT.git] / packaging / ssat.spec
1 Name:           ssat
2 Summary:        Shell Script Automated Tester
3 Version:        1.1.0
4 Release:        1rc1
5 Group:          Development/Tools
6 Packager:       MyungJoo Ham <myungjoo.ham@samsung.com>
7 License:        Apache-2.0
8 Source0:        ssat-%{version}.tar.gz
9 Source1001:     ssat.manifest
10 BuildArch:      noarch
11
12 Requires:       bash
13
14 %description
15 SSAT provides testing environment for shell scripts with Apache-2.0 license.
16 This is created to avoid any complications related with GPL licenses.
17
18 %prep
19 %setup -q
20 cp %{SOURCE1001} .
21
22 %build
23 # DO NOTHING
24
25 %install
26 mkdir -p %{buildroot}%{_bindir}
27 install -p -m 0755 ssat.sh %{buildroot}%{_bindir}/
28 install -p -m 0644 ssat-api.sh %{buildroot}%{_bindir}/
29 pushd %{buildroot}%{_bindir}
30 ln -s ssat.sh ssat
31 popd
32
33 %files
34 %manifest ssat.manifest
35 %{_bindir}/ssat
36 %{_bindir}/ssat.sh
37 %{_bindir}/ssat-api.sh