Disable enable-dynamic-extensions flag
[platform/upstream/sqlite.git] / packaging / sqlite.spec
1 Name:           sqlite
2 Version:        3.18.0
3 Release:        0
4 License:        Public-Domain
5 %define tarversion 3180000
6 Summary:        Embeddable SQL Database Engine
7 Url:            http://www.sqlite.org/
8 Group:          System/Database
9 Source0:        sqlite-autoconf-%tarversion.tar.gz
10 Source1:        baselibs.conf
11 Source1001:     sqlite.manifest
12 BuildRequires:  readline-devel
13 BuildRequires:  pkgconfig(pkg-config)
14 Requires:       libsqlite = %{version}
15 Provides:       sqlite3
16
17 %description
18 SQLite is a C library that implements an embeddable SQL database
19 engine. Programs that link with the SQLite library can have SQL
20 database access without running a separate RDBMS process.
21
22 SQLite is not a client library used to connect to a big database
23 server. SQLite is a server and the SQLite library reads and writes
24 directly to and from the database files on disk.
25
26 SQLite can be used via the sqlite command line tool or via any
27 application that supports the Qt database plug-ins.
28
29 %package -n libsqlite
30 Summary:        Shared libraries for the Embeddable SQL Database Engine
31 Group:          System/Database
32 Provides:       libsqlit3
33
34 %description -n libsqlite
35 This package contains the shared libraries for the Embeddable SQL
36 Database Engine.
37
38 SQLite is a C library that implements an embeddable SQL database
39 engine. Programs that link with the SQLite library can have SQL
40 database access without running a separate RDBMS process.
41
42 SQLite is not a client library used to connect to a big database
43 server. SQLite is a server and the SQLite library reads and writes
44 directly to and from the database files on disk.
45
46 SQLite can be used via the sqlite command line tool or via any
47 application that supports the Qt database plug-ins.
48
49 %package devel
50 Summary:        Embeddable SQL Database Engine
51 Group:          Development/Libraries
52 Requires:       glibc-devel
53 Requires:       libsqlite = %{version}
54 Requires:       sqlite
55 Provides:       sqlite3-devel = %{version}
56 Obsoletes:      sqlite3-devel < %{version}
57
58 %description devel
59 SQLite is a C library that implements an embeddable SQL database
60 engine. Programs that link with the SQLite library can have SQL
61 database access without running a separate RDBMS process.
62
63 SQLite is not a client library used to connect to a big database
64 server; SQLite is the server. The SQLite library reads and writes
65 directly to and from the database files on disk.
66
67 SQLite can be used via the sqlite command-line tool or via any
68 application which supports the Qt database plug-ins.
69
70 %prep
71 %setup -q -n sqlite-autoconf-%tarversion
72 cp %{SOURCE1001} .
73
74 %build
75 CFLAGS=`echo %{optflags} |sed -e 's/-ffast-math//g'`
76 %{?asan:CFLAGS+=" -lpthread -ldl "}
77 chmod +x autogen.sh
78 %autogen
79 %configure -disable-dependency-tracking \
80     --enable-dynamic-extensions=no \
81         --enable-shared=yes \
82         --enable-static=no \
83         --enable-threadsafe \
84     --enable-fts5
85
86 make
87
88 %install
89 %make_install
90
91 %post -n libsqlite -p /sbin/ldconfig
92
93 %postun -n libsqlite -p /sbin/ldconfig
94
95 %files
96 %manifest %{name}.manifest
97 %defattr(-,root,root)
98 %{_bindir}/sqlite3
99
100 %files -n libsqlite
101 %manifest %{name}.manifest
102 %defattr(-,root,root)
103 %{_libdir}/libsqlite*.so.*
104
105 %files devel
106 %manifest %{name}.manifest
107 %defattr(-,root,root)
108 %{_includedir}/*.h
109 %{_libdir}/libsqlite*.so
110 %{_libdir}/pkgconfig/sqlite3.pc
111
112 %docs_package